Artigo: 942041 - Última revisão: terça-feira, 25 de Setembro de 2007 - Revisão: 1.0

Mensagem de erro quando tenta abrir uma página Web que está hospedada no IIS 7.0: "HTTP Erro - de 404.0 não encontrado"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta abrir uma página Web que esteja hospedada em Serviços de informação Internet (IIS) 7.0, poderá receber uma das seguintes mensagens de erro:
Mensagem de erro 1
Erro de servidor na aplicação "ApplicationName"

Erro de HTTP 404.0 - não encontrado

HResult: 0 x 80070002

Descrição de HResult: O recurso que procura para tiver sido removido, tinha o respectivo nome alterado ou está temporariamente indisponível.
Mensagem de erro 2
Erro de servidor na aplicação "ApplicationName"

Erro de HTTP 404.0 - não encontrado

HResult: 0x8007007e

Descrição de HResult: não foi possível encontrar o módulo especificado.

Causa

Mensagem de erro 1

Este problema ocorre por um ou mais das seguintes razões:
  • O directório especificado ou o ficheiro não existe no servidor Web.
  • O URL contém um erro de tipográficos.
  • Um filtro personalizado ou um módulo personalizado restringe o acesso ao ficheiro. O filtro ou no módulo envia a mensagem de erro "Erro de HTTP 404.0" novamente para o cliente como uma resposta.

Mensagem de erro 2

Este problema ocorre porque o recurso pedido está mapeado para um componente de rotina de tratamento que tem dependências noutros ficheiros. No entanto, estes ficheiros estão em falta ou inacessível.

Resolução

Mensagem de erro 1

Para resolver este problema, utilize um dos seguintes métodos:
  • Certifique-se que o recurso pedido está na localização que o URL aponta para.
  • Reveja o URL que abre no browser.
  • Certifique-se de que não existem filtros personalizados ou módulos restringir o acesso ao ficheiro que pretende procurar.

Mensagem de erro 2

Para resolver este problema, certifique-se de que quaisquer ficheiros de dependência que o componente de rotina de tratamento tem dependências em podem ser acedidos e que estão na localização correcta.

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Information Services 7.0
Palavras-chave: 
kbmt kbexpertiseadvanced kbtshoot kbprb KB942041 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 942041  (http://support.microsoft.com/kb/942041/en-us/ )