Cuando se abre una página Web escribiendo un URI de archivo en la barra de direcciones de Windows Internet Explorer 7 en un equipo basado en Windows Vista, la cadena de consulta desaparece después de la página Web se abre

Seleccione idioma Seleccione idioma
Id. de artículo: 942172 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo basado en Windows Vista, abrir una página Web escribiendo un identificador de recursos uniforme (URI) de archivo en la barra de direcciones de Windows Internet Explorer 7 en. Este URI de archivo contiene una cadena de consulta. Sin embargo, cuando se abra la página Web, la cadena de consulta desaparece de la barra de direcciones. Además, la consulta no está en el objeto documento.ubicación.

Por ejemplo, si abre una página Web escribiendo file:///c:/test.htm?p=1 en la barra de direcciones, la cadena de consulta desaparece de la barra de direcciones después de abrir la página Web.

Este problema se produce también si ejecuta un comando en un símbolo del sistema para abrir una página Web en uno de los equipos siguientes:
  • Un equipo basado en Windows XP que tiene instalado Internet Explorer 7
  • Un equipo basado en Windows Server 2003 que tiene instalado Internet Explorer 7
Por ejemplo, este problema también se produce si ejecuta el comando siguiente para abrir la página Web:
iexplore.exe file:///c:/test.htm?p=1

Causa

En Windows Vista, cuando escriba un URI de archivo en la barra de direcciones de una instancia de pocos derechos de Internet Explorer 7, Internet Explorer 7 inicia una instancia normal derechos de Internet Explorer 7 para controlar el URI de archivo. Para ello, Internet Explorer pasa el URI de archivo a la instancia normal derechos mediante una línea de comandos. En la línea de comandos, se quitan la fragmentos y consultas del URI de archivo. Por lo tanto, este problema se produce. Estos fragmentos y las consultas del URI de archivo también se quitan si ejecuta un comando para abrir la página Web en Windows XP o en Windows Server 2003.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Vista. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935791Cómo obtener el service pack más reciente de Windows Vista

Información de revisiones

Windows Vista

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Para instalar la revisión, debe tener instalado Internet Explorer 7.
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no sustituye a ninguna otro publicada previamente.
Registro de información
Para habilitar esta revisión, siga estos pasos.

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
  1. Haga clic en
    Contraer esta imagenAmpliar esta imagen
    the Start button
    Inicio , escriba regedit en el cuadro Iniciar búsqueda y, a continuación, presione ENTRAR .
  2. Busque y haga clic en la siguiente subclave del Registro:
    Explorer\Main\FeatureControl HKEY_CURRENT_USER\Software\Microsoft\Internet
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172 y, a continuación, presione ENTRAR .
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba iexplore.exe y, a continuación, presione ENTRAR .
  7. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  10. Escriba ieuser.exe y, a continuación, presione ENTRAR .
  11. Haga clic con el botón secundario del mouse en ieuser.exe y, a continuación, haga clic en Modificar .
  12. Escriba 1 y, a continuación, haga clic en Aceptar .
  13. Editor de registro de salida.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Vista, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Update.mumNo aplicable1,94613 De septiembre de 200712: 00No aplicable
X86_22ba0e076db1e980674d602d9f13643d_31bf3856ad364e35_6.0.6000.20679_none_5b03d9056456861a.manifestNo aplicable69513 De septiembre de 200712: 00No aplicable
X86_microsoft-windows-ieframe_31bf3856ad364e35_6.0.6000.20679_none_63031c04ca46c2a1.manifestNo aplicable829,59913 De septiembre de 200712: 00No aplicable
Ieframe.dll7.0.6000.206796,066,17613 De septiembre de 200702: 13x 86
Ieui.dll7.0.6000.20679180,73613 De septiembre de 200702: 13x 86
Windows Vista, versiones basadas en 64 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Amd64_22ba0e076db1e980674d602d9f13643d_31bf3856ad364e35_6.0.6000.20679_none_b72274891cb3f750.manifestNo aplicable69713 De septiembre de 200712: 00No aplicable
Amd64_2928ddff5b95d9a1bc7cde8dac1094b8_31bf3856ad364e35_6.0.6000.20679_none_e3ce32b301f21e40.manifestNo aplicable69913 De septiembre de 200712: 00No aplicable
Amd64_microsoft-windows-ieframe_31bf3856ad364e35_6.0.6000.20679_none_bf21b78882a433d7.manifestNo aplicable829,70313 De septiembre de 200712: 05No aplicable
Package_1_for_kb942172 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.2.0.mumNo aplicable1.79413 De septiembre de 200712: 00No aplicable
Package_2_for_kb942172 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.2.0.mumNo aplicable1,95713 De septiembre de 200712: 00No aplicable
Update.mumNo aplicable1,86913 De septiembre de 200712: 00No aplicable
Ieframe.dll7.0.6000.206797,068,16013 De septiembre de 200712: 03x 64
Ieui.dll7.0.6000.20679228,35213 De septiembre de 200712: 03x 64

Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Para instalar la revisión, debe tener Internet Explorer 7 y Windows XP Service Pack 2 instalado.
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no sustituye a ninguna otro publicada previamente.
Registro de información
Para habilitar esta revisión, siga estos pasos:
  1. Busque y haga clic en la siguiente subclave del Registro:
    Explorer\Main\FeatureControl HKEY_CURRENT_USER\Software\Microsoft\Internet
  2. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  3. Escriba FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172 y, a continuación, presione ENTRAR .
  4. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  5. Escriba iexplore.exe y, a continuación, presione ENTRAR .
  6. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  7. Escriba 1 y, a continuación, haga clic en Aceptar .
  8. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  9. Escriba ieuser.exe y, a continuación, presione ENTRAR .
  10. Haga clic con el botón secundario del mouse en ieuser.exe y, a continuación, haga clic en Modificar .
  11. Escriba 1 y, a continuación, haga clic en Aceptar .
  12. Editor de registro de salida.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP con SP2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Ieframe.dll7.0.6000.206816,066,17618 De septiembre de 200704: 10x 86

Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Para instalar la revisión, debe tener Internet Explorer 7 y Windows Server 2003 Service Pack 2 instalado.
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no sustituye a ninguna otro publicada previamente.
Registro de información
Para habilitar esta revisión, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    Explorer\Main\FeatureControl HKEY_CURRENT_USER\Software\Microsoft\Internet
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172 y, a continuación, presione ENTRAR .
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba iexplore.exe y, a continuación, presione ENTRAR .
  7. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  10. Escriba ieuser.exe y, a continuación, presione ENTRAR .
  11. Haga clic con el botón secundario del mouse en ieuser.exe y, a continuación, haga clic en Modificar .
  12. Escriba 1 y, a continuación, haga clic en Aceptar .
  13. Editor de registro de salida.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003 con SP2, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Ieframe.dll7.0.6000.206816,066,17618 De septiembre de 200715: 04x 86
Windows Server 2003 con SP2, versiones basadas en x 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ieframe.dll7.0.6000.206817,068,16018 De septiembre de 200705: 02x 64SP2No aplicable
Wieframe.dll7.0.6000.206816,066,17618 De septiembre de 200705: 02x 86SP2GUAU
Windows Server 2003 con SP2, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Ieframe.dll7.0.6000.2068111,708,92818 De septiembre de 200702: 09IA-64SP2No aplicable
Wieframe.dll7.0.6000.206816,066,17618 De septiembre de 200702: 10x 86SP2GUAU

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Windows Vista Service Pack 1.

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 942172 - Última revisión: viernes, 16 de mayo de 2008 - Versión: 5.1
La información de este artículo se refiere a:
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 in Windows Vista
Palabras clave: 
kbmt kbautohotfix kbvistasp1fix kbfix kbexpertisebeginner kbpubtypekc kbqfe kbhotfixserver KB942172 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 942172

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com