Lorsque vous ouvrez une page Web en tapant un URI de fichier dans la barre d'adresses Windows Internet Explorer 7 sur un ordinateur Windows Vista, la chaîne de requête disparaît après que la page Web s'ouvre

Traductions disponibles Traductions disponibles
Numéro d'article: 942172 - Voir les produits auxquels s'applique cet article
important Cet article contient des informations sur la modification du Registre. Assurez-vous de sauvegarder le Registre avant de le modifier. Vérifiez que vous connaissez comment restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows
Agrandir tout | Réduire tout

Sommaire

Symptômes

Sur un ordinateur Windows Vista, vous ouvrez une page Web en tapant URI un fichier Uniform Resource (IDENTIFIER) dans la barre d'adresses Windows Internet Explorer 7 dans. Cet URI de fichier contient une chaîne de requête. Toutefois, une fois la page Web ouverte, la chaîne de requête disparaît de la barre d'adresses. En outre, la requête n'est pas dans l'objet document.location.

Par exemple, si vous ouvrez une page Web en tapant file:///c:/test.htm?p=1 dans la barre d'adresses, la chaîne de requête disparaît à partir de la barre d'adresses après que la page Web s'ouvre.

Ce problème se produit également si vous exécutez une commande à une invite de commandes pour ouvrir une page Web sur un des ordinateurs suivants :
  • Un ordinateur Windows XP ayant installé Internet Explorer 7
  • Un ordinateur Windows Server 2003-basé ayant installé Internet Explorer 7
Par exemple, ce problème se produit également si vous exécutez la commande suivante pour ouvrir la page Web :
iexplore.exe file:///c:/test.htm?p=1

Cause

Dans Windows Vista, lorsque vous tapez un URI de fichier dans la barre d'adresses d'une instance droits faible d'Internet Explorer 7, Internet Explorer 7 démarre une instance normale-droits d'Internet Explorer 7 pour gérer l'URI du fichier. Pour ce faire, Internet Explorer transmet l'URI du fichier à l'instance de droits standard à l'aide d'une ligne de commande. Sur la ligne de commande, les fragments et le requêtes de l'URI de fichier sont supprimées. Par conséquent, ce problème se produit. Ces fragments et les requêtes de l'URI de fichier sont également supprimées si vous exécutez une commande pour ouvrir la page Web dans Windows XP ou Windows Server 2003.

Résolution

Informations sur le service pack

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows Vista. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
935791 Comment obtenir le dernier pack de service Windows Vista

Informations sur le correctif

Windows Vista

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.
Conditions préalables
Pour installer le correctif, vous faut Internet Explorer 7 est installé.
Demande de redémarrage
Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.
Informations sur le remplacement de correctif
Ce correctif ne remplace pas les autres correctifs précédemment publiés.
Registre informations
Pour activer ce correctif, procédez comme suit.

Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.
  1. Cliquez sur Démarrer
    Réduire cette imageAgrandir cette image
    the Start button
    , tapez regedit dans la zone Rechercher et appuyez sur ENTRÉE .
  2. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  4. Tapez FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172 et puis appuyez sur ENTRÉE .
  5. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  6. Tapez iexplore.exe , puis appuyez sur ENTRÉE .
  7. Cliquez avec le bouton droit sur iexplore.exe , puis cliquez sur Modifier .
  8. Tapez 1 , puis cliquez sur OK .
  9. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  10. Tapez ieuser.exe et puis appuyez sur ENTRÉE .
  11. Cliquez avec le bouton droit sur ieuser.exe , puis cliquez sur Modifier .
  12. Tapez 1 , puis cliquez sur OK .
  13. Quittez l'Éditeur du Registre.
Informations de fichier
La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows Vista, versions 86 x
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Update.mumNon applicable1,94613-Sep-200700 :Non applicable
X86_22ba0e076db1e980674d602d9f13643d_31bf3856ad364e35_6.0.6000.20679_none_5b03d9056456861a.manifestNon applicable69513-Sep-200700 :Non applicable
X86_microsoft-windows-ieframe_31bf3856ad364e35_6.0.6000.20679_none_63031c04ca46c2a1.manifestNon applicable829,59913-Sep-200700 :Non applicable
Ieframe.dll7.0.6000.206796,066,17613-Sep-200702:13x 86
Ieui.dll7.0.6000.20679180,73613-Sep-200702:13x 86
Windows Vista, versions 64 x
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Amd64_22ba0e076db1e980674d602d9f13643d_31bf3856ad364e35_6.0.6000.20679_none_b72274891cb3f750.manifestNon applicable69713-Sep-200700 :Non applicable
Amd64_2928ddff5b95d9a1bc7cde8dac1094b8_31bf3856ad364e35_6.0.6000.20679_none_e3ce32b301f21e40.manifestNon applicable69913-Sep-200700 :Non applicable
Amd64_microsoft-windows-ieframe_31bf3856ad364e35_6.0.6000.20679_none_bf21b78882a433d7.manifestNon applicable829,70313-Sep-200712:05Non applicable
Package_1_for_kb942172 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.2.0.mumNon applicable1,79413-Sep-200700 :Non applicable
Package_2_for_kb942172 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.2.0.mumNon applicable1,95713-Sep-200700 :Non applicable
Update.mumNon applicable1,86913-Sep-200700 :Non applicable
Ieframe.dll7.0.6000.206797,068,16013-Sep-200703:12x 64
Ieui.dll7.0.6000.20679228,35213-Sep-200703:12x 64

Windows XP

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.
Conditions préalables
Pour installer le correctif, il vous faut Internet Explorer 7 et Windows XP Service Pack 2.
Demande de redémarrage
Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.
Informations sur le remplacement de correctif
Ce correctif ne remplace pas les autres correctifs précédemment publiés.
Registre informations
Pour activer ce correctif, procédez comme suit :
  1. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  2. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  3. Tapez FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172 et puis appuyez sur ENTRÉE .
  4. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  5. Tapez iexplore.exe , puis appuyez sur ENTRÉE .
  6. Cliquez avec le bouton droit sur iexplore.exe , puis cliquez sur Modifier .
  7. Tapez 1 , puis cliquez sur OK .
  8. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  9. Tapez ieuser.exe et puis appuyez sur ENTRÉE .
  10. Cliquez avec le bouton droit sur ieuser.exe , puis cliquez sur Modifier .
  11. Tapez 1 , puis cliquez sur OK .
  12. Quittez l'Éditeur du Registre.
Informations de fichier
La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows XP avec Service Pack 2, x 86 versions
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ieframe.dll7.0.6000.206816,066,17618-Sep-200704:10x 86

Windows Server 2003

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.
Conditions préalables
Pour installer le correctif, il vous faut Internet Explorer 7 et Windows Server 2003 Service Pack 2 installé.
Demande de redémarrage
Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.
Informations sur le remplacement de correctif
Ce correctif ne remplace pas les autres correctifs précédemment publiés.
Registre informations
Pour activer ce correctif, procédez comme suit :
  1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  2. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  4. Tapez FEATURE_ACCEPT_QUERY_AND_FRAGMENT_OF_CMDLINE_FILE_URI_KB942172 et puis appuyez sur ENTRÉE .
  5. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  6. Tapez iexplore.exe , puis appuyez sur ENTRÉE .
  7. Cliquez avec le bouton droit sur iexplore.exe , puis cliquez sur Modifier .
  8. Tapez 1 , puis cliquez sur OK .
  9. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  10. Tapez ieuser.exe et puis appuyez sur ENTRÉE .
  11. Cliquez avec le bouton droit sur ieuser.exe , puis cliquez sur Modifier .
  12. Tapez 1 , puis cliquez sur OK .
  13. Quittez l'Éditeur du Registre.
Informations de fichier
La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows Server 2003 avec Service Pack 2, x 86 versions
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ieframe.dll7.0.6000.206816,066,17618-Sep-200704:15x 86
Windows Server 2003 avec Service Pack 2, versions 64 x
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeDemande de Service PackSuccursale de service
Ieframe.dll7.0.6000.206817,068,16018-Sep-200702:05x 64SERVICE PACK 2Non applicable
Wieframe.dll7.0.6000.206816,066,17618-Sep-200702:05x 86SERVICE PACK 2WOW
Windows Server 2003 avec Service Pack 2, versions Itanium
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeDemande de Service PackSuccursale de service
Ieframe.dll7.0.6000.2068111,708,92818-Sep-200702:09IA-64SERVICE PACK 2Non applicable
Wieframe.dll7.0.6000.206816,066,17618-Sep-200702:10x 86SERVICE PACK 2WOW

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ». Ce problème a été corrigé dans le Service Pack 1 pour Windows Vista.

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 942172 - Dernière mise à jour: vendredi 16 mai 2008 - Version: 5.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 in Windows Vista
Mots-clés : 
kbmt kbautohotfix kbvistasp1fix kbfix kbexpertisebeginner kbpubtypekc kbqfe kbhotfixserver KB942172 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 942172
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com