Mensaje de error cuando intenta mover o cambiar de tamaño una ventana en un equipo que tiene instalado Windows Internet Explorer 7: "Error en la secuencia de comandos de esta página"

Seleccione idioma Seleccione idioma
Id. de artículo: 942173 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo que tiene instalado Windows Internet Explorer 7, intenta utilizar una operación de arrastre para mover o cambiar el tamaño una ventana de Internet Explorer o la ventana de otra aplicación. Sin embargo, recibirá el siguiente mensaje de error:
Se ha producido un error en la secuencia de comandos de esta página
Línea: LineNumber
Char: CharacterNumber
Error: Acceso denegado.
Código: 0
Dirección URL: URL
Este problema se produce si una secuencia de comandos en la ventana ejecuta el método windows.resizeTo o el método windows.moveTo cuando intenta mover o cambiar el tamaño de la ventana.

Causa

Este problema se produce debido a un cambio de diseño. Este cambio de diseño ayuda a mejorar la seguridad en el equipo bloqueando cualquier mover o cambiar el tamaño de las funciones.

Windows utiliza una secuencia de comandos para bloquear estas funciones cuando el botón del mouse está presionado. Si el botón del mouse está presionado, Windows considera la operación una operación de arrastre. Windows bloquea cualquier mover o cambiar el tamaño de las funciones. Este comportamiento ayuda a impedir que un atacante transferir archivos malintencionados al equipo.

Solución

Hay una revisión resolver este problema. Después de aplicar la revisión, debe agregar la entrada de registro FEATURE_MOVERESIZE_ACCESSDENIED_KB942173. A continuación, aplicar esta entrada del registro a la aplicación. Al hacerlo, la aplicación no está restringida por el cambio de diseño relacionados con la seguridad.

Windows Vista

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Vista. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935791Cómo obtener el service pack más reciente de Windows Vista

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado Internet Explorer 7.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ninguna otro publicada previamente.

Registro de información

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para habilitar la revisión de la aplicación, siga estos pasos:
  1. Haga clic en Inicio , escriba regedit en el cuadro Iniciar búsqueda y, a continuación, presione ENTRAR.
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_MOVERESIZE_ACCESSDENIED_KB942173 y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en FEATURE_MOVERESIZE_ACCESSDENIED_KB942173 , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba ProcessName y, a continuación, presione ENTRAR.

    Nota ProcessName representa el nombre de proceso de la aplicación. Por ejemplo, si desea mover o cambiar el tamaño la ventana de una aplicación HTML, escriba mshta.exe .
  7. Haga clic con el botón secundario del mouse en el valor DWORD ProcessName y, a continuación, haga clic en Modificar .
  8. En el cuadro datos del valor , escriba 0 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Vista, versiones de 86 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Update.mumNo aplicable1,95512 De septiembre de 200716: 23No aplicable
X86_bb225861cc7ae02b31da3880fadda23f_31bf3856ad364e35_6.0.6000.20678_none_1b3b71b0d4600536.manifestNo aplicable70412 De septiembre de 200716: 23No aplicable
X86_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_6.0.6000.20678_none_11a2c1b73e521b1d.manifestNo aplicable928,49412 De septiembre de 200716: 23No aplicable
Mshtml.dll7.0.6000.206783,593,21612 De septiembre de 200702: 26x 86
Mshtml.tlb7.0.6000.206781,383,42411 De septiembre de 200723: 56No aplicable
Windows Vista, versiones de 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Amd64_2307a15376bbc6073fbb4b021df7d753_31bf3856ad364e35_6.0.6000.20678_none_c3e4e58e87be7aa5.manifestNo aplicable70812 De septiembre de 200716: 23No aplicable
Amd64_bb225861cc7ae02b31da3880fadda23f_31bf3856ad364e35_6.0.6000.20678_none_775a0d348cbd766c.manifestNo aplicable70612 De septiembre de 200716: 23No aplicable
Amd64_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_6.0.6000.20678_none_6dc15d3af6af8c53.manifestNo aplicable928,55512 De septiembre de 200716: 27No aplicable
Package_1_for_kb942173 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNo aplicable1,80312 De septiembre de 200716: 23No aplicable
Package_2_for_kb942173 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNo aplicable1,96612 De septiembre de 200716: 23No aplicable
Update.mumNo aplicable1,86912 De septiembre de 200716: 23No aplicable
Mshtml.dll7.0.6000.206785,680,12812 De septiembre de 200703: 27x 64
Mshtml.tlb7.0.6000.206781,383,42411 De septiembre de 200723: 51No aplicable

Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Internet Explorer 7 y Windows Server 2003 Service Pack 2 (SP2) instalado.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ninguna otro publicada previamente.

Registro de información

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para habilitar la revisión de la aplicación, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_MOVERESIZE_ACCESSDENIED_KB942173 y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en FEATURE_MOVERESIZE_ACCESSDENIED_KB942173 , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba ProcessName y, a continuación, presione ENTRAR.

    Nota ProcessName representa el nombre de proceso de la aplicación. Por ejemplo, si desea mover o cambiar el tamaño la ventana de una aplicación HTML, escriba mshta.exe .
  7. Haga clic con el botón secundario del mouse en el valor DWORD ProcessName y, a continuación, haga clic en Modificar .
  8. En el cuadro datos del valor , escriba 0 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003 con SP2, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Mshtml.dll7.0.6000.206783,593,21613 De septiembre de 200717: 46x 86
Windows Server 2003 con SP2, versiones basadas en x 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Mshtml.dll7.0.6000.206785,680,12813 De septiembre de 200716: 17x 64SP2No aplicable
Wmshtml.dll7.0.6000.206783,593,21613 De septiembre de 200716: 18x 86SP2GUAU
Windows Server 2003 con SP2, versiones basadas en IA64
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Mshtml.dll7.0.6000.2067810,055,68013 De septiembre de 200716: 15IA-64SP2No aplicable
Tabla de OneNote de contents.onetoc2No aplicable4,74426 De septiembre de 200702: 39No aplicableSP2No aplicable
Tabla de OneNote de contents.onetoc2No aplicable3,65626 De septiembre de 200702: 39No aplicableSP2GUAU
Wmshtml.dll7.0.6000.206783,593,21613 De septiembre de 200716: 15x 86SP2GUAU

Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Internet Explorer 7 y Windows XP Service Pack 2 (SP2).

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ninguna otro publicada previamente.

Registro de información

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para habilitar la revisión de la aplicación, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_MOVERESIZE_ACCESSDENIED_KB942173 y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en FEATURE_MOVERESIZE_ACCESSDENIED_KB942173 , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba ProcessName y, a continuación, presione ENTRAR.

    Nota ProcessName representa el nombre de proceso de la aplicación. Por ejemplo, si desea mover o cambiar el tamaño la ventana de una aplicación HTML, escriba mshta.exe .
  7. Haga clic con el botón secundario del mouse en el valor DWORD ProcessName y, a continuación, haga clic en Modificar .
  8. En el cuadro datos del valor , escriba 0 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP con SP2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Mshtml.dll7.0.6000.206783,593,21613 De septiembre de 200715: 23x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Windows Vista Service Pack 1.

Más información

Para obtener más información acerca del método moveTo , visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
http://msdn2.microsoft.com/en-us/library/ms536626.aspx
Para obtener más información sobre el método resizeTo , visite el siguiente sitio Web de MSDN:
http://msdn2.microsoft.com/en-us/library/ms536723.aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
904947Puede recibir un mensaje "Acceso denegado" cuando intenta mover o cambiar el tamaño una ventana en un equipo basado en Windows Server 2003 S o basado en Windows XP S
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 942173 - Última revisión: viernes, 16 de mayo de 2008 - Versión: 2.1
La información de este artículo se refiere a:
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 in Windows Vista
Palabras clave: 
kbmt kbautohotfix kbvistasp1fix kbfix kbexpertisebeginner kbpubtypekc kbqfe kbhotfixserver KB942173 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 942173

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com