Talvolta i livelli semitrasparenti attivare grigio quando si Sfoglia una pagina di Web contenente livelli semitrasparenti utilizzando Internet Explorer 7

Traduzione articoli Traduzione articoli
Identificativo articolo: 942174 - Visualizza i prodotti a cui si riferisce l?articolo.
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322756Come eseguire il backup e il ripristino del Registro di sistema in Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Lo sviluppo di una pagina Web che contiene livelli semitrasparenti. Nella pagina Web, Ŕ possibile utilizzare la proprietÓ Filter per regolare l'opacitÓ dei livelli semitrasparenti. Quando si visualizza la pagina Web utilizzando Internet Explorer 7, i livelli semitrasparenti attivare in modo intermittente grigio.

Cause

Questo problema si verifica a causa di una condizione di competizione in Internet Explorer. Questa condizione di competizione si verifica quando due thread chiama contemporaneamente la funzione SelectObject sull'handle GDI a Windows HBITMAP .

Risoluzione

Informazioni sul Windows Vista service pack

Per risolvere il problema, ottenere il service pack pi¨ recente per Windows Vista. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
935791Come ottenere il service pack pi¨ recente per Windows Vista

Informazioni sull'hotfix per Windows Vista

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per installare l'hotfix, Ŕ necessario Internet Explorer 7 installato.

NecessitÓ di riavvio

Non Ŕ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.

Registro di sistema informazioni

avviso Pu˛ causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.

Per utilizzare questo aggiornamento rapido (hotfix), attenersi alla seguente procedura:
  1. Fare clic su Start , digitare regedit nella casella Inizia ricerca e quindi premere INVIO.
  2. Individuare la seguente sottochiave del Registro di sistema e quindi fare clic su:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Scegliere Nuovo dal menu Modifica , quindi chiave .
  4. Digitare FEATURE_IMAGING_MULTITHREAD_PROTECTION_WHEN_OPTIMIZED_KB942174 e quindi premere INVIO .
  5. Fare clic con il pulsante destro del mouse su FEATURE_IMAGING_MULTITHREAD_PROTECTION_WHEN_OPTIMIZED_KB942174 , scegliere Nuovo , quindi Valore DWORD .
  6. Digitare iexplore.exe e quindi premere INVIO .
  7. Fare clic con il pulsante destro del mouse su iexplore.exe e quindi fare clic su Modifica .
  8. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  9. Uscire dall'editor del Registro di sistema.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Vista, versioni basate su 86 su x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Update.mumNon applicabile1,95512-09-200715: 12Non applicabile
X86_bb225861cc7ae02b31da3880fadda23f_31bf3856ad364e35_6.0.6000.20678_none_1b3b71b0d4600536.manifestNon applicabile70412-09-200715: 12Non applicabile
X86_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_6.0.6000.20678_none_11a2c1b73e521b1d.manifestNon applicabile928,49412-09-200715: 13Non applicabile
Mshtml.dll7.0.6000.206783,593,21612-09-200702: 26x 86
Mshtml.tlb7.0.6000.206781,383,42411-09-200723: 56Non applicabile
Windows Vista, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Amd64_2307a15376bbc6073fbb4b021df7d753_31bf3856ad364e35_6.0.6000.20678_none_c3e4e58e87be7aa5.manifestNon applicabile70812-09-200715: 13Non applicabile
Amd64_bb225861cc7ae02b31da3880fadda23f_31bf3856ad364e35_6.0.6000.20678_none_775a0d348cbd766c.manifestNon applicabile70612-09-200715: 13Non applicabile
Amd64_microsoft-windows-ie-htmlrendering_31bf3856ad364e35_6.0.6000.20678_none_6dc15d3af6af8c53.manifestNon applicabile928,55512-09-200715: 17Non applicabile
Package_1_for_kb942174 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNon applicabile1,80312-09-200715: 13Non applicabile
Package_2_for_kb942174 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.0.1.0.mumNon applicabile1,96612-09-200715: 13Non applicabile
Update.mumNon applicabile1,86912-09-200715: 13Non applicabile
Mshtml.dll7.0.6000.206785,680,12812-09-200703: 27x 64
Mshtml.tlb7.0.6000.206781,383,42411-09-200723: 51Non applicabile

Informazioni sull'hotfix per Windows XP

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per installare l'hotfix, Ŕ necessario Internet Explorer 7 e Windows XP Service Pack 2.

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.

Registro di sistema informazioni

avviso Pu˛ causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.

Per utilizzare questo aggiornamento rapido (hotfix), attenersi alla seguente procedura:
  1. Fare clic su Start , digitare regedit nella casella Inizia ricerca e quindi premere INVIO.
  2. Individuare la seguente sottochiave del Registro di sistema e quindi fare clic su:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Scegliere Nuovo dal menu Modifica , quindi chiave .
  4. Digitare FEATURE_IMAGING_MULTITHREAD_PROTECTION_WHEN_OPTIMIZED_KB942174 e quindi premere INVIO .
  5. Fare clic con il pulsante destro del mouse su FEATURE_IMAGING_MULTITHREAD_PROTECTION_WHEN_OPTIMIZED_KB942174 , scegliere Nuovo , quindi Valore DWORD .
  6. Digitare iexplore.exe e quindi premere INVIO .
  7. Fare clic con il pulsante destro del mouse su iexplore.exe e quindi fare clic su Modifica .
  8. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  9. Uscire dall'editor del Registro di sistema.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows XP con SP2, versioni 86 e x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll7.0.6000.206783,593,21613-09-200716: 06x 86

Informazioni sull'hotfix per Windows Server 2003

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per installare l'hotfix, Ŕ necessario Internet Explorer 7 e Windows Server 2003 Service Pack 2.

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.

Registro di sistema informazioni

avviso Pu˛ causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.

Per utilizzare questo aggiornamento rapido (hotfix), attenersi alla seguente procedura:
  1. Fare clic su Start , digitare regedit nella casella Inizia ricerca e quindi premere INVIO.
  2. Individuare la seguente sottochiave del Registro di sistema e quindi fare clic su:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Scegliere Nuovo dal menu Modifica , quindi chiave .
  4. Digitare FEATURE_IMAGING_MULTITHREAD_PROTECTION_WHEN_OPTIMIZED_KB942174 e quindi premere INVIO .
  5. Fare clic con il pulsante destro del mouse su FEATURE_IMAGING_MULTITHREAD_PROTECTION_WHEN_OPTIMIZED_KB942174 , scegliere Nuovo , quindi Valore DWORD .
  6. Digitare iexplore.exe e quindi premere INVIO .
  7. Fare clic con il pulsante destro del mouse su iexplore.exe e quindi fare clic su Modifica .
  8. Nella casella dati valore digitare 1 e quindi fare clic su OK .
  9. Uscire dall'editor del Registro di sistema.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Server 2003 con SP2, versioni 86 e x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll7.0.6000.206783,593,21613-09-200716: 54x 86
Windows Server 2003 con SP2, versioni x 64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Mshtml.dll7.0.6000.206785,680,12813-09-200715: 47x 64SP2Non applicabile
Wmshtml.dll7.0.6000.206783,593,21613-09-200715: 48x 86SP2WOW
Windows Server 2003 con SP2, versioni basate su IA64
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRequisiti SPRamo del servizio
Mshtml.dll7.0.6000.2067810,055,68013-09-200715: 44IA-64SP2Non applicabile
Wmshtml.dll7.0.6000.206783,593,21613-09-200715: 44x 86SP2WOW

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema Ŕ stato innanzitutto corretto in Windows Vista Service Pack 1.

Informazioni

In Internet Explorer, due thread utilizzare livelli semitrasparente. Questi thread sono thread dell'interfaccia utente e l'immagine di decodifica del thread.

L'immagine di decodifica thread consente di ottimizzare l'immagine in una funzione di PatBlt colore unico. Questo thread determina il colore mediante chiamata di alla funzione SelezionaOggetto sull'oggetto HBITMAP .

Allo stesso tempo, il thread dell'interfaccia utente disegna l'immagine. Inoltre, questo thread determina il colore mediante chiamata di alla funzione SelezionaOggetto sull'oggetto HBITMAP .

Tuttavia, Ŕ possibile selezionare l'oggetto HBITMAP solo nel contesto di una periferica (DC). Pertanto, uno dei due chiamate alla funzione SelectObject non riesce. Se il thread di decodifica non chiama la funzione SelectObject , il colore a tinta unita diventa il valore non corretto. Il colore a tinta unita viene utilizzato per la funzione PatBlt per eseguire operazioni di disegno future.

Per ulteriori informazioni sulla proprietÓ di stile , visitare il sito di Web di Microsoft:
http://msdn2.microsoft.com/en-us/library/ms532941.aspx
Per informazioni della proprietÓ Filter , visitare il sito di Web di Microsoft:
http://msdn2.microsoft.com/en-us/library/ms532847.aspx
Per ulteriori informazioni sulla funzione SelectObject , visitare il sito di Web di Microsoft:
http://msdn2.microsoft.com/en-us/library/ms533272.aspx
Per ulteriori informazioni sulla funzione PatBlt , visitare il sito di Web di Microsoft:
http://msdn2.microsoft.com/en-us/library/ms532568.aspx
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 942174 - Ultima modifica: giovedý 15 maggio 2008 - Revisione: 2.1
Le informazioni in questo articolo si applicano a:
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 in Windows Vista
Chiavi:á
kbmt kbautohotfix kbvistasp1fix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB942174 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 942174
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com