Article ID: 942283 - Last Review: October 25, 2007 - Revision: 1.3

Error message when you try to view EDI reports in the HAT tool in BizTalk Server 2006 R2: "An error occurred in accessing the EDI database"

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SYMPTOMS

When you try to view Electronic Data Interchange (EDI) reports in the Health and Activity Tracking (HAT) tool in Microsoft BizTalk Server 2006 R2, you may receive an error message that resembles the following:
Health and Activity Tracking

An error occurred in accessing the EDI database. Make sure that SQL Server is running and that you have network connectivity to the server and that you have rights to access the database.

Cannot open database "BizTalkEDIDb" requested by the login. The login failed. Login failed for user 'domain\user'.

CAUSE

The BizTalkEDIDb database is not created when you perform a clean installation of BizTalk Server 2006 R2 and then configure BizTalk Server. However, the link to view EDI reports may still be present in the HAT tool.

WORKAROUND

To work around this issue, use the BizTalk Server 2006 Administration Console Group Hub to view EDI and AS2 reporting data. To do this, follow these steps:
  1. Start the BizTalk Server 2006 Administration Console.
  2. Expand BizTalk Server Administration, and then click the group that you want.
  3. In the EDI Status Reports section of the Group Hub page, click one of the following links:
    • EDI Interchange and Correlated ACK Status
    • Batch Status
    • Interchange Aggregation Report
    • Transaction Set Aggregation Report

APPLIES TO
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Branch Edition
Keywords: 
kbbtshat kbbts kbtshoot kbprb KB942283
 

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