Article ID: 942284 - Last Review: April 1, 2009 - Revision: 2.0

A BizTalk Service service may not start as expected when you restart a computer that is running Windows Vista or Windows Server 2008

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SYMPTOMS

In Microsoft BizTalk Server, a BizTalk Service service may not start as expected when you restart a computer that is running Windows Vista or Windows Server 2008. Additionally, the following errors may be logged in the System log.

Error 1
Log Name: System
Source: Service Control Manager
Event ID: 7001
Task Category: None
Level: Error
Keywords: Classic
Description:
The BizTalk Service BizTalk Group : BizTalkServerApplication service depends on the Enterprise Single Sign-On Service service which failed to start because of the following error: After starting, the service hung in a start-pending state.
Error 2
Log Name: System
Source: Service Control Manager
Event ID: 7022
Task Category: None
Level: Error
Keywords: Classic
Description:
The Enterprise Single Sign-On Service service hung on starting.
This issue may occur when the startup type for the BizTalk Service service is set to Automatic.

CAUSE

This issue occurs when the Enterprise Single Sign-on service does not start as quickly as expected. Because BizTalk Service services depend on the Enterprise Single Sign-on service, the BizTalk Service service in question does not start as expected.

RESOLUTION

To resolve this issue, configure the Enterprise Single Sign-on service and each BizTalk Service service to use the Automatic (Delayed Start) startup type. To do this, follow these steps:
  1. Click Start, type services in the Start Search box, and then select Services in the Programs list. If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
  2. Under Name, right-click Enterprise Single Sign-on Service, and then click Properties.
  3. In the Startup type box, click Automatic (Delayed Start), and then click OK.
  4. Under Name, right-click a BizTalk Service service, and then click Properties.
  5. In the Startup type box, click Automatic (Delayed Start), and then click OK.
  6. Repeat steps 4 and 5 for any remaining BizTalk Service services.

APPLIES TO
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Branch Edition
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