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BizTalk RFID logging data may be lost in BizTalk Server 2006 R2

Article ID:942285
Last Review:October 25, 2007
Revision:1.4
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SYMPTOMS

Consider the following scenario:
You install Microsoft BizTalk Server 2006 R2.
You install Microsoft BizTalk RFID.
You use the BizTalk RFID service to process BizTalk RFID data. BizTalk RFID logging data is stored in the Rfidservices.log file.
The Rfidservices.log file reaches the maximum size. The Rfidservices.log file is renamed as Rfidservices_1.log. Then, a new Rfidservices.log file is created to store BizTalk RFID logging data.
The BizTalk RFID service is restarted. The current Rfidservices.log file is backed up to a file that is named Rfidservices_date_time.log, and a new Rfidservices.log file is created to store BizTalk RFID logging data.

Note The placeholder date represents the date in the form "dd_MMM_yy." The placeholder time represents the time in the form "HH_mm_ss."
The Rfidservices.log file reaches the maximum size. The Rfidservices.log file is renamed as Rfidservices_1.log. Then, a new Rfidservices.log file is created to store BizTalk RFID logging data.
In this scenario, logging data may be lost when the existing Rfidservices_1.log file is overwritten.

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CAUSE

This issue occurs because the rotated log files are not backed up when the BizTalk RFID service is restarted. For example, the Rfidservices_1.log file is not backed up when the BizTalk RFID service is restarted.

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WORKAROUND

To work around this issue, use one of the following methods.

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Method 1: Manually back up the BizTalk RFID log files

Manually back up the BizTalk RFID log files regularly.

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Method 2: Increase the maximum log file size

If the BizTalk RFID service is restarted regularly, you may be able to work around this issue by increasing the maximum size of the Rfidservices.log file. To do this, follow these steps:
1.Start RFID Manager.
2.Right-click the server, and then click Properties.
3.Click Logging.
4.In the Log size box, type a maximum log file size appropriate for your configuration, and then click OK.

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Method 3: Increase the maximum log file size and the maximum number of log files

If the BizTalk RFID service is not restarted regularly, you may be able to work around this issue by increasing the maximum size of the Rfidservices.log file and by increasing the maximum number of log files. To do this, follow these steps:
1.Start RFID Manager.
2.Right-click the server, and then click Properties.
3.Click Logging.
4.In the Log size box, type a maximum log file size appropriate for your configuration.
5.In the No. of log files box, type a maximum number of log files, and then click OK.

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STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

In BizTalk RFID, the following features are used when logged data is backed up:
Log file backup
The current BizTalk RFID log file (Rfidservices.log) is backed up every time that the BizTalk RFID service is restarted. When the BizTalk RFID service is restarted, the current Rfidservices.log file is backed up to a file that is named Rfidservices_date_time.log.

Note The placeholder date represents the date in the form "dd_MMM_yy." The placeholder time represents the time in the form "HH_mm_ss."
Log file rotation
The current Rfidservices.log file is renamed when the maximum log file size is reached. For example, if the maximum log file size is reached, the Rfidservices.log file is renamed as Rfidservices_1.log, and a new Rfidservices.log file is created.
By configuring the maximum log file size and the maximum number of log files, you can control the disk space that is used by BizTalk RFID log files. However, rotated log files such as Rfidservices_1.log are not backed up when the BizTalk RFID service is restarted.

You must consider your configuration when you use the methods that are mentioned in the "Workaround" section. For example, consider how frequently the BizTalk RFID service is restarted and how much logging occurs in your configuration.

If the BizTalk RFID service is restarted regularly, you may be able to work around this issue by increasing the maximum size of the log file. If the BizTalk RFID service is not restarted regularly, you may want to increase both the maximum log file size and the maximum number of log files. However, you may also want to manually back up the RFID log files.

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APPLIES TO
Microsoft BizTalk Server 2006 R2 Standard Edition
Microsoft BizTalk Server 2006 R2 Enterprise Edition
Microsoft BizTalk Server 2006 R2 Developer Edition
Microsoft BizTalk Server 2006 R2 Branch Edition

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Keywords: 
kbtshoot kbprb kbbts KB942285

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