Recibe un mensaje de error al intentar aplicar una revisión o actualización: "Error 9002. No se puede instalar la revisión de Microsoft Visual Studio .NET 2003 (KBxxxxxx) porque tiene una o más revisiones instaladas. Quítelas e inténtelo de nuevo".

Seleccione idioma Seleccione idioma
Id. de artículo: 942380 - Ver los productos a los que se aplica este artículo
Importante: este artículo contiene información acerca de cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo realizar una copia de seguridad, modificar y restaurar el Registro en Windows XP y Windows Server 2003
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta aplicar una revisión o una actualización, puede recibir un mensaje de error similar al siguiente:
"Error 9002. No se puede instalar la revisión de Microsoft Visual Studio .NET 2003 (KBxxxxxx) porque tiene una o más revisiones instaladas. Quítelas e inténtelo de nuevo.
Puede recibir este mensaje de error al intentar aplicar una revisión o una actualización para cualquiera de los productos siguientes:
  • Microsoft .NET Framework 1.1 o .NET Framework 1.0
  • Microsoft Visual Studio .NET 2003 o Visual Studio .NET 2002

Causa

Este problema puede producirse debido a lo siguiente:
  • Ha aplicado una revisión sin combinar para el producto.

    Una revisión sin combinar es una revisión o una actualización que no se incluirá en un Service Pack o en el lanzamiento de un producto. Este tipo de corrección está pensado para resolver un problema concreto que un cliente tiene con un producto. Sin embargo, esta corrección no es adecuada para su uso en general.
  • Ha aplicado una actualización que le impide intencionadamente aplicar una revisión o una actualización.

    Algunas actualizaciones bloquean intencionadamente otras actualizaciones por razones técnicas como dependencias entre actualizaciones.

Solución

Como solución alternativa a este problema, utilice uno de los métodos siguientes.

Método 1

Quite la revisión o la actualización que está bloqueando la revisión o la actualización que está intentando aplicar.

Normalmente puede quitar una revisión o una actualización utilizando el elemento Agregar o quitar programas del Panel de control. Para averiguar qué revisión o actualización debe quitar, siga estos pasos:
  1. Abra el registro de Windows Installer (.msi) correspondiente a la revisión o la actualización que no pudo aplicar. Si no tiene el registro, o si no puede encontrarlo, utilice el comando siguiente para intentar aplicar de nuevo la revisión o la actualización:
    nombreDeRevisiónOActualización.exe /L:nombreDelRegistro.log
  2. En el archivo de registro que buscó o creó en el paso 1, busque la línea que contiene un texto similar al siguiente:
    DDPatch:M937058.BlockingPatches=U822550;U832138;U8321381031;U842936;U883661;U8321381036
    Los números corresponden a las revisiones o actualizaciones que causan el bloqueo. Los números empiezan con una U o con una M.

    Si no puede encontrar en el registro ninguna revisión o actualización que produzca bloqueos, vaya al paso 4.
  3. Utilice el elemento Agregar o quitar programas del Panel de control para quitar todas las revisiones y actualizaciones que aparecen en la lista que buscó en el paso 2. A continuación, intente de nuevo aplicar la revisión o la actualización que intentó aplicar cuando experimentó este problema.
  4. Si no puede encontrar en el registro ninguna revisión o actualización que produzca bloqueos, examine la lista del elemento Agregar o quitar programas del Panel de control para determinar qué revisión o actualización debe quitar. Para ello, siga estos pasos:
    1. Abra el elemento Agregar o quitar programas del Panel de control.
    2. Busque todas las revisiones y actualizaciones que correspondan al producto que está intentando actualizar.
    3. Quite la revisión o la actualización que aplicó en último lugar. Si ha aplicado varias revisiones y actualizaciones, y no sabe qué revisión o actualización aplicó en último lugar, puede empezar por quitar la revisión o la actualización que tenga el número más alto.
    4. Después de quitar la revisión o la actualización, intente aplicar la revisión o la actualización que intentaba aplicar cuando experimentó este problema. Si sigue experimentando el problema, repita el paso c para quitar la siguiente revisión o actualización más reciente. Después, intente aplicar de nuevo la revisión o la actualización que intentaba aplicar cuando experimentó este problema.
    Nota: quizás tenga que repetir los pasos c y d para varias revisiones y actualizaciones antes de poder aplicar correctamente la revisión o la actualización que intentaba aplicar cuando experimentó este problema.

Método 2

Advertencia: pueden producirse problemas graves si modifica incorrectamente el Registro mediante el Editor del Registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Quite la entrada del Registro que indica la presencia de la revisión o la actualización que produce bloqueos. En la tabla siguiente se enumeran las claves del Registro correspondientes a los productos mencionados en la sección "Síntomas".
Contraer esta tablaAmpliar esta tabla
Número Producto Clave del Registro
1 Microsoft .NET Framework 1.0
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\.NETFramework\1.0
2 Microsoft .NET Framework 1.1
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\.NETFramework\1.1
3 Microsoft Visual Studio .NET 2002
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Visual Studio\7.0
4 Microsoft Visual Studio .NET 2003
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Visual Studio\7.1
Para quitar la entrada del Registro que indica la presencia de la revisión o la actualización que produce el bloqueo, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit.exe y haga clic en Aceptar.
  2. Según el producto para el que está intentando aplicar una revisión o una actualización, determine la clave del Registro asociada de la tabla mostrada previamente.
  3. En el Editor del Registro, busque la clave del Registro apropiada.
  4. Busque la entrada del Registro correspondiente a la revisión o la actualización que produce el bloqueo. Para obtener información acerca de cómo determinar la revisión o la actualización para la que debe quitar la entrada del Registro, vea los pasos 1 y 2 del método 1.
    • Ejemplo 1:
      Está intentando aplicar la actualización 937058 para Microsoft Visual Studio .NET 2003. Sin embargo, la actualización está bloqueada porque previamente aplicó la actualización 842936. En esta situación, debe buscar una de las claves del Registro siguientes:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Visual Studio\7.1\M842936

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Visual Studio\7.1\U842936
    • Ejemplo 2:
      Está intentando aplicar la actualización 928367 para Microsoft .NET Framework 1.0. Sin embargo, la actualización está bloqueada porque previamente aplicó la actualización 886906. En esta situación, debe buscar una de las claves del Registro siguientes:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\.NETFramework\1.0\M886906

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\.NETFramework\1.0\U886906
  5. Cuando encuentre la clave del Registro adecuada, haga clic con el botón secundario en ella y, a continuación, haga clic en Eliminar. Por ejemplo, haga clic con el botón secundario en M842936.
  6. Salga del Editor del Registro.
Para obtener más información acerca de una revisión sin combinar que ha aplicado previamente, o acerca de una actualización que está bloqueada por una revisión o una actualización aplicada previamente, póngase en contacto con los Servicios de soporte técnico de Microsoft. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS

Propiedades

Id. de artículo: 942380 - Última revisión: lunes, 03 de diciembre de 2007 - Versión: 1.4
La información de este artículo se refiere a:
  • Microsoft .NET Framework 1.1 Service Pack 1
  • Microsoft .NET Framework 1.0 Service Pack 3
  • Microsoft Visual Studio .NET 2003 Service Pack 1 sobre las siguientes plataformas
    • Microsoft Visual Studio .NET 2003 Professional
    • Microsoft Visual Studio .NET 2003 Enterprise Architect
    • Microsoft Visual Studio .NET 2003 Enterprise Developer
    • Microsoft Visual Studio .NET 2003 Academic Edition
    • Microsoft Visual Basic .NET 2003 Standard Edition
    • Microsoft Visual C++ .NET 2003 Standard
    • Microsoft Visual C# .NET 2003 Standard Edition
    • Microsoft Visual J# .NET 2003 Standard Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition SP1
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2002 Professional sobre las siguientes plataformas
    • Microsoft Visual Basic .NET 2002 Standard Edition
    • Microsoft Visual C# .NET 2002 Standard Edition
    • Microsoft Visual C++ .NET 2002 Standard
Palabras clave: 
kbtshoot kbexpertisebeginner kbexpertiseinter kbexpertiseadvanced kbsecurity kbbug kbpubtypekc KB942380

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com