Não pode ver informações de certificados no Windows Internet Explorer 7 ou no Gestor de certificados se utilizar um ficheiro de resposta automática para instalar o Windows Vista

Traduções de Artigos Traduções de Artigos
Artigo: 942543 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Depois de importar um certificado num computador baseado no Windows Vista com êxito, não pode ver as informações do certificado no Windows Internet Explorer 7 ou no Gestor de certificados.

Causa

Este problema ocorre se não tiver permissões de leitura para a seguinte subchave de registo:
HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\ProtectedRoots
Este problema ocorre caso se verifiquem as seguintes condições:
  • Utilizou um processo de configuração automática para instalar o Windows Vista.
  • O ficheiro de resposta automática (Autounattend.xml) inclui o seguinte código:
    <copyprofile> true </copyprofile>
  • A imagem do sistema operativo foi resealed utilizando o comando sysprep generalize .
Neste cenário, o utilizador que executa o Assistente fora do Box Experience (OOBE) não está atribuído permissões de leitura para a chave de registo ProtectedRoots. Em vez disso, a conta de administrador é atribuída permissões de leitura para esta chave. No entanto, as informações de certificado que são apresentadas no Internet Explorer 7 ou no Gestor de certificados são armazenadas na chave de registo ProtectedRoots. Assim, o utilizador com sessão iniciada actualmente no computador não é possível visualizar as informações do certificado.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Windows Vista. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
935791Como obter o Windows Vista service pack mais recente

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui uma correcção disponibilizada anteriormente.

Informações sobre instalação de correcções

Para se certificar de que o perfil de utilizador que tem actualmente sessão iniciada substitui o perfil de utilizador predefinido, defina a tag CopyProfile como VERDADEIRO. Esta correcção tem de ser instalada antes do Windows Vista processo de configuração generalizes e substitui o perfil de utilizador predefinido.

Se já tiver executado o comando sysprep em conjunto com a opção / generalize , siga estes passos:
  1. Inicie o processo de configuração Windows Vista.
  2. Quando o Assistente de OOBE está em execução, prima Ctrl + Shift + F3 para introduzir o modo de auditoria e, em seguida, instalar esta correcção.
  3. Para reiniciar o Assistente de OOBE, execute o seguinte comando:
    Sysprep.exe /oobe/generalize/unattend:Autounattend.xml
    Nota O Autounattend.xml é um ficheiro XML que inclua a marca <copyprofile> true </copyprofile>.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Windows Vista, versões de 32 bits
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
X86_8bb49f1e2f2802f208f28a064cbec977_31bf3856ad364e35_6.0.6000.20683_none_b100ed7533c7ac82.manifestNão aplicável69920-Set-200717: 09Não aplicável
X86_microsoft-windows-shell-setup_31bf3856ad364e35_6.0.6000.20683_none_d0aab06905d56bdb.manifestNão aplicável27,69420-Set-200717: 09Não aplicável
Shsetup.dll6.0.6000.2068397,28019-Set-200703: 01x 86
Windows Vista, versões de 64 bits
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Amd64_22988fa923d8cf470142418bb55d60f7_31bf3856ad364e35_6.0.6000.20683_none_455254050c5279c9.manifestNão aplicável1,04620-Set-200717: 09Não aplicável
Amd64_microsoft-windows-shell-setup_31bf3856ad364e35_6.0.6000.20683_none_2cc94becbe32dd11.manifestNão aplicável27,72020-Set-200717: 16Não aplicável
X86_microsoft-windows-shell-setup_31bf3856ad364e35_6.0.6000.20683_none_d0aab06905d56bdb.manifestNão aplicável27,69420-Set-200717: 16Não aplicável
Shsetup.dll6.0.6000.20683116,73619-Set-200703: 40x 64
Shsetup.dll6.0.6000.2068397,28019-Set-200703: 01x 86

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a". Este problema foi corrigido pela primeira vez no Windows Vista Service Pack 1.

Mais Informação

Para obter mais informações sobre este problema num computador com o Windows Vista, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
932156Não pode ver informações de certificados no Windows Internet Explorer 7 ou no Gestor de certificados depois de importar um certificado num computador baseado no Windows Vista com êxito

Propriedades

Artigo: 942543 - Última revisão: 20 de maio de 2008 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Starter
Palavras-chave: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseinter kbqfe kbhotfixserver KB942543 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 942543

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com