Не удается просмотреть сведения о сертификате в обозревателе Internet Explorer 7 или в диспетчере сертификатов при использовании файла ответов автоматической установки Windows Vista

Переводы статьи Переводы статьи
Код статьи: 942543 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

После успешного импорта сертификата на компьютере под управлением Windows Vista не удается просмотреть сведения о сертификате в обозревателе Internet Explorer 7 или диспетчера сертификатов.

Причина

Эта проблема возникает, если у вас нет разрешения на чтение в следующем разделе реестра:
HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\ProtectedRoots
Эта проблема возникает, если выполняются следующие условия:
  • Использовать автоматическую установку для установки Windows Vista.
  • Файла ответов автоматической установки (Autounattend.XML) включает в себя следующий тег:
    <copyprofile>значение true</copyprofile>
  • Был resealed образ операционной системы с помощьюsysprep generalizeкоманды.
В этом случае пользователь, запускающий мастера недостаточно Box Experience (OOBE) не был назначен для раздела реестра ProtectedRoots разрешения на чтение. Вместо этого учетную запись администратора присваивается разрешения на чтение данного раздела. Тем не менее в разделе реестра ProtectedRoots хранятся сведения о сертификате, который отображается в обозревателе Internet Explorer 7 или в диспетчере сертификатов. Таким образом пользователя, вошедшего в систему не удается просмотреть сведения о сертификате.

Решение

Сведения пакета обновления

Решить эту проблему, получите последний пакет обновления для Windows Vista. Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
935791Как получить последний пакет обновления для Windows Vista

Сведения о исправления

Исправление доступно в корпорации Майкрософт. Это исправление предназначено для устранения проблемы, описанной в этой статье.. Его необходимо применять только в тех системах, в которых наблюдается данная проблема.. Исправление может проходить дополнительное тестирование.. Таким образом, если вы не подвержены серьезно эту проблему, рекомендуется дождаться следующего обновления программного обеспечения, содержащего это исправление.

Исправление доступно для загрузки, существует ли раздел «Исправление доступно для загрузки» в верхней части этой статьи базы знаний. Если этот раздел не отображается, обратитесь в Службу поддержки клиентов Microsoft для получения исправления..

Примечание, Если дополнительные проблемы, или если требуется устранить неполадки может потребоваться создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются вами дополнительно.. Для получения полного списка, и служба технической поддержки по телефону номера или создать отдельный запрос, посетите следующий веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=support
ПримечаниеВ форме "Исправление доступно для загрузки" отображаются языки, для которых доступно исправление. Если язык не отображается, это потому, что исправление не поддерживается для этого языка.

Необходимые условия

Необходимые компоненты не требуются.

Требование перезагрузки

Нет необходимости перезагружать компьютер после установки данного исправления.

Сведения о замене исправлений

Это исправление не заменяет ранее выпущенные исправления.

Сведения об установке исправлений

, Чтобы убедиться в том, что профиль пользователя, вошедшего в систему поверх профиля пользователя по умолчанию, установите тег CopyProfile значение true. Это исправление необходимо установить перед Windows Vista процесс установки generalizes и поверх профиля пользователя по умолчанию.

Если уже было выполненоSysprepкоманды вместе с/ generalizeпараметр, выполните следующие действия:
  1. Запустите процесс установки Windows Vista.
  2. Выполняется при мастере ПРИВЕТСТВИЯ, нажмите кнопкуCtrl + Shift + F3Чтобы перейти в режим аудита и установите исправление.
  3. Перезапустить мастер ПРИВЕТСТВИЯ, выполните следующую команду:
    Sysprep.exe /oobe/generalize/unattend:Autounattend.xml
    ПримечаниеФайл Autounattend.XML используется XML-файле, содержащем <copyprofile>значение true,</copyprofile> тег.

Сведения о файле

Английская версия данного исправления содержит атрибуты файла (или более поздние атрибуты файлов), приведенные в следующей таблице. Дата и время для файлов указаны во всеобщем скоординированном времени (UTC).. При просмотре сведений о файле, время изменяется на местное.. Чтобы узнать разницу между временем по Гринвичу и местным временем,Часовой поясвкладкеДата и времяэлемента в элементе управления.
Windows Vista, 32-разрядные версии
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
X86_8bb49f1e2f2802f208f28a064cbec977_31bf3856ad364e35_6.0.6000.20683_none_b100ed7533c7ac82.manifestНе применимо69920 Сентября 2007 г.17: 09Не применимо
X86_microsoft-windows-shell-setup_31bf3856ad364e35_6.0.6000.20683_none_d0aab06905d56bdb.manifestНе применимо27,69420 Сентября 2007 г.17: 09Не применимо
Shsetup.dll6.0.6000.2068397,28019 Сентября 2007 г.03: 01x 86
Windows Vista, 64-разрядные версии
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Amd64_22988fa923d8cf470142418bb55d60f7_31bf3856ad364e35_6.0.6000.20683_none_455254050c5279c9.manifestНе применимо1,04620 Сентября 2007 г.17: 09Не применимо
Amd64_microsoft-windows-shell-setup_31bf3856ad364e35_6.0.6000.20683_none_2cc94becbe32dd11.manifestНе применимо27,72020 Сентября 2007 г.17: 16Не применимо
X86_microsoft-windows-shell-setup_31bf3856ad364e35_6.0.6000.20683_none_d0aab06905d56bdb.manifestНе применимо27,69420 Сентября 2007 г.17: 16Не применимо
Shsetup.dll6.0.6000.20683116,73619 Сентября 2007 г.03: 40x 64
Shsetup.dll6.0.6000.2068397,28019 Сентября 2007 г.03: 01x 86

Статус

Корпорация Майкрософт подтвердила, что это является проблемой в продуктах Майкрософт, которые перечислены в разделе «Данная статья применима к». Впервые эта ошибка была исправлена в Windows Vista с пакетом обновления 1 (SP1).

Дополнительная информация

Для получения дополнительных сведений об этой проблеме на компьютере под управлением Windows Vista щелкните следующий номер статьи базы знаний Майкрософт:
932156Не удается просмотреть сведения о сертификате в обозревателе Internet Explorer 7 или в диспетчере сертификатов после успешного импорта сертификата на компьютере под управлением Windows Vista

Свойства

Код статьи: 942543 - Последний отзыв: 11 октября 2011 г. - Revision: 3.0
Информация в данной статье относится к следующим продуктам.
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Starter
Ключевые слова: 
kbautohotfix kbvistasp1fix kbexpertiseinter kbqfe kbhotfixserver kbmt KB942543 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:942543

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com