คุณไม่สามารถดูข้อมูลใบรับรอง ใน Windows Internet Explorer 7 หรือในตัว จัดการใบรับรองถ้าคุณใช้แฟ้มคำตอบที่มีการทำงานอัตโนมัติการติดตั้ง Windows Vista

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 942543 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

หลังจากที่คุณนำสำเร็จเข้าใบรับรองบนคอมพิวเตอร์ที่ใช้ Windows Vista คุณไม่สามารถดูข้อมูลใบรับรอง ใน Windows Internet Explorer 7 หรือในตัว จัดการใบรับรอง

สาเหตุ

ปัญหานี้เกิดขึ้นหากคุณไม่มีสิทธิ์ในการอ่านสำหรับคีย์ย่อยของรีจิสทรีต่อไปนี้:
HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\ProtectedRoots
ปัญหานี้จะเกิดขึ้นหากมีเงื่อนไขต่อไปนี้::
  • คุณสามารถใช้กระบวนการติดตั้งแบบอัตโนมัติการติดตั้ง Windows Vista
  • แฟ้มคำตอบที่ทำงานอัตโนมัติ (Autounattend.xml) ประกอบด้วยป้ายต่อไปนี้:
    <copyprofile>True</copyprofile>
  • รูปของระบบปฏิบัติถูก resealed โดยใช้การsysprep generalizeคำสั่ง
ในสถานการณ์สมมตินี้ ผู้ใช้ที่เรียกใช้ตัวช่วยสร้างการไม่อยู่ที่กล่องประสบการณ์การใช้งาน (OOBE) จะไม่กำหนดสิทธิ์ในการอ่านสำหรับคีย์รีจิสทรี ProtectedRoots แทน บัญชี Administrator ถูกกำหนดให้สิทธิ์ในการอ่านสำหรับคีย์นี้ อย่างไรก็ตาม ข้อมูลใบรับรองที่จะแสดงขึ้น ใน Internet Explorer 7 หรือในตัว จัดการใบรับรอง ถูกเก็บไว้ในคีย์รีจิสทรี ProtectedRoots ดังนั้น ผู้ใช้ที่อยู่ในขณะนี้สู่เครื่องคอมพิวเตอร์ไม่สามารถดูข้อมูลใบรับรอง

การแก้ไข

ข้อมูล Service Pack

เมื่อต้องการแก้ไขปัญหานี้ ให้ขอรับ Service Pack ล่าสุดสำหรับ Windows Vista สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
935791วิธีการขอรับ Service Pack ของ Windows Vista รุ่นล่าสุด

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มีเป้าหมายเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น นำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหานี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น หากคุณไม่ได้รับความเสียหายรุนแรงจากปัญหานี้ เราขอแนะนำให้คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่มีโปรแกรมแก้ไขด่วนนี้

หากมีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" อยู่ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น โปรดติดต่อฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ:หากเกิดปัญหาอื่น ๆ หรือ ถ้ามีการแก้ไขปัญหาเป็นสิ่งจำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะเกิดขึ้นเมื่อมีคำถามและประเด็นการสนับสนุนอื่นๆ ซึ่งไม่จัดอยู่ในโปรแกรมแก้ไขด่วนเฉพาะที่กล่าวถึงนี้ สำหรับรายการของหมายเลขโทรศัพท์ของฝ่ายบริการและการสนับสนุนลูกค้าของ Microsoft ทั้งหมด หรือถ้าต้องการสร้างคำขอรับการสนับสนุนแยกต่างหาก โปรดเข้าสู่เว็บไซต์ของ Microsoft ต่อไปนี้::
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:แบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาในโปรแกรมแก้ไขด่วนมีอยู่ หากคุณไม่เห็นภาษาของคุณ เป็นเพราะไม่มีโปรแกรมแก้ไขด่วนสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

ไม่มีข้อกำหนดเบื้องต้นใดๆ

ข้อกำหนดในการเริ่มต้นระบบคอมพิวเตอร์ใหม่

คุณไม่จำเป็นต้องเริ่มต้นคอมพิวเตอร์ใหม่หลังจากใช้โปรแกรมแก้ไขด่วนนี้

ข้อมูลการทดแทนโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้แทนที่โปรแกรมแก้ไขด่วนก่อนหน้านี้

ข้อมูลการติดตั้งโปรแกรมแก้ไขด่วน

เมื่อต้องการตรวจสอบให้แน่ใจว่า โปรไฟล์ผู้ใช้ที่จะเข้าสู่ระบบในขณะนี้เขียนทับโพรไฟล์ผู้ใช้เริ่มต้น เซ็ตแท็ก CopyProfile จริง ต้องมีการติดตั้งโปรแกรมแก้ไขด่วนนี้ก่อน Windows Vista กระบวนการเซ็ตอัพ generalizes และโพรไฟล์ผู้ใช้เริ่มต้นเขียนทับ

ถ้าคุณอยู่แล้วได้sysprepคำสั่งร่วมกับ/ generalizeตัวเลือก ทำตามขั้นตอนเหล่านี้:
  1. เริ่มกระบวนการติดตั้ง Windows Vista
  2. เมื่อมีการเรียกใช้ตัวช่วยสร้างการ OOBE กดctrl + Shift + F3โหมดการตรวจสอบ แล้ว ติดตั้งโปรแกรมแก้ไขด่วนนี้
  3. เมื่อต้องการเริ่มต้นตัวช่วยสร้างการ OOBE ดำเนินการคำสั่งต่อไปนี้ต่อไปนี้:
    sysprep.exe /oobe/generalize/unattend:Autounattend.xml
    หมายเหตุ:Autounattend.xml คือ ไฟล์ XML ที่มีแท็กที่<copyprofile>เป็นจริง</copyprofile>

ข้อมูลแฟ้ม

โปรแกรมแก้ไขด่วนรุ่นภาษาอังกฤษนี้มีแอตทริบิวต์แฟ้ม (หรือแอตทริบิวต์แฟ้มหลังจากนี้) ซึ่งแสดงในตารางต่อไปนี้ วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในนั้นวันที่และเวลาสินค้าในการควบคุมแผง
Windows Vista รุ่น 32 บิต
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
X86_8bb49f1e2f2802f208f28a064cbec977_31bf3856ad364e35_6.0.6000.20683_none_b100ed7533c7ac82.manifestไม่สามารถใช้งานได้69920 Sep 200717:09ไม่สามารถใช้งานได้
X86_microsoft-หน้าต่างเชลล์-setup_31bf3856ad364e35_6.0.6000.20683_none_d0aab06905d56bdb.manifestไม่สามารถใช้งานได้27,69420 Sep 200717:09ไม่สามารถใช้งานได้
Shsetup.dll6.0.6000.2068397,28019 Sep 200703:01x86
windows Vista รุ่น 64 บิต
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
Amd64_22988fa923d8cf470142418bb55d60f7_31bf3856ad364e35_6.0.6000.20683_none_455254050c5279c9.manifestไม่สามารถใช้งานได้1,04620 Sep 200717:09ไม่สามารถใช้งานได้
Amd64_microsoft-หน้าต่างเชลล์-setup_31bf3856ad364e35_6.0.6000.20683_none_2cc94becbe32dd11.manifestไม่สามารถใช้งานได้27,72020 Sep 200717:16ไม่สามารถใช้งานได้
X86_microsoft-หน้าต่างเชลล์-setup_31bf3856ad364e35_6.0.6000.20683_none_d0aab06905d56bdb.manifestไม่สามารถใช้งานได้27,69420 Sep 200717:16ไม่สามารถใช้งานได้
Shsetup.dll6.0.6000.20683116,73619 Sep 200703:40x64
Shsetup.dll6.0.6000.2068397,28019 Sep 200703:01x86

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน" ปัญหานี้ถูกแก้ไขใน Windows Vista Service Pack 1 ครั้งแรก

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับปัญหานี้บนคอมพิวเตอร์ที่ใช้ Windows Vista คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
932156คุณไม่สามารถดูข้อมูลใบรับรอง ใน Windows Internet Explorer 7 หรือในตัว จัดการใบรับรองหลังจากที่คุณนำเข้าใบรับรองบนคอมพิวเตอร์ที่ใช้ Windows Vista เสร็จเรียบร้อยแล้ว
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

คุณสมบัติ

หมายเลขบทความ (Article ID): 942543 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 4.0
ใช้กับ
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Starter
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseinter kbqfe kbHotfixServer kbmt KB942543 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:942543

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com