Una aplicación de 32 bits no puede tener acceso a la carpeta system32 en un equipo que ejecuta una versión de 64 bits de Windows Server 2003 o de Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 942589 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo que ejecuta una versión de 64 bits de Windows Server 2003 o de Windows XP, una aplicación de 32 bits no puede tener acceso a la carpeta siguiente:
%WinDir%\System32
Por tanto, la aplicación de 32 bits no puede iniciar las aplicaciones de 64 bits en la carpeta System32. Además, la aplicación de 32 bits no puede recuperar el información de archivo acerca de los archivos en la carpeta System32 o en las subcarpetas de la carpeta System32.

Causa

Este comportamiento se produce porque Windows en Windows de 64 bits (WOW64) proporciona la redirección del sistema de archivos. En una versión de 64 bits de Windows Server 2003 o de Windows XP, la carpeta %Windir%\System32 se reserva para las aplicaciones de 64 bits. Cuando una aplicación de 32 bits intenta tener acceso a la carpeta System32, acceso se redirige a la carpeta siguiente:
%WinDir%\SysWOW64
De forma predeterminada, se habilita la redirección del sistema de archivos.

Solución

Después de instalar la revisión siguiente, una aplicación de 32 bits puede tener acceso a la siguiente carpeta del sistema nativo en lugar de la carpeta %Windir%\System32:
%WinDir%\Sysnative
WOW64 reconoce la carpeta Sysnative como un alias especial. Por tanto, el sistema de archivos no redirige acceso fuera de la carpeta Sysnative. Este mecanismo es flexible y fácil de usar. Puede utilizar la carpeta Sysnative para omitir la redirección del sistema de archivos.

Nota Después de aplicar este hotfix, debe anexar la ruta de acceso de %WinDir%\Sysnative a la variable de entorno % path %. Para ello, ejecute el siguiente comando en un símbolo del sistema:
establecer path=%path%;%WinDir%\Sysnative

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si se requiere cualquier solución de problemas, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión específica. Para obtener una lista completa de servicio de atención al cliente y soporte números de teléfono o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponible" muestra los idiomas para el que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe tener instalado en el equipo Windows Server 2003 Service Pack 2 o Windows Server 2003 Service Pack 1. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para buscar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria en el elemento fecha y hora en el panel de control.
Windows Server 2003 con Service Pack 1, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Wow64.dll5.2.3790.3013496,64024-Sep-200705: 18IA-64
Windows Server 2003 con Service Pack 2, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Wow64.dll5.2.3790.4156496,64024-Sep-200706: 02IA-64
Windows Server 2003 o Windows XP, versiones de 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Wow64.dll5.2.3790.3013249,34422 De septiembre de 200709: 02x 64
Windows Server 2003 o Windows XP con Service Pack 2, versiones de 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Wow64.dll5.2.3790.4156249,34422 De septiembre de 200709: 10x 64

Solución

Para solucionar este comportamiento, siga uno de los métodos siguientes.

Método 1

Crear un punto de unión de NTFS que señala a la carpeta %Windir%\System32. Acceso al punto de unión NTFS en lugar de la carpeta %Windir%\System32.

Método 2

Puede utilizar las siguientes funciones para controlar la redirección del sistema de archivos.
  • Wow64DisableWow64FsRedirection
  • Wow64EnableWow64FsRedirection
  • Wow64RevertWow64FsRedirection
Para obtener más información al respecto, visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa365743.aspx

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 942589 - Última revisión: miércoles, 21 de octubre de 2009 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional x64 Edition
Palabras clave: 
kbmt kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB942589 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 942589

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com