高い画面解像度設定を Windows Server 2003 ベースのコンピューターに接続されているターミナル サーバー セッションで使用されている場合、色深度を 8 ビットが予期せず変更です。

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文書番号: 942610
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目次

現象

次のシナリオを検討してください。
  • Windows Server 2003 ベースのコンピューターにターミナル サーバー セッションを確立します。
  • 高い画面解像度の設定、ターミナル サーバー セッションを使用します。
たとえば、1024年ピクセル 3840 の画面解像度でターミナル サーバー セッションを確立するために、次のコマンドを使用します。
mstsc/v:<server name=""></server> /w:3840/h:1024
このシナリオでは、ターミナル サーバーのセッションが予期せずのみ 8 ビットの色深度 (256 色) を表示します。

この問題は、次のいずれかの Windows Server 2003 ベースのコンピューターにインストールされている場合に発生します。
  • Windows Server 2003 Service Pack 2 (SP2)
  • 以下の Knowledge Base の資料に記載されている修正プログラムします。
    918679 リモート デスクトップの Web 接続 ActiveX コントロール画面の解像度 1600 x 1200 ピクセルより高い場合は、Windows Server 2003 ベースのターミナル サーバーに接続できません。

原因

918679 の修正プログラムまたは Windows Server 2003 SP2 をインストールした後、指定された解像度 1600 x 1200 ピクセルよりも大きい場合は、ターミナル サービス、ターミナル サーバー セッションの色 8 ビットに制限します。

解決方法

次の修正プログラムを適用すると、高解像度でターミナル サーバー セッションの色深度は 16 ビットまでです。

メモ この修正プログラムを高い解像度と高い色深度が適用されている、ターミナル サーバーのセッションがターミナル サーバー上のリソースを使い果たしてしまう可能性があります。この問題が発生する場合は、マイクロソフト カスタマー サポート サービスにお問い合わせください。完全な一覧 Microsoft カスタマー サポート サービスの電話番号とサポートのコストに関する情報を次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support

修正プログラムの情報

サポートされている修正プログラムがマイクロソフトから入手可能です。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストを受け取ることがあります。したがって、この問題で深刻な影響をされていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

この修正プログラムがダウンロードできないか場合は、この記事の上部に「修正プログラムのダウンロード」セクションです。このセクションが表示されない場合は、マイクロソフト カスタマー サービス &amp; サポート修正プログラムを入手するに問い合わせてください。

メモ その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス &amp; サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームに修正プログラムが提供されている言語を表示します。お使いの言語が表示されない場合は、修正プログラムがその言語の利用できないためにです。

前提条件

この修正プログラムを適用するには、Windows Server 2003 SP2 がターミナル サーバーにインストールする必要があります。 詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
889100Windows Server 2003 用の最新の service pack を入手する方法

再起動の必要性

この修正プログラムを適用した後コンピューターを再起動する必要があります。

修正プログラムの置き換えに関する情報

この修正プログラムは、他の修正プログラムに置き換えられない。

レジストリ情報

修正プログラムをシステムには、次のレジストリ エントリを自動的に追加されます。
レジストリ サブキー:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal サーバー

レジストリ エントリ:
AllowHigherColorDepth

種類: REG_DWORD
値: 1

ファイル情報

この修正プログラムの英語版がファイル属性 (またはそれ以降のファイル属性) が、次のとおり。日付および時刻これらのファイルを世界協定時刻 (UTC) が表示されます。ファイル情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 タイム ゾーン タブには 日付と時刻 コントロール パネルの項目。
Windows Server 2003 Service Pack 2 を搭載した x86 ベースのバージョン x
元に戻す全体を表示する
ファイル名ファイルのバージョンファイルのサイズ日付時間プラットフォーム
Rdpwd.sys5.2.3790.4179152,7122007 年 10 月 30 日17: 57x 86
Windows Server 2003 Service Pack 2 は、Itanium ベース バージョン
元に戻す全体を表示する
ファイル名ファイルのバージョンファイルのサイズ日付時間プラットフォーム
Rdpwd.sys5.2.3790.4179479,3682007 年 10 月 30 日15: 51IA-64
Windows Server 2003 Service Pack 2 x 64 ベース版
元に戻す全体を表示する
ファイル名ファイルのバージョンファイルのサイズ日付時間プラットフォーム
Rdpwd.sys5.2.3790.4179231,0482007 年 10 月 30 日15: 51x64

状況

マイクロソフトでは、この「対象」に記載されているマイクロソフト製品の問題として認識しています。

詳細

ソフトウェアの更新の用語の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
824684マイクロソフトのソフトウェア更新プログラムの説明に使用される一般的な用語の説明

プロパティ

文書番号: 942610 - 最終更新日: 2011年8月10日 - リビジョン: 3.0
キーワード:?
kbbug kbfix kbqfe kbpubtypekc kbexpertiseinter kbhotfixserver kbwinserv2003postsp2fix kbautohotfix kbmt KB942610 KbMtja
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英語版 KB:942610
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