Update: Sie möglicherweise Probleme bei Verwendung ein Adapters Windows Communication Foundation (WCF) in Microsoft BizTalk Server 2006 R2

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Problembeschreibung

Wenn Sie einen Adapter für Microsoft Windows Communication Foundation (WCF) in Microsoft BizTalk Server 2006 R2 verwenden, können Sie eines der folgenden Probleme auftreten.

Problem 1

Wenn Sie benutzerdefinierten Bindung für eine ausgehende Prozess verwenden, übergibt der WCF-Adapter nicht die Namespaceinformationen. Wenn Sie die WriteStartElement-Methode, um ein Starttag in eine XML-Datei schreiben aufrufen, also das Starttag der XML-Datei nicht mit einem beliebigen Namespace verknüpft.

Problem 2

Der WCF-Adapter wird falsche Daten erzeugt, wenn die folgenden Bedingungen erfüllt sind:
  • Der Sendeport des WCF-Adapters verwendet eine Vorlage-Nachricht, die Zeichenfolgencodierung der verwendet.
  • Die Größe der Nachricht Vorlage ist größer als 4 KB.
  • Die Nachricht Vorlage verwendet, die nicht-UTF8-Codierung.

Problem 3

Der WCF-Adapter folgt nicht die Zeitlimiteinstellung Transaktion in der Datei Machine.config. Der WCF-Adapter hat eine maximale Transaktion Timeout-Einstellung von 60 Minuten. Der festgelegte Timeoutwert für eine Transaktion wird nicht geändert werden, selbst wenn die Transaktion Zeitüberschreitungseinstellung in der Datei "Machine.config" mehr als 60 Minuten ist.

Ursache

Diese Probleme treten aufgrund von Fehlern in der Assembly Microsoft.BizTalk.Adapter.Wcf.Runtime.dll.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix wird möglicherweise zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemlösungen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen, die für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, liegt dies daran, dass ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Sie müssen BizTalk Server 2006 R2 für diesen Hotfix installiert haben.

Informationen zum Neustart

Sie müssen den Computer neu zu starten, nachdem Sie diesen Hotfix installiert haben.

Informationen zur Registrierung

Sie müssen die Registrierung ändern.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Dieser Hotfix enthält nur die Dateien, die erforderlich sind, um die Probleme zu beheben, die in diesem Artikel aufgelistet. Dieser Hotfix enthält möglicherweise nicht alle Dateien, die Sie benötigen, um ein Produkt vollständig auf den neuesten Stand zu aktualisieren.

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time (UTC) aufgelistet. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC-Zeit und lokaler Zeit zu ermitteln, verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Microsoft.BizTalk.Adapter.WCF.Runtime.dll3.6.1413.2209,98427-Sep 200709: 19X 86
Hinweis: Aufgrund von Dateiabhängigkeiten kann der aktuellste Hotfix, der diese Dateien enthält auch weitere Dateien enthalten.

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Die Probleme, die im Abschnitt "Problembeschreibung" beschrieben sind werden in dem Hotfix behoben.

Problem 1

Der Code wurde geändert, sodass die Namespaceinformationen an die WriteStartElement-Methode übergeben wird.

Problem 2

Die Codierung der Nachricht aus der Bytereihenfolgemarkierung (BOM) wird erkannt, wenn der Adapter die Meldungsfolge Adapter von BizTalk Server-Nachrichtenstrom erstellt.

Problem 3

Die System-Timeout-Einstellung wird für die Zeitlimiteinstellung für WCF-Adapter verwendet. Der Standardwert von der System-Timeout-Einstellung ist 10 Minuten. Dieser Wert kann geändert werden, indem Sie die Datei Machine.config ändern. Sie können z. B. im folgenden Abschnitt in der Datei "Machine.config" So ändern Sie die Timeouteinstellung auf 15 Minuten ändern.
<configuration>
 <system.transactions>
   <machineSettings maxTimeout="00:15:00" />
 </system.transactions>
</configuration>
Weitere Informationen zur Terminologie für Softwareupdates finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 942612 - Geändert am: Donnerstag, 1. November 2007 - Version: 1.5
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Branch
Keywords: 
kbmt kbautohotfix kbbtsadapters kbbiztalk2006r2sp1fix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB942612 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 942612
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