Erreur Stop lorsque vous essayez de télécharger des mises à jour à partir de Windows Update sur un ordinateur qui exécute Windows Vista: « 0x80070246 »

Traductions disponibles Traductions disponibles
Numéro d'article: 942968 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Lorsque vous essayez de télécharger des mises à jour à partir de Windows Update sur un ordinateur qui exécute Windows Vista, le message d'erreur Stop suivant peut s'afficher :
STOP 0X80070246
ERROR_ILLEGAL_CHARACTER
En outre, l'entrée suivante peut être enregistrée dans le fichier WindowsUpdate.log :
Automatic Updates Failure Content Install
		  Installation Failure: Windows failed to install the following update with error
		  0x80070246: "Name of Update"
fichier de WindowsUpdate.log la note se trouve dans l'emplacement suivant :
%Windir%\WindowsUpdate.log

Cause

Ce problème se produit si le fichier GlobalInstallOrder.xml est endommagé. Le fichier GlobalInstallOrder.xml est à l'emplacement suivant :
%Windir%\Winsxs\x86_microsoft-Windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_none_07289f4cca5f6990\GlobalInstallOrder.XML

Résolution

Pour résoudre ce problème, remplacez le fichier GlobalInstallOrder.xml endommagé sur le système avec le même fichier à partir de Windows Vista support d'installation. Pour ce faire, procédez comme suit :
  1. Procurez-vous le pilote de filtre WIM auprès le Kit d'installation automatisée (Windows AIK). Pour télécharger et installer l'AIK Windows, reportez-vous au site Web de Microsoft à l'adresse suivante :
    http://www.microsoft.com/downloads/details.aspx?FamilyID=c7d4bc6d-15f3-4284-9123-679830d629f2&DisplayLang=en
  2. Cliquez sur Démarrer , pointez sur Tous les programmes , cliquez sur Microsoft Windows AIK , cliquez avec le bouton droit sur invite de commande des outils Windows PE et puis cliquez sur Exécuter en tant qu'administrateur .

    Si vous êtes invité à fournir un mot de passe administrateur, tapez le mot de passe. Si vous êtes invité pour continuer, cliquez sur Continuer .
  3. À l'invite de commandes, tapez la commande suivante et appuyez sur ENTRÉE.
    MD c:\Mount
    Cette commande crée un dossier nommé Monter.
  4. Insérez le support d'installation Windows Vista dans le lecteur CD ou DVD.
  5. À l'invite de commandes, tapez la commande suivante et appuyez sur ENTRÉE :
    ImageX /mount DVDDriveLetter \sources\install.wim 1 \mount
  6. À l'invite de commandes, tapez la commande suivante et appuyez sur ENTRÉE :
    CD\mount\Windows\winsxs\x86_microsoft-Windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_none_07289f4cca5f6990
    Cette commande déplace vers le dossier source
  7. À l'invite de commandes, tapez la commande suivante et appuyez sur ENTRÉE :
    xcopy GlobalInstallOrder.xml %windir%\winsxs\x86_microsoft-windows-servicingstack_31bf3856ad364e35_6.0.6000.16386_none_07289f4cca5f6990
    Cette commande copie le fichier GlobalInstallOrder.xml dans le dossier de destination.

Plus d'informations

Pour plus d'informations sur l'utilisation de l'outil Sfc.exe pour remplacer le fichier endommagé, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
929833 Certaines fonctions Windows Vista peut ne pas fonctionner ou Windows Vista peut cesser de répondre

Propriétés

Numéro d'article: 942968 - Dernière mise à jour: mardi 14 septembre 2010 - Version: 4.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Update
  • Windows Vista Professionnel
  • Windows Vista Entreprise
  • Windows Vista Édition Familiale Basique
  • Windows Vista Édition Familiale Premium
  • Windows Vista Édition Intégrale
  • Windows Vista Professionnel 64 bits
  • Windows Vista Entreprise 64 bits
  • Windows Vista Édition Familiale Basique 64 bits
  • Windows Vista Édition Familiale Premium 64 bits
  • Windows Vista Édition Intégrale 64 bits
  • Microsoft Update
Mots-clés : 
kbmt kbexpertiseinter kbtshoot kbprb KB942968 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 942968
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com