Se le pide inesperadamente que reinicie el equipo después de instalar un Service Pack de 2007 Office o una actualización de 2007 Office

Seleccione idioma Seleccione idioma
Id. de artículo: 942995 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de instalar un Service Pack de 2007 Microsoft Office o una actualización de 2007 Office, le solicitan que reinicie el equipo.

Causa

Este problema se puede producir si el Service Pack o la actualización debe modificar un archivo que está siendo utilizado actualmente. El archivo es usado por un programa que se está ejecutando cuando instala el Service Pack o la actualización. A veces, el programa que está utilizando el archivo no es un programa de Office.

Este problema puede producirse cuando se cumple una o varias de las condiciones siguientes:
  • Un dispositivo que se sincroniza con Microsoft Outlook va unido al equipo cliente. Además, se está ejecutando ActiveSync.
  • Se está ejecutando un programa de Office.
  • Se está ejecutando Office Communicator 2005 u Office Communicator 2007.
  • Se está ejecutando el servicio Office Groove 2007 (GrooveMonitor.exe).
  • Se está ejecutando el servicio Windows Desktop Search (Searchprotocolhost.exe).
  • Está instalado el editor de métodos de entrada japonés.
Nota: esta lista no es general. Otros programas pueden causar también este problema.

Solución

Antes de instalar el Service Pack o la actualización, cierre cualquier programa o servicio que se esté ejecutando y que pueda interferir en la instalación del Service Pack o de la actualización.

Los métodos siguientes proporcionan información sobre la manera de cerrar algunos programas y servicios que puedan causar este problema.

Cómo cerrar ActiveSync

Para cerrar ActiveSync, debe finalizar el proceso Wcescomm.exe. Para finalizar el proceso Wcescomm.exe, vea la sección "Cómo finalizar un proceso para un programa que se está ejecutando en segundo plano".

Nota: si un usuario o dispositivo está conectado al servicio ActiveSync, el usuario o el dispositivo se desconectará cuando finalice el proceso.

Cómo salir de un programa de Office

Para salir de un programa de Offcie, haga clic en Salir en el menú Archivo. Si el programa de Office no es visible en la pantalla, presiones Alt+Tab para cambiar al programa. O bien, haga clic en el botón de la barra de tareas del programa de Office.

Nota: un proceso de un programa de Office se puede seguir ejecutando en segundo plano si un problema hace que el programa se cierre anormalmente. Si sospecha que un programa de Office se está ejecutando en segundo plano, finalice el proceso. Para ello, vea la sección "Cómo finalizar un proceso para un programa que se está ejecutando en segundo plano".

Cómo cerrar Communicator 2005 o Communicator 2007

Para cerrar Communicator 2005 o Communicator 2007, cierre la sesión de Communicator, cierre el programa y salga de él. Para ello, siga estos pasos:
  1. En el menú Conectar, haga clic en Cerrar sesión.
  2. En el menú Conectar, haga clic en Cerrar.

    Nota: cuando cierra Communicator 2005 o Communicator 2007, el programa notifica el área de notificación.
  3. Haga clic con el botón secundario en el icono de Communicator 2005 o Communicator 2007 del área de notificación y, después, haga clic en Salir.

Cómo finalizar un proceso para un programa que se está ejecutando en segundo plano

Importante: finalizar un proceso puede causar resultados no deseados. Ello incluye la inestabilidad del sistema y pérdida de datos. Cuando finaliza un proceso, no puede guardar su estado u otros datos antes de que el proceso finalice.

Para finalizar un proceso de un programa que se está ejecutando en segundo plano, use uno de los métodos siguientes.

Método 1: utilizar el Administrador de tareas

  1. Presione Ctrl+Alt+Supr.
  2. En la ficha Procesos, haga clic en nombreArchivoProceso y, a continuación, haga clic en Terminar proceso.

    Nota: en este método, nombreArchivoProceso representa el nombre del archivo del proceso que quiera terminar.

Método 2: utilizar el comando Taskkill.

  1. Haga clic en Inicio y en Ejecutar, escriba cmd y, a continuación, haga clic en Aceptar.
  2. En el símbolo del sistema, escriba taskkill /im nombreArchivoProceso y presione Entrar.

    Notas
    • En este método, nombreArchivoProceso representa el nombre del archivo del proceso que quiera terminar.
    • Para obtener más información acerca del comando Taskkill, escriba taskkill /? en el símbolo del sistema y presione Entrar.
  3. En el símbolo del sistema, escriba exit para cerrar la ventana del símbolo del sistema.

Cómo impedir que el equipo se reinicie inesperadamente cuando implementa un Service Pack de 2007 Office o una actualización de 2007 Office

Si es un administrador que está implementando un Service Pack o una actualización de Office, puede usar una secuencia de comandos para cerrar programas o servicios que puedan interferir en la instalación del Service Pack o la actualización.

Microsoft proporciona ejemplos de programación solamente como ilustración, sin ninguna garantía ya sea expresa o implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se muestra, así como las herramientas empleadas para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden ayudar a explicar la funcionalidad de un procedimiento en particular. Sin embargo, no modificarán estos ejemplos para proporcionar una funcionalidad adicional ni crearán procedimientos que cumplan sus requisitos específicos.

Para usar una secuencia de comandos para cerrar programas o servicios, cree una semejante a la siguiente.
; TechNet Sample 2005
; http://www.microsoft.com/technet/scriptcenter/resources/qanda/sept04/hey0927.mspx
; For more information about how to use scripts to manage processes, visit the following Microsoft Web site:
; http://www.microsoft.com/technet/scriptcenter/guide/sas_prc_overview.mspx

strComputer = "."
Set objWMIService = GetObject _
    ("winmgmts:\\" & strComputer & "\root\cimv2")
Set colProcessList = objWMIService.ExecQuery _
    ("Select * from Win32_Process Where Name = 'Communicator.exe'")
For Each objProcess in colProcessList
    objProcess.Terminate()
Next

Más información

Con frecuencia, la instalación de un Service Pack o una actualización de 2007 Office no requiere que reinicie el equipo. Sin embargo, hay escenarios en los que debe reiniciar el equipo.

Si debe reiniciar el equipo después de instalar un Service Pack o una actualización de 2007 Office, la información de reinicio se incluirá en la documentación que acompaña al Service Pack o la actualización de Office.

Para determinar la causa de la solicitud de reinicio, revise el contenido del archivo de registro de la instalación. De manera predeterminada, este archivo no se creó. Para crear el archivo del registro de la instalación y para encontrar los procesos que puedan estar causando el problema, siga estos pasos:
  1. Utilice uno de los procedimientos siguientes, según corresponda a su situación:
    • En Windows Vista, haga clic en Inicio
      Contraer esta imagenAmpliar esta imagen
      el botón Inicio
      , escriba run, escriba la ruta y el nombre de archivo del Service Pack o la actualización seguido de /log en el cuadro Iniciar búsqueda y, a continuación, presione Entrar.

      Contraer esta imagenAmpliar esta imagen
      Permiso de Control de cuentas de
					 usuario
      Si se le pide la contraseña del administrador o que confirme la acción, escriba la contraseña o haga clic en Continuar.
    • En Windows Vista, haga clic en Inicio, escriba run, escriba la ruta y el nombre de archivo del Service Pack o la actualización seguido de /log en el cuadro Abrir y, a continuación, haga clic en Aceptar.
    Por ejemplo, escriba lo siguiente en el cuadro Iniciar búsqueda o en el cuadro Abrir:
    rutaDeAcceso\nombreArchivo /log %temp%\Office2007SP1SetupLog.txt
    Notas
    • El marcador de posición rutaDeAcceso es la ruta de acceso completa al Service Pack o a la actualización. El marcador de posición nombreArchivo es el nombre del Service Pack o de la actualización.
    • En la carpeta Temp se guardarán varios archivos de texto. Para 2007 Office SP1, el archivo de registro relevante es MAINWWsp1.log.
  2. Abra el archivo de registro en un editor de texto, como el Bloc de notas.
  3. Busque el siguiente texto:
    being held in use
  4. Prosiga la búsqueda hasta que haya encontrado todas las ocurrencias del texto en el paso 3.
El texto del archivo de registro será similar al siguiente:
MSI (s) (5C:3C) [16:06:34:629]: Producto: Microsoft Office Enterprise 2007. The file C:\Program Files\Common Files\Microsoft Shared\OFFICE12\MSO.DLL is being held in use by the following process Name: GROOVE , Id 388.
El modificador de línea de comandos /log es compatible con un paquete de instalación de software, un paquete de actualización o un paquete de revisión. Estos paquetes se deben crear con Microsoft Self-Extractor. El modificador /log habilita el registro detallado en el archivo del registro de la instalación.

Para obtener más información acerca de los modificadores de la línea de comandos que son compatibles con Microsoft Self-Extractor, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
912203 Descripción de los modificadores de línea de comandos que son compatibles con un paquete de instalación de software, de actualización o de revisión que haya sido creado utilizando el autoextractor de Microsoft
Para obtener más información acerca de este problema en Outlook 2007, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
943590 Recibe un mensaje de error cuando intenta iniciar Outlook 2007 después de instalar 2007 Office Suite Service Pack 1: "El archivo Outlook.ost está en uso y no se puede tener acceso"

Propiedades

Id. de artículo: 942995 - Última revisión: viernes, 14 de diciembre de 2007 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Small Business 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office Groove 2007
  • Microsoft Office InfoPath 2007
  • Microsoft Office OneNote 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office SharePoint Designer 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Word 2007
Palabras clave: 
kbupdateissue kbtshoot kbpubtypekc kbexpertisebeginner kbprb KB942995

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com