Você é solicitado inesperadamente a reiniciar o computador após a instalação do service pack ou de uma atualização do 2007 Office System

Traduções deste artigo Traduções deste artigo
ID do artigo: 942995 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Após a instalação de um service pack ou de uma atualização do 2007 Office System, você é solicitado inesperadamente a reiniciar o computador.

Causa

Esse problema pode ocorrer se o service pack ou a atualização precisar modificar um arquivo em uso no momento. O arquivo é usado por um programa que está em execução quando você instala o service pack ou a atualização. Algumas vezes, o programa que está usando o arquivo não é do Office.

Esse problema pode ocorrer se uma ou mais das seguintes condições forem verdadeiras:
  • Um dispositivo que sincroniza com o Microsoft Outlook está encaixado com o computador cliente. Além disso, o ActiveSync está em execução.
  • Um programa do Office está em execução.
  • O Office Communicator 2005 ou Office Communicator 2007 está em execução.
  • O serviço do Office Groove 2007 (GrooveMonitor.exe) está em execução.
  • O serviço do Windows Desktop Search (Searchprotocolhost.exe) está em execução.
  • O Editor de método de entrada japonês está instalado.
Observação Esta lista não é abrangente. Outros programas também podem causar esse problema.

Resolução

Antes de instalar o service pack ou a atualização, saia de todos os programas ou serviços que estejam em execução e que possam interferir na instalação do service pack ou da atualização.

Os seguintes métodos fornecem informações sobre como sair dos programas e dos serviços que podem causar esse problema.

Como sair do ActiveSync

Para sair do ActiveSync, é necessário finalizar o processo Wcescomm.exe. Para finalizar o processo Wcescomm.exe, consulte a seção "Como finalizar um processo para um programa que está executando em segundo plano".

Observação Se um usuário ou um dispositivo estiver conectado ao serviço ActiveSync, o usuário ou o dispositivo será desconectado quando você finalizar o processo.

Como sair de um programa do Office

Para sair de um programa do Office, clique em Sair no menu Arquivo. Se o programa do Office não estiver visível na tela, pressione ALT+TAB para alternar para o programa do Office. Ou, clique no botão do programa do Office na barra de tarefas.

Observação Um processo de um programa do Office pode continuar executando em segundo plano se um problema fizer com que ele saia de maneira anormal. Se suspeitar que um processo de um programa do Office está em execução em segundo plano, encerre o processo. Para fazer isto, consulte a seção "Como finalizar um processo para um programa que está executando em segundo plano".

Como sair do Communicator 2005 ou do Communicator 2007

Para sair do Communicator 2005 ou do Communicator 2007, saia do Communicator, feche o programa e, em seguida, saia do programa. Para fazer isto, execute as seguintes etapas:
  1. No menu Connect, clique em Sign Out.
  2. No menu Connect clique em Close.

    Observação Ao fechar o Communicator 2005 ou o Communicator 2007, o programa é minimizado para a área de notificação.
  3. Clique com o botão direito do mouse no ícone do Communicator 2005 ou do Communicator 2007 na área de notificação e clique em Exit.

Como finalizar um processo para um programa que está executando em segundo plano

Importante Finalizar um processo pode causar resultados indesejados. Isso inclui instabilidade do sistema e perda de dados. Ao finalizar um processo, não existe a possibilidade de salvar seu estado ou outros dados antes de seu encerramento.

Para finalizar o processo para um programa que está executando em segundo plano, use um dos seguintes métodos.

Método 1: Use o Gerenciador de Tarefas

  1. Pressione CTRL+ALT+DEL.
  2. Na guia Processos, clique em nome_do_arquivo_do_processo e em Finalizar processo.

    Observação Nesse método, nome_do_arquivo_do_processo representa o nome do arquivo do processo que deseja finalizar.

Método 2: Use o comando Taskkill

  1. Clique em Iniciar, em Executar, digite cmd e clique em OK.
  2. No prompt de comando, digite taskkill /im nome_do_arquivo_do_processo e pressione ENTER.

    Observações
    • Nesse método,nome_do_arquivo_do_processo representa o nome do arquivo do processo que deseja finalizar.
    • Para obter informações adicionais sobre o comando Taskkill, digite taskkill /? no prompt de comando e pressione ENTER.
  3. No prompt de comando, digite exit para fechar a janela Prompt de comando.

Como impedir a reinicialização inesperada do computador ao implantar um service pack ou uma atualização do 2007 Office System

Se você for um administrador que está implantando um service pack ou uma atualização do Office, será possível usar um script para sair dos programas ou dos serviços que possam interferir na instalação do service pack ou da atualização.

A Microsoft fornece exemplos de programação apenas por questões ilustrativas, sem garantias expressas ou implícitas. Isto inclui, mas não está limitado a garantias implícitas de comercialização ou adequação a um determinado propósito. Este artigo pressupõe que você conhece a linguagem de programação demonstrada e também as ferramentas usadas para criar e depurar procedimentos. Os engenheiros de suporte da Microsoft podem ajudá-lo, fornecendo a explicação da funcionalidade de um determinado procedimento. Mas não modificarão estes exemplos para fornecer funcionalidades adicionais ou construir procedimentos específicos para atender às suas necessidades específicas.

Para usar um script para sair do programas ou dos serviços, crie um script semelhante ao seguinte.
; TechNet Sample 2005
; http://www.microsoft.com/technet/scriptcenter/resources/qanda/sept04/hey0927.mspx
; For more information about how to use scripts to manage processes, visit the following Microsoft Web site:
; http://www.microsoft.com/technet/scriptcenter/guide/sas_prc_overview.mspx

strComputer = "."
Set objWMIService = GetObject _
    ("winmgmts:\\" & strComputer & "\root\cimv2")
Set colProcessList = objWMIService.ExecQuery _
    ("Select * from Win32_Process Where Name = 'Communicator.exe'")
For Each objProcess in colProcessList
    objProcess.Terminate()
Next

Mais Informações

Normalmente, a instalação de um service pack do 2007 Office System ou de uma atualização não exige a reinicialização do computador. No entanto, existem situações nas quais é necessário reiniciar o computador.

Se for necessário reiniciar o computador após a instalação de um service pack ou de uma atualização do Office, as informações sobre a reinicialização serão incluídas na documentação que acompanha o service pack ou a atualização do Office.

Para determinar a causa da necessidade de reinicialização, revise os conteúdos do arquivo de log da instalação. Por padrão, esse arquivo não é criado. Para criar o arquivo de log da instalação e encontrar o processo que pode estar causando esse problema, execute as seguintes etapas:
  1. Faça uma das seguintes, conforme mais apropriado à situação:
    • No Windows Vista, clique em Iniciar
      Recolher esta imagemExpandir esta imagem
      no botão Iniciar
      , digite executar, digite o caminho e o nome do arquivo do service pack ou da atualização, seguido por /log na caixa Iniciar pesquisa e pressione ENTER.

      Recolher esta imagemExpandir esta imagem
      Permissão UAC
      Se for solicitada uma senha de administrador ou uma confirmação, digite a senha ou clique em Continuar.
    • No Windows XP, clique em Iniciar, em Executar, digite o caminho e o nome do arquivo do service pack ou da atualização seguido por /log na caixa Abrir e, em seguida, clique em OK.
    Por exemplo, digite o seguinte na caixa Iniciar pesquisa na caixa Abrir:
    caminho\nome_do_arquivo /log:%temp%\Office2007SP1SetupLog.txt
    Observações
    • O caminho é o espaço reservado para o caminho completo do service pack ou da atualização. O nome_do_arquivo é o espaço reservado para o nome do service pack ou da atualização.
    • Vários arquivos de textos serão salvos na pasta Temp. Para o Office 2007 SP1, o arquivo de log relevante é MAINWWsp1.log.
  2. Abra o arquivo de log em um editor de texto, como o Bloco de Notas.
  3. Pesquise pelo seguinte texto:
    being held in use
  4. Continue a pesquisa até que você tenha encontrado todas as ocorrências do texto na etapa 3.
O texto do arquivo de log será semelhante ao seguinte:
MSI (s) (5C:3C) [16:06:34:629]: Product: Microsoft Office Enterprise 2007. The file C:\Program Files\Common Files\Microsoft Shared\OFFICE12\MSO.DLL is being held in use by the following process Name: GROOVE , Id 388.
A opção de linha de comando /log tem suporte pelo pacote de instalação de software, por um pacote de atualização ou por um hotfix. Esses pacotes podem ser criados usando o Microsoft Self-Extractor. A opção /log habilita o registro detalhado no arquivo do log da instalação.

Para obter mais informações sobre as opções de linha de comando que têm suporte a pelo Microsoft Self-Extractor, clique no número abaixo para exibir o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
912203 Descrição das opções de linha de comando com suporte pelo pacote de instalação de software, pacote de atualização ou por um hotfix que foi criado usando o Microsoft Self-Extractor
Para obter mais informações sobre esse problema no Outlook 2007, clique no número abaixo para exibir o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
943590 Mensagem de erro ao tentar iniciar o Outlook 2007 após a instalação do 2007 Microsoft Office Suite Service Pack 1 (SP1): "Outlook.ost está em uso e não pode ser acessado"

Propriedades

ID do artigo: 942995 - Última revisão: quarta-feira, 12 de dezembro de 2007 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Small Business 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office Groove 2007
  • Microsoft Office InfoPath 2007
  • Microsoft Office OneNote 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office SharePoint Designer 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Word 2007
Palavras-chave: 
kbupdateissue kbtshoot kbpubtypekc kbexpertisebeginner kbprb KB942995

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com