Artigo: 943059 - Última revisão: segunda-feira, 26 de Novembro de 2007 - Revisão: 2.1

Talvez não consiga iniciar um executável quando arrastar vários ficheiros para um atalho num computador com o Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Arraste vários ficheiros para o atalho para um executável num computador com o Windows Vista. Neste caso, o executável é iniciado e a lista de ficheiros que são arrastadas é passada como uma lista de parâmetros da linha de comandos. No entanto, não é iniciado o executável em alguns casos.

Causa

Este problema ocorre se o comprimento dos caminhos combinados dos ficheiros que são arrastados exceder 260 caracteres.

Como contornar

Para contornar este problema, utilize um dos seguintes métodos:
  • Abra o Explorador do Windows e, em seguida, arraste os ficheiros para o executável no Explorador do Windows.
  • Inicie a aplicação e, em seguida, utilize um os seguintes métodos para abrir os ficheiros pretendidos:
    • Arraste o ficheiro para a janela da aplicação.
    • Utilize a aplicação para abrir o ficheiro.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbtshoot kbprb KB943059 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 943059  (http://support.microsoft.com/kb/943059/en-us/ )