You cannot install updates after a repair install of Windows XP or after Windows XP SP3 is installed immediately after a clean install of Windows XP SP2

Article ID: 943144 - View products that this article applies to.
If you are a Small Business customer, find additional troubleshooting and learning resources at the Support for Small Business site.

To continue receiving security updates for Windows, make sure you're running Windows XP with Service Pack 3 (SP3). For more information, refer to this Microsoft webpage: Support is ending for some versions of Windows

Expand all | Collapse all

On This Page

Symptoms

When you try to install Windows updates from the Windows Update website, the Microsoft Update website, or by using Automatic Update, you receive a message that the update is not installed successfully. Additionally, the update is not displayed in the update history.

You may experience this issue in the following scenarios:

Scenario 1

You try to install updates after you repair a Windows XP installation by using the Windows XP CD.

Scenario 2

You perform the following operations before you try to install Windows updates:
  1. You perform a new installation of Windows XP Service Pack 2 (SP2).
  2. You do not restart the computer.
  3. You go to the Windows Update website, or the Microsoft Update website.

    Collapse this imageExpand this image
    Note When you go to the update website, the latest version of Windows Update software will be installed on your computer.
  4. You install Windows XP Service Pack 3 (SP3).
  5. You try to install Windows updates after the installation of Windows XP SP3.
If you are experiencing other issues related to Windows Update, see the "More Information" section to find appropriate solutions.

Cause

This issue occurs because the Wups2.dll file that is included in the latest version of Windows Update is installed incorrectly.

For scenario 1, the registry entries that correspond to the Wups2.dll file are missing after the repair installation of Windows XP. The release version of Windows XP does not contain the Windows Update software.

For scenario 2, the registry entries that correspond to Windows Update are changed back to the Windows XP SP2 version if you did not restart the computer before you installed Windows XP SP3. The registry entries for the Wups2.dll file are changed to point to the Wups.dll file that is included in the release version of Windows XP SP2.

Resolution

To resolve this problem, use one of the following methods.

Method 1: Download and install the Windows Update Agent

How to determine whether you are running a 32-bit or a 64-bit edition of Windows
Collapse this imageExpand this image
To learn whether you are using a 32-bit version or 64-bit version of Windows, open System Information (Msinfo32.exe). Then, review the value that is listed for System Type. To do this, follow these steps:
  1. Click Start, and then click Run.
    Collapse this imageExpand this image
  2. Type msinfo32.exein the Open box, and then click OK or press ENTER.
    Collapse this imageExpand this image
  3. In System Information, review the value for System Type.
    • For 32-bit editions of Windows, the System Type value is x86-based PC.
    • For 64-bit editions of Windows, the System Type value is x64-based PC.
    Collapse this imageExpand this image

Collapse this imageExpand this image

The following files are available for download from the Microsoft Download Center:

For an x86-based computer
For an x64-based computer
For an Itanium-based computer

For more information about how to download the latest version of Windows Update Agent, click the following article number to view the article in the Microsoft Knowledge Base:
949104 How to obtain the latest version of the Windows Update Agent to help manage updates on a computer
Collapse this imageExpand this image

Method 2: Register the Wups2.dll file

To have us register the Wups2.dll file in Windows for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and then follow the steps in the Fix it wizard.
Collapse this imageExpand this image
Fix this problem
Microsoft Fix it 50597
Collapse this imageExpand this image

Collapse this imageExpand this image
Notes
  • This wizard may be only in English. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or to a CD. Then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

Collapse this imageExpand this image
To register the Wups2.dll file in Windows, follow these steps:
  1. Stop the Automatic Updates service. To do this, follow these steps:
    1. Open the Command Prompt window. To do this, click Start, click Run, type cmd, and then click OK.
      Collapse this imageExpand this image


      Collapse this imageExpand this image
    2. At the command prompt, type the following command, and then press ENTER:
      net stop wuauserv
      Collapse this imageExpand this image
  2. Register the Wups2.dll file. To do this, follow these steps:
    1. At the command prompt, type the following command, and then press ENTER:
      regsvr32 %windir%\system32\wups2.dll

      Collapse this imageExpand this image
      Note For a computer that is running Windows XP Professional x64 Edition, type the following command, and then press ENTER:
      regsvr32 %windir%\syswow64\wups2.dll
    2. Click OK if you receive a verification message.
    Collapse this imageExpand this image
  3. Start the Automatic Updates service. To do this, type the following command at the command prompt, and then press ENTER:
    net start wuauserv
    Collapse this imageExpand this image
  4. Exit the Command Prompt window. To do this, type exit at the command prompt, and then press ENTER.
    Collapse this imageExpand this image
Collapse this imageExpand this image

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

More information

Other Microsoft Knowledge Base articles that may help you resolve your Windows Update problem:
Collapse this imageExpand this image
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
958051 You may receive a "0x8007F0F4" error code when you try to install updates from the Windows Update website or from the Microsoft Update website
836941 You may encounter temporary connection-related errors when you use Windows Update or Microsoft Update to install updates
946414 Error when you download updates using Windows Update or Microsoft Update: 8000FFFF
910336 You receive a "0x80070002" or "0x80070003" error code after you download an update from Windows Update, from Microsoft Update, or from Windows Server Update Services
900936 Error code 0x8024402C when you try to install updates on Windows Update or Microsoft Update websites
958049 Error code when you use the Windows Update or Microsoft Update website to install updates: "0x8007066A"
919749 Error code 0x80245003 when you try to install updates from the Windows Update website or the Microsoft Update website
958052 You receive error code 0x80070643 or error code 0x643 when you use the Windows Update or Microsoft Update websites to install updates
910337 You may receive an error message that contains the "0x8DDD0018" code or the "0x80246008" code when you try to download updates from the Microsoft Windows Update website or from the Microsoft Update website
Collapse this imageExpand this image



For more information about how to troubleshoot Windows Update issues, click the following article numbers to view the articles in the Microsoft Knowledge Base:
910339 How to troubleshoot Windows Update or Microsoft Update when you are repeatedly offered an update
906602 How to troubleshoot common Windows Update, Microsoft Update, and Windows Server Update Services installation issues
306525 How to configure and use Automatic Updates in Windows XP
950718 How to troubleshoot an unsuccessful installation of Windows XP Service Pack 3

If this article cannot resolve your problem, click the following links to find more options:

Properties

Article ID: 943144 - Last Review: January 17, 2013 - Revision: 23.0
Applies to
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Home Edition, when used with:
    • Microsoft Windows XP Service Pack 2
    • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Media Center Edition 2004
  • Microsoft Windows XP Media Center Edition 2005
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbenv kbexpertisebeginner kbtshoot kbprb kbcip kbfixme kbmsifixme KB943144

Give Feedback