The TV screen appears as solid green or as blocky pixels when you use Windows Media Center to watch HDTV content on a Windows Vista-based computer

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Article ID: 943195 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You use Windows Media Center to watch high-definition television (HDTV) on a Windows Vista-based computer.
  • You have installed hotfix 932698 on the computer.
  • You do one of the following:
    • You switch the HDTV format between the 1080i format and the 720p format.
    • You open a different DVR-MS file.
    • You change the live TV programming to a different high-definition channel or to a different standard-definition channel.
In this scenario, the TV screen may appear as solid green, or it may appear as blocky pixels. This behavior continues until the next key frame is displayed.

CAUSE

This issue occurs because the Microsoft MPEG2 decoder does not correctly flush the previous key frames.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista, x86-based versions

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File nameFile versionFile sizeDateTimePlatform
X86_d39af18e3a88958fdca1439215ccdda7_31bf3856ad364e35_6.0.6000.20699_none_94c5ec71606373cd.manifestNot Applicable69912-Oct-200714:47Not Applicable
X86_microsoft-windows-msmpeg2vdec_31bf3856ad364e35_6.0.6000.20699_none_8f425452d439f8ff.manifestNot Applicable15,98612-Oct-200714:47Not Applicable
Msmpeg2vdec-ppdlic.xrm-msNot Applicable3,05312-Oct-200702:44Not Applicable
Msmpeg2vdec.dll11.0.6000.6344584,70412-Oct-200703:07x86

Windows Vista, 64-bit versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_e268a1cf34a970ce450089e6f8b7cc8f_31bf3856ad364e35_6.0.6000.20699_none_f32b98c43c39bee1.manifestNot Applicable1,04612-Oct-200714:47Not Applicable
Amd64_microsoft-windows-msmpeg2vdec_31bf3856ad364e35_6.0.6000.20699_none_eb60efd68c976a35.manifestNot Applicable16,01012-Oct-200714:54Not Applicable
X86_microsoft-windows-msmpeg2vdec_31bf3856ad364e35_6.0.6000.20699_none_8f425452d439f8ff.manifestNot Applicable15,98612-Oct-200714:54Not Applicable
Msmpeg2vdec-ppdlic.xrm-msNot Applicable3,05312-Oct-200703:55Not Applicable
Msmpeg2vdec.dll11.0.6000.6344725,50412-Oct-200704:02x64
Msmpeg2vdec-ppdlic.xrm-msNot Applicable3,05312-Oct-200702:44Not Applicable
Msmpeg2vdec.dll11.0.6000.6344584,70412-Oct-200703:07x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about key frames, click the following article number to view the article in the Microsoft Knowledge Base:
269068 Understanding frames per second (FPS)
HDTV programs are encoded by using certain formats, such as 720p and 1080i. The numeric value in the format reference refers to the number of lines that are embedded in the TV signal. The letter refers to the type of scan that the television uses to display the picture. The letter "i" means interlaced, and the letter "p" means progressive.

Properties

Article ID: 943195 - Last Review: May 20, 2008 - Revision: 2.1
APPLIES TO
  • Windows Vista Ultimate
  • Windows Vista Home Premium
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbexpertisebeginner kbhotfixserver kbqfe KB943195

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