You notice timing jitter and clock drift when you perform an editing operation or a playback operation on a MIDI audio device in Windows Vista

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Article ID: 943253 - View products that this article applies to.
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SYMPTOMS

On a computer that is running Windows Vista, you perform an editing operation or a playback operation on a MIDI audio device. When you do this, you may notice timing jitter and clock drift.

This problem occurs if the following conditions are true:
  • The MIDI device does not reside on the peripheral component interconnect (PCI) bus.
  • The MIDI device does not advertise any audio endpoints.

CAUSE

This problem occurs because the Dmusic.sys file was removed in Windows Vista. This file is a kernel mode synthesizer of the Microsoft DirectMusic components. This kernel mode synthesizer supplies the DirectMusic components with a high-resolution timer in operating systems that are earlier than Windows Vista.

When the synthesizer was removed, no other kernel mode component supported a DirectMusic clock. Therefore, Windows Vista uses the clock that is provided by the WinMM component.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. After you apply this hotfix, Windows Vista uses the QueryPerformanceCounter function from the user mode to provide a high resolution clock.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable1,77519-Nov-200723:05Not applicable
X86_5166fccd65d13f0f63837acd69d0c871_31bf3856ad364e35_6.0.6000.20723_none_878b61be7dd8eff5.manifestNot applicable70019-Nov-200723:05Not applicable
X86_microsoft-windows-audio-dmusic_31bf3856ad364e35_6.0.6000.20723_none_4484db1caba7621a.manifestNot applicable225,83519-Nov-200723:05Not applicable
Dmband.dll6.0.6000.2072330,20817-Nov-200704:10x86
Dmcompos.dll6.0.6000.2072362,97617-Nov-200704:10x86
Dmime.dll6.0.6000.20723178,68817-Nov-200704:10x86
Dmloader.dll6.0.6000.2072338,40017-Nov-200704:10x86
Dmscript.dll6.0.6000.2072384,48017-Nov-200704:10x86
Dmstyle.dll6.0.6000.20723105,47217-Nov-200704:10x86
Dmsynth.dll6.0.6000.20723105,47217-Nov-200704:10x86
Dmusic.dll6.0.6000.20723101,88817-Nov-200704:10x86
Dswave.dll6.0.6000.2072320,99217-Nov-200704:10x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 943253 - Last Review: May 19, 2008 - Revision: 2.1
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB943253

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