Budete vyzváni k zadání pověření při přístupu k serveru úplný název domény z počítače se systémem Windows Vista nebo Windows 7 a nakonfigurován žádný server proxy

Překlady článku Překlady článku
ID článku: 943280 - Produkty, které se vztahují k tomuto článku.

Podpora pro systém Windows Vista bez nějaké aktualizace service Pack nainstalována byla ukončena na 13. dubna 2010. Chcete-li pokračovat v přijímání aktualizací zabezpečení pro systém Windows, ujistěte se, že používáte systém Windows Vista s aktualizací Service Pack 2 (SP2). Další informace naleznete v této webové stránky společnosti Microsoft: Support is ending for some versions of Windows

Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Předpokládejme následující situaci.
  • V počítačích se systémem Windows Vista nebo Windows 7 nenakonfigurujete server proxy v aplikaci Windows Internet Explorer.
  • Protokol WebDAV (Web Distributed Authoring and Versioning) (WebDav) slouží k přístupu na web úplné doménové názvy (FQDN).
V tomto případě se zobrazí výzva k zadání pověření, přestože uživatelský účet, který používáte, má oprávnění pro přístup k tomuto webu.

Například při otevření souboru aplikace Microsoft Office z webu Microsoft Office SharePoint pomocí 2007 Microsoft Office v systému Windows Vista klientského počítače, který nemá žádné proxy konfigurován, budete vyzváni k ověření.

Poznámka: Tento problém se nevyskytuje počítače se systémem Windows XP.

Důležité Tato oprava hotfix je zahrnuta do aktualizace Windows Vista Service Pack 1 nebo novější aktualizace service pack. Musíte však stále nakonfigurovat položky registru AuthForwardServerList. Další informace naleznete v tématu v části informace v registru.

Příčina

Aplikace Internet Explorer v systému Windows Vista používá služba Webový klient při přístupu k prostředkům WebDAV pomocí aplikace Internet Explorer. Služby Webový klient používá k provedení vzdáleného hostitele v síti I/O Windows HTTP Services (WinHTTP). Služba WinHTTP odešle pověření uživatele pouze v odpovědi na požadavky, ke kterým dochází na místním intranetovém webu. Služba WinHTTP nekontroluje nastavení zóny zabezpečení v aplikaci Internet Explorer, chcete-li zjistit, zda webový server je v zóně umožňující pověření automaticky odeslána.

Pokud je nakonfigurován žádný server proxy, odešle služba WinHTTP pověření pouze webů v místní síti intranet.

Poznámka: Pokud adresa URL obsahuje žádné období v poli Název serveru, například v následujícím příkladu serveru se považuje za na místním intranetovém webu:
http://SharePoint/davshare


Pokud adresa URL obsahuje období, serveru se považuje za v síti Internet. Období označit tak, že můžete použít adresu FQDN. Proto žádná pověření jsou automaticky odeslaných na tento server je nastaven server proxy, a pokud tento server je označen pro obcházení serveru proxy.

Poznámka: Server může uvést pro obcházení serveru proxy buď prostřednictvím seznamu vynechaných serverů nebo pomocí skriptu konfigurace serveru proxy.

V tomto případě se zobrazí výzva k zadání pověření při požaduje pověření na webu. Nastavení zóny zabezpečení i v takovém případě ignorovány.

Řešení

Oprava je zahrnuta v systému Windows 7. Chcete-li problém vyřešit, potřebujete pouze vytvořit níže uvedenou položku registru.

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo řešení potíží je vyžadován, pravděpodobně budete muset vytvořit požadavek na samostatnou službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "K dispozici oprava Hotfix stahování" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Nejsou žádné požadavky nutné pro instalaci této opravy hotfix.

Požadavek na restartování

Bude nutné po instalaci této restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o registru

Chcete-li použít tuto opravu hotfix, musíte upravit registr.
Důležité Tento oddíl, metody nebo úkol obsahuje kroky, které vám sdělit, jak upravit registr. Po nesprávné úpravě registru však mohou nastat závažné problémy. Postupujte proto pečlivě podle uvedených kroků. Pro zvýšení bezpečnosti registr zálohujte jestě před jeho úpravami. Potom můžete v případě potíží registr obnovit. Další informace o zálohování a obnovení registru naleznete následujícím článku znalostní v databáze Microsoft Knowledge Base:
322756Zálohování a obnovení registru v systému Windows
Po instalaci této opravy hotfix, musíte vytvořit položku registru. Postupujte takto:
  1. Klepněte na tlačítko Start, do pole Zahájit hledání zadejte příkaz regedit a stiskněte klávesu ENTER.
  2. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  3. V nabídce Úpravy přejděte na příkaz Nový a pak klepněte na položku Víceřetězcová hodnota.
  4. Zadejte AuthForwardServerList a stiskněte klávesu ENTER.
  5. V nabídce Úpravy klepněte na příkaz změnit.
  6. V Hodnota dat , zadejte adresu URL serveru, který je hostitelem sdílení webové a potom klepněte na tlačítko OK.

    Poznámka: Můžete také zadat seznam adres URL v Hodnota dat pole. Další informace naleznete v části "Seznam URL vzorové" v tomto článku.
  7. Ukončete program Editor registru.
Po vytvoření této položky registru služby Webový klient přečte hodnotu položky. Pokud klientský počítač pokusí přístup adresu URL, která odpovídá některé výrazy v seznamu, uživatelských pověření budou odeslány úspěšně ověřit uživatele, i když je nakonfigurováno žádné proxy.

Poznámka: Budete muset po úpravě registru restartujte službu Webový klient.

Adresa URL seznamu vzorku

Následuje seznam URL vzorku:
https://*.Contoso.com
http://*.dns.live.com
*.microsoft.com
https://172.169.4.6
tuto adresu URL seznamu umožňuje v něm tuto službu k odeslání pověření následující cestou.

Poznámka: Po konfiguraci tohoto seznamu URL pověření automaticky ověří na servery WebDAV, i když jsou tyto servery v síti Internet.
  • Šifrovaný kanál je podřízená doména domény, jehož název je contoso.com.
  • Nezabezpečené kanál je podřízená doména domény, jehož název je dns.live.com.
  • Žádný kanál k serveru, jejichž název končí ". microsoft.com. „
  • Šifrovaný kanál hostitele, jehož adresa IP je 172.169.4.6.

Způsoby předejít v seznamu Adresa URL

  • Znak hvězdička ** nepřidávejte na konci adresy URL. Pokud tak učiníte, může způsobit bezpečnostní riziko.
    http://*.DNS.live.*
  • Hvězdička ** přidat před nebo za řetězec. Když toto provedete, služba Webový klient může zasílat pověření uživatele další servery. Příklady:
    • http://*Contoso.com

      V tomto příkladu bude služba také odesílat pověření uživatele http:// extra_characters contoso.com
    • http://Contoso*.com

      V tomto příkladu bude služba také odesílat pověření uživatele http://Contoso extra_characters .com
  • V seznamu URL nezadávejte název UNC hostitele. Například nepoužívejte následující:
    *.contoso.com@SSL
  • V seznamu URL nezahrnujte název sdílené položky nebo čísla portu, který má být použit. Například nepoužívejte následující:
    • http://*.DNS.live.com/DavShare
    • http://*DNS.live.com:80
  • V seznamu URL nepoužívejte IPv6.
Důležité Tento seznam URL nemá vliv na nastavení zóny zabezpečení. Tento seznam URL se používá pouze pro konkrétní účel předávání pověření pro servery WebDAV. Seznam by měl být vytvořen jako restriktivně co nejvíce zabránit problémy se zabezpečením. Rovněž protože neexistuje žádné zvláštní odepřít seznamu, pověření jsou předávány všechny servery, které odpovídají tomuto seznamu.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním časem a UTC časem kartě časové pásmo v položce datum a čas v Ovládacích panelech.
Windows Vista, verze pro počítače s procesory x86
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
davclnt.dll6.0.6000.2072948,64029. 11. 200704: 07X86
Mrxdav.sys6.0.6000.20729112,64029. 11. 200702: 02X86
Webclnt.dll6.0.6000.20729196,09629. 11. 200704: 09.Nelze použít
Windows Vista, verze platformy x64
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
davclnt.dll6.0.6000.2072966,56029. 11. 200705: 03X64
Mrxdav.sys6.0.6000.20729136,70429. 11. 200702: 12X64
Webclnt.dll6.0.6000.20729212,99229. 11. 200705: 05X64
davclnt.dll6.0.6000.2072948,64029. 11. 200704: 07X86
Webclnt.dll6.0.6000.20729196,09629. 11. 200704: 09.Nelze použít

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 943280 - Poslední aktualizace: 18. března 2010 - Revize: 5.1
Informace v tomto článku jsou určeny pro produkt:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Klíčová slova: 
kbmt kbautohotfix kbfix kbexpertiseadvanced kbqfe kbhotfixserver KB943280 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:943280

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com