You cannot unlock a Windows Vista-based computer after you log on to an Active Directory domain

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Article ID: 943440 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario.
  • On a Windows Vista-based computer, you log on to an Active Directory domain in a forest by using a user account in this domain.
  • The Windows Vista-based computer belongs to another domain in this forest.
  • You lock the Windows Vista-based computer.
In this scenario, you cannot unlock the computer by entering the account password.

This issue occurs if the following conditions are true.
  • You configure the "Assign a default domain for logon" Group Policy setting, and then you set the domain to which you log on as the default domain.
  • You log on to the domain from the Windows Vista-based computer by entering the user name without including the domain name.

CAUSE

This problem occurs because of a timing issue.

During the logon process, the "Assign a default domain for logon" Group Policy setting may not be applied. In this situation, when the logon process queries Group Policy, the process cannot find the "Assign a default domain for logon" Group Policy setting. Then, Windows Vista assumes that the user is logging on by using the credentials from the same domain as the domain to which the computer belongs. This combination of domain name and user name is saved. Later, when you try to unlock the computer, the saved domain name and the saved user name, together with the password that you enter, are used as the credentials to verify the unlock operation. Because the user account does not belong to the domain to which the computer belongs, verification fails. Therefore, the computer cannot be unlocked.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable2,01608-Oct-200716:23Not Applicable
X86_63006ce6ad8eb30841beb31c327c1ac9_31bf3856ad364e35_6.0.6000.20695_none_fbcc1f3e3f642969.manifestNot Applicable70908-Oct-200716:23Not Applicable
X86_microsoft-windows-authentication-authui_31bf3856ad364e35_6.0.6000.20695_none_0a3a8b7c11a36dd5.manifestNot Applicable59,31008-Oct-200716:23Not Applicable
Authui.dll6.0.6000.206951,984,51206-Oct-200702:57x86
Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_63006ce6ad8eb30841beb31c327c1ac9_31bf3856ad364e35_6.0.6000.20695_none_57eabac1f7c19a9f.manifestNot Applicable71108-Oct-200716:23Not Applicable
Amd64_fe83d3517814b18e6fc7b2ef7fa1db28_31bf3856ad364e35_6.0.6000.20695_none_5986008e31433652.manifestNot Applicable71308-Oct-200716:23Not Applicable
Amd64_microsoft-windows-authentication-authui_31bf3856ad364e35_6.0.6000.20695_none_665926ffca00df0b.manifestNot Applicable59,36808-Oct-200716:27Not Applicable
Package_1_for_kb943440~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,80808-Oct-200716:23Not Applicable
Package_2_for_kb943440~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,02708-Oct-200716:23Not Applicable
Update.mumNot Applicable1,92508-Oct-200716:23Not Applicable
Authui.dll6.0.6000.206952,270,72006-Oct-200703:52x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

The "Assign a default domain for logon" Group Policy setting was introduced in Windows Vista. This Group Policy setting specifies a default logon domain that may differ from the domain to which the computer belongs. If this Group Policy setting is not configured, and if a user does not specify a domain on which to log on during the logon process, the domain to which the computer belongs is presumed to be the default domain. For example, if the computer belongs to the Fabrikam domain, the default domain to which the user logs on is Fabrikam.

To configure an "Assign a default domain for logon" Group Policy object, follow these steps:
  1. Open the Group Policy Object Editor.
  2. In the Group Policy Object Editor console tree, expand Administrative Template, expand System, expand Logon, and then double-click Assign a default domain for logon.
  3. On the Setting tab, click Enabled, and then enter the domain name in the Default Logon Domain box.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 943440 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbexpertisebeginner kbexpertiseadvanced kbfix kbqfe kbHotfixServer KB943440

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