Když vyprší platnost lístku Kerberos pro ověřování Kerberos SMB připojení, která je vytvořena na serveru se systémem Windows Server 2003, nelze poškozený oplock na souboru včas

Překlady článku Překlady článku
ID článku: 943459 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Předpokládejme následující situaci:
  • Klient vytvoří připojení k serveru zprávu blok (SMB) k serveru se systémem Windows Server 2003 pomocí ověřovací protokol Kerberos verze 5.
  • Soubor je otevřen přes toto připojení SMB. Oportunistický zámek (oplock) je nastavena na souboru.
  • Po dobu dlouhý nečinnosti platnost lístku Kerberos.
V tomto scénáři server pokusí přerušením oplock. Však dochází k dlouhé prodlevě před oplock nakonec rozdělena na serveru. Navíc klient obdrží chybu "status_network_session_expired".

Příčina

Server odešle požadavek klienta přerušením oplock. Na tento požadavek se potom odpoví klient. Server vrátí chybu "status_network_session_expired" namísto zpracování odpověď klienta, protože relace již vypršela. Klient nemůže však reauthenticate se serverem. V této situaci server má čekat dlouho oplock časový limit.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li použít tuto opravu hotfix, musí mít Windows Server 2003 Service Pack 1 nebo Windows Server 2003 Service Pack 2 v počítači nainstalována. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
889100Jak získat nejnovější aktualizaci Service Pack pro systém Windows Server 2003

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Windows Server 2003 s aktualizací Service Pack 1 pro procesory x86
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Srv.sys5.2.3790.3076361,47222. Ledna 200811: 08X86
Windows Server 2003 Service Pack 2, x 86 verze
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Srv.sys5.2.3790.4222358,40022. Ledna 200811: 18X86
Windows Server 2003 s aktualizací Service Pack 1 pro procesory Itanium
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Srv.sys5.2.3790.30761,110,52822. Ledna 200815: 56IA-64
Windows Server 2003 Service Pack 2 pro procesory Itanium
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Srv.sys5.2.3790.42221,111,04022. Ledna 200816: 18IA-64
Windows Server 2003 s aktualizací Service Pack 1 pro procesory x64
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Srv.sys5.2.3790.3076674,30422. Ledna 200815: 49X64
Windows Server 2003 Service Pack 2 pro verze x 64
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Srv.sys5.2.3790.4222647,68022. Ledna 200816: 19X64

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Jak potíže obejít

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které sdělit, jak upravit registr. Po nesprávné úpravě registru však mohou nastat závažné problémy. Postupujte proto pečlivě podle uvedených kroků. Pro zvýšení bezpečnosti registr zálohujte jestě před jeho úpravami. Potom můžete v případě potíží registr obnovit. Další informace o zálohování a obnovení registru naleznete následujícím článku znalostní v databáze Microsoft Knowledge Base:
322756Zálohování a obnovení registru v systému Windows
Tento problém vyřešit, snižte hodnotu časového limitu break oplock zkrátit dobu server čeká před menší než 35 sekund přeruší oplock. Však musíte být velmi opatrní při použití tohoto řešení, protože toto řešení může způsobit záporné efekty, například ztrátu dat uložených v mezipaměti v závislosti na prostředí.

Chcete-li změnit hodnotu časového limitu break oplock, postupujte takto:
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.
  2. Vyhledejte následující podklíč registru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. Podle situace použijte jednu z následujících možností:
    1. Pokud položka registru LanmanServer je k dispozici pod podklíč Parameters, přejděte ke kroku 5.
    2. Položka registru LanmanServer není k dispozici, je nutné vytvořit tuto položku. Chcete-li to provést, klepněte pravým tlačítkem myši na podklíč parametry, přejděte na příkaz Nový a klepněte na příkaz Hodnota DWORD.
  4. Zadejte LanmanServer a stiskněte klávesu ENTER.
  5. Klepněte pravým tlačítkem myši LanmanServer a potom klepněte na příkaz změnit.
  6. V poli Údaj hodnoty zadejte odpovídající hodnotu a klepněte na tlačítko OK.
  7. Ukončete program Editor registru.
  8. Restartujte počítač.
Poznámka: Položka registru LanmanServer Určuje dobu, po kterou server čeká na odpověď na požadavek break oplock klienta. Ve výchozím nastavení server čeká 35 sekund před konce oplock podle vynutit. Můžete zadat nižší hodnotu tato položka registru snížit dobu čekání. Kratší doba čekání však může potenciálně způsobit ztrátu dat uložených v mezipaměti. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
296264Konfigurace příležitostného zamykání v systému Windows

Další informace

Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 943459 - Poslední aktualizace: 13. července 2009 - Revize: 2.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Klíčová slova: 
kbmt kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB943459 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:943459

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com