Das Kerberos-Ticket für eine Kerberos-Authentifizierung von SMB-Verbindung läuft ab, die auf einen Windows 2003-Server erstellt wird, kann nicht Oplock auf eine Datei in einem angemessenen aufgeteilt werden

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Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Ein Client erstellt eine Server Message Block (SMB) Verbindung zu einem Windows 2003-Server mithilfe des Authentifizierungsprotokoll Kerberos Version 5.
  • Eine Datei ist über das SMB-Verbindung geöffnet. Eine opportunistische Sperre (Oplock) wird auf die Datei festgelegt.
  • Nach einer Zeit lang im Leerlauf läuft das Kerberos-Ticket.
In diesem Szenario versucht der Server die Oplock break. Allerdings tritt eine Verzögerung vor der Oplock schließlich auf dem Server unterbrochen wird. Darüber hinaus erhält der Client einen Fehler "Status_network_session_expired".

Ursache

Der Server sendet eine Anforderung an den Client der Oplock aufheben. Dann antwortet der Client auf diese Anforderung. Der Server gibt stattdessen Verarbeitung der Antwort-Client den "Status_network_session_expired"-Fehler zurück, da die Sitzung bereits abgelaufen ist. Der Client kann nicht jedoch mit dem Server erneut authentifiziert. In diesem Fall muss der Server lange für die Oplock-Timeouts warten.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix installieren, muss Windows Server 2003 Service Pack 1 oder Windows Server 2003 Service Pack 2 auf dem Computer installiert sein. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Server 2003 mit Service Pack 1, x 86-basierte Versionen
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
SRV.sys5.2.3790.3076361.47222-Jan 200811: 08X 86
Windows Server 2003 mit Service Pack 2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
SRV.sys5.2.3790.4222358,40022-Jan 200811: 18X 86
Windows Server 2003 mit Service Pack 1, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
SRV.sys5.2.3790.30761,110,52822-Jan 200815: 56IA-64
Windows Server 2003 mit Service Pack 2, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
SRV.sys5.2.3790.42221,111,04022-Jan 200816: 18IA-64
Windows Server 2003 mit Service Pack 1, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
SRV.sys5.2.3790.3076674,30422-Jan 200815: 49X 64
Windows Server 2003 mit Service Pack 2, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
SRV.sys5.2.3790.4222647,68022-Jan 200816: 19X 64

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Abhilfe

wichtig In diesem Abschnitt, Methode oder Aufgabe enthält Hinweise zum Ändern der Registrierung. Allerdings können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie daher sicher, dass Sie diese Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie der Registrierung, bevor Sie ihn ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756Zum Sichern und Wiederherstellen der Registrierung in Windows
Dieses Problem zu umgehen, reduzieren Sie den Timeoutwert Oplock Break auf weniger als 35 Sekunden die Zeit verringern, die der Server, bevor es wartet unterbricht eine Oplock. Allerdings müssen Sie sehr vorsichtig sein wenn Sie diese Problemumgehung verwenden da diese Problemumgehung negative Effekte wie Verlust zwischengespeicherter Daten je nach Umgebung verursachen kann.

Gehen Sie folgendermaßen vor um Oplock Break Timeoutwert zu ändern:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Suchen Sie den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. Verwenden Sie für Ihre Situation eine der folgenden Optionen:
    1. Wenn der OplockBreakWait Registrierungseintrag unter dem Unterschlüssel Parameter verfügbar ist, gehen Sie zu Schritt 5.
    2. Wenn der OplockBreakWait-Registrierungseintrag nicht verfügbar ist, müssen Sie diesen Eintrag erstellen. Dazu müssen, klicken Sie mit der rechten Maustaste auf den Parameter-Unterschlüssel, zeigen Sie auf neu , und klicken Sie dann auf DWORD-Wert .
  4. Geben Sie OplockBreakWait , und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie mit der rechten Maustaste auf OplockBreakWait , und klicken Sie dann auf Ändern .
  6. Geben Sie in das Feld Wertdaten einen entsprechenden Wert ein und klicken Sie dann auf OK .
  7. Beenden Sie den Registrierungs-Editor.
  8. Starten Sie den Computer neu.
Hinweis: Der Registrierungseintrag OplockBreakWait gibt die Zeit, die der Server einem Client zu reagieren auf eine Oplock Break-Anforderung wartet. Standardmäßig wartet der Server 35 Sekunden, bevor es durch erzwingen eine Oplock unterbrochen. Sie können einen niedrigeren Wert für diesen Registrierungseintrag, um die Wartezeit zu reduzieren angeben. Eine kürzere Wartezeit kann jedoch potenziell Verlust der zwischengespeicherten Daten führen. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
296264Konfigurieren von opportunistischem Sperren in Windows

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 943459 - Geändert am: Montag, 13. Juli 2009 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 943459
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