Quando o Kerberos expira para uma ligação SMB autenticado por Kerberos que é criada para um servidor baseado no Windows Server 2003, o "oplock" num ficheiro não pode ser dividido atempadamente

Traduções de Artigos Traduções de Artigos
Artigo: 943459 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere o seguinte cenário:
  • Um cliente cria uma ligação de bloco (SMB) de mensagem do servidor a um servidor baseado no Windows Server 2003 utilizando o protocolo de autenticação Kerberos versão 5.
  • Um ficheiro é aberto através desta ligação SMB. Um bloqueio oportunista (oplock) é definido no ficheiro.
  • Após um período de tempo inactivo tempo, o Kerberos expira.
Neste cenário, o servidor tenta dividir o "oplock". No entanto, um longo atraso ocorre antes do oplock eventualmente é dividido no servidor. Além disso, o cliente recebe um erro de "status_network_session_expired".

Causa

O servidor envia um pedido para o cliente para dividir o "oplock". Em seguida, o cliente responder a este pedido. O servidor devolve o erro "status_network_session_expired" em vez de processar a resposta de cliente porque a sessão já expirou. No entanto, o cliente não é possível autenticar novamente com o servidor. Nesta situação, o servidor tem de esperar muito tempo para o "oplock" limite de tempo.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para aplicar esta correcção, tem de ter Windows Server 2003 Service Pack 1 ou Windows Server 2003 Service Pack 2 instalado no computador. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
889100Como obter o service pack mais recente do Windows Server 2003

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Windows Server 2003 com Service Pack 1, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
SRV.sys5.2.3790.3076361,47222 De Janeiro de 200811: 08x 86
Windows Server 2003 com Service Pack 2, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
SRV.sys5.2.3790.4222358,40022 De Janeiro de 200811: 18x 86
Windows Server 2003 com Service Pack 1, versões baseadas em Itanium
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
SRV.sys5.2.3790.30761,110,52822 De Janeiro de 200815: 56IA-64
Windows Server 2003 com Service Pack 2, versões baseadas em Itanium
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
SRV.sys5.2.3790.42221,111,04022 De Janeiro de 200816: 18IA-64
Windows Server 2003 com Service Pack 1, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
SRV.sys5.2.3790.3076674,30422 De Janeiro de 200815: 49x 64
Windows Server 2003 com Service Pack 2, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
SRV.sys5.2.3790.4222647,68022 De Janeiro de 200816: 19x 64

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Como contornar

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows
Para contornar este problema, reduzir o valor de limite de tempo de quebra de oplock para menor do que 35 segundos para reduzir o tempo que o servidor aguarda antes interrompe um oplock. No entanto, tem de ter muito cuidado quando utiliza esta solução alternativa, uma vez que esta solução alternativa pode causar efeitos negativos, tais como perda de dados em cache, dependendo do ambiente.

Para alterar o valor de limite de tempo de quebra de oplock, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. Utilize uma das seguintes opções, conforme for adequado à sua situação:
    1. Se a entrada de registo OplockBreakWait estiver disponível na subchave de parâmetros, avance para o passo 5.
    2. Se a entrada de registo OplockBreakWait não estiver disponível, tem de criar esta entrada. Para efectuar este procedimento, com o botão direito do rato a subchave de parâmetros, aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  4. Escreva OplockBreakWait e, em seguida, prima ENTER.
  5. Clique com o botão direito do rato OplockBreakWait e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , escreva um valor apropriado e, em seguida, clique em OK .
  7. Saia do Editor de registo.
  8. Reinicie o computador.
Nota A entrada de registo OplockBreakWait Especifica o tempo que o servidor aguarda por um cliente responder a um pedido de quebra de bloqueio opcional. Por predefinição, o servidor aguarda 35 segundos antes-divide um oplock por força. Pode especificar um valor inferior para esta entrada de registo reduzir o tempo de espera. No entanto, um tempo de espera inferior poderá potencialmente causar perda de dados em cache. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
296264Configurar o bloqueio oportunista no Windows

Mais Informação

Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 943459 - Última revisão: 13 de julho de 2009 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB943459 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 943459

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com