A memory leak occurs in the Msctf.dll component when you use a WebBrowser control application in Windows XP, in Windows Server 2003, or in Windows Vista

Article translations Article translations
Article ID: 943510 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You have a computer that is running Windows XP or Windows Server 2003.
  • You run a WebBrowser control application for a long time.
In this scenario, you may notice that system performance drops significantly. Additionally, if you use a performance monitor tool to monitor the system's performance, you find evidence of a memory leak in the Msctf.dll component.

This issue occurs if the following conditions are true:
  • Under Regional and Language Options in Control Panel, you click to clear the Turn off advanced text services check box.
  • The value of the LoadIMM registry entry is set to 1 in hexadecimal format.

    Note This registry entry is located under the following subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\IMM
You may also encounter this problem on a computer that is running Windows Vista.

CAUSE

This problem occurs because of an error in the Msctf.dll component.

Memory allocation in the Msctf.dll component increases every time that a new focused window is created by the WebBrowser control application. However, the memory is not freed when these windows are destroyed. Therefore, a memory leak occurs if the application frequently creates and destroys child windows.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Msctf.dll5.1.2600.3253297,98415-Nov-200711:12x86SP2
Msctfime.ime5.1.2600.3253177,15215-Nov-200711:12Not ApplicableSP2

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or later versions installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Msctf.dll5.2.3790.3044318,97615-Nov-200711:22x86SP1
Msctfime.ime5.2.3790.3044177,15215-Nov-200711:22Not ApplicableSP1
Windows Server 2003 with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Msctf.dll5.2.3790.4189317,44015-Nov-200711:41x86SP2
Msctfime.ime5.2.3790.4189177,15215-Nov-200711:41Not ApplicableSP2
Windows Server 2003 with SP1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msctf.dll5.2.3790.3044634,88015-Nov-200709:25x64SP1Not Applicable
Msctfime.ime5.2.3790.3044361,47215-Nov-200709:25Not ApplicableSP1Not Applicable
Wmsctf.dll5.2.3790.3044318,97615-Nov-200709:25x86SP1WOW
Wmsctfime.ime5.2.3790.3044177,15215-Nov-200709:25Not ApplicableSP1WOW
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msctf.dll5.2.3790.4189634,88015-Nov-200709:32x64SP2Not Applicable
Msctfime.ime5.2.3790.4189361,47215-Nov-200709:32Not ApplicableSP2Not Applicable
Wmsctf.dll5.2.3790.4189317,44015-Nov-200709:32x86SP2WOW
Wmsctfime.ime5.2.3790.4189177,15215-Nov-200709:32Not ApplicableSP2WOW
Windows Server 2003 with SP1, Itanium-based
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msctf.dll5.2.3790.30441,010,17615-Nov-200709:25IA-64SP1Not Applicable
Msctfime.ime5.2.3790.3044562,68815-Nov-200709:25Not ApplicableSP1Not Applicable
Wmsctf.dll5.2.3790.3044318,97615-Nov-200709:25x86SP1WOW
Wmsctfime.ime5.2.3790.3044177,15215-Nov-200709:25Not ApplicableSP1WOW
Windows Server 2003 with SP2, Itanium-based
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msctf.dll5.2.3790.41891,010,17615-Nov-200709:31IA-64SP2Not Applicable
Msctfime.ime5.2.3790.4189562,68815-Nov-200709:31Not ApplicableSP2Not Applicable
Wmsctf.dll5.2.3790.4189317,44015-Nov-200709:31x86SP2WOW
Wmsctfime.ime5.2.3790.4189177,15215-Nov-200709:31Not ApplicableSP2WOW

Windows Vista

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista , x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable2,02225-Oct-200714:57Not Applicable
X86_41b86ffd2ff4a55b705c0d02d56561c5_31bf3856ad364e35_6.0.6000.20708_none_e358401f0f36caba.manifestNot Applicable71525-Oct-200714:57Not Applicable
X86_microsoft-windows-t..icesframework-msctf_31bf3856ad364e35_6.0.6000.20708_none_746f108f0ab4f32a.manifestNot Applicable31,87325-Oct-200714:57Not Applicable
Msctf.dll6.0.6000.20708805,88825-Oct-200703:13x86
Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_1574ff0ac19edf22c3db161c4af62e23_31bf3856ad364e35_6.0.6000.20708_none_875cc26cd71ccce2.manifestNot Applicable71925-Oct-200714:57Not Applicable
Amd64_41b86ffd2ff4a55b705c0d02d56561c5_31bf3856ad364e35_6.0.6000.20708_none_3f76dba2c7943bf0.manifestNot Applicable71725-Oct-200714:57Not Applicable
Amd64_microsoft-windows-t..icesframework-msctf_31bf3856ad364e35_6.0.6000.20708_none_d08dac12c3126460.manifestNot Applicable31,89725-Oct-200715:00Not Applicable
Package_1_for_kb943510~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,81425-Oct-200714:57Not Applicable
Package_2_for_kb943510~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,03325-Oct-200714:57Not Applicable
Update.mumNot Applicable1,92525-Oct-200714:57Not Applicable
Msctf.dll6.0.6000.207081,052,67225-Oct-200704:04x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about the WebBrowser control, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/aa752040.aspx
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824994 Description of the contents of Windows XP Service Pack 2 and Windows Server 2003 software update packages


For help with system performance issues in Windows Vista, visit the following Microsoft web page:
Problems with overall system speed and system performance

Properties

Article ID: 943510 - Last Review: May 16, 2008 - Revision: 2.2
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB943510

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com