A computer that is running Windows XP Tablet PC Edition 2005 unexpectedly enters standby or hibernation when you operate a digitizer device or a touchscreen device

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Article ID: 943856 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario
  • You use a computer that is running Windows XP Tablet PC Edition 2005.
  • You connect a USB digitizer device or a USB touchscreen device to the computer by using a standard Human Interface Devices (HID) configuration.
In this scenario, Windows XP Tablet PC Edition 2005 unexpectedly changes the system state to standby (S3) or to hibernation (S4) when you operate the digitizer device or the touchscreen device.

CAUSE

Under a standard Human Interface Devices (HID) configuration, the Hidclass.sys system drive is used when you operate a digitizer device or a touchscreen device that uses a USB connection. However, the Hidclass.sys system drive does not reset the sleep timer even when the digitizer device or the touchscreen device is being used. Therefore, Windows XP Tablet PC Edition 2005 enters standby or hibernation in this scenario.

RESOLUTION

After you apply this hotfix, the Wisptis.exe file and the Tpgwlnot.dll file will reset the sleep timer when the digitizer device or the touchscreen device is being used.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You can apply this hotfix only on a Tablet PC on which Windows XP Tablet PC Edition 2005 Service Pack 2 is installed.
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Tablet PC Edition 2005
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File nameFile versionFile sizeDateTimePlatform
Tpgwlnot.dll1.7.2600.323732,25622-Oct-200703:07x86
Wisptis.exe1.7.2600.3237293,88818-Oct-200711:47x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 943856 - Last Review: November 2, 2007 - Revision: 1.1
APPLIES TO
  • Microsoft Windows XP Tablet PC Edition 2005
Keywords: 
kbautohotfix kbhotfixserver kbqfe KB943856

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