Windows XP Tablet PC Edition 2005 を実行しているコンピュータで、デジタイザ デバイスまたはタッチスクリーン デバイスを操作すると予期せずスタンバイ状態または休止状態になる

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文書番号: 943856 - 対象製品
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目次

現象

次のような状況で問題が発生します。
  • Windows XP Tablet PC Edition 2005 を実行しているコンピュータを使用します。
  • 標準のヒューマン インターフェイス デバイス (HID) 構成を使用して、USB デジタイザ デバイスまたは USB タッチスクリーン デバイスをコンピュータに接続します。
この状況で、デジタイザ デバイスまたはタッチスクリーン デバイスを操作すると、Windows XP Tablet PC Edition 2005 が予期せずスタンバイ状態 (S3) または休止状態 (S4) に変わります。

原因

標準のヒューマン インターフェイス デバイス (HID) 構成では、USB 接続を使用するデジタイザ デバイスまたはタッチスクリーン デバイスを操作すると、システム ドライバ Hidclass.sys が使用されます。しかし、デジタイザ デバイスまたはタッチスクリーン デバイスを使用しても、システム ドライバ Hidclass.sys によってスリープ タイマがリセットされません。そのため、Windows XP Tablet PC Edition 2005 がスタンバイ状態または休止状態になります。

解決方法

この修正プログラムを適用すると、デジタイザ デバイスまたはタッチスクリーン デバイスを使用したときに、Wisptis.exe ファイルおよび Tpgwlnot.dll ファイルによりスリープ タイマがリセットされます。

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Online Customer Services にオンライン リクエストを送信し、修正プログラムを入手します。オンライン リクエストを送信して修正プログラムを入手するには、次のマイクロソフト Web ページを参照してください。
http://go.microsoft.com/?linkid=6294451
: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成することが必要になる場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。別のサービス リクエストを作成するには、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support

必要条件

この修正プログラムは、Windows XP Tablet PC Edition 2005 Service Pack 2 がインストールされている Tablet PC にのみ適用できます。
322389 最新の Windows XP Service Pack を入手する方法

再起動の必要性

この修正プログラムの適用後、コンピュータを再起動する必要があります。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。

ファイル情報

Windows XP Tablet PC Edition 2005
元に戻す全体を表示する
ファイル名バージョン日付時刻サイズプラットフォーム
tpgwlnot.dll1.7.2600.32372007/10/1901:3232,256x86
wisptis.exe1.7.2600.32372007/10/1820:47293,888x86

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

プロパティ

文書番号: 943856 - 最終更新日: 2007年11月22日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Tablet PC Edition 2005
キーワード:?
kbqfe kbhotfixserver KB943856
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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