Artikel-ID: 943864 - Geändert am: Freitag, 2. November 2007 - Version: 1.1

Host-Benutzer können andere gehosteten Benutzer sehen, wenn Sie die HMC Active Directory zugreifen können, durch Verwenden von LDAP-Tools in Microsoft Solution für Hosted Messaging und Zusammenarbeit, Version 4.0

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Problembeschreibung

Microsoft Solution for Hosted Messaging und Zusammenarbeit Version 4.0 haben eines Systems Hosted Messaging und Collaboration (HMC) in der Regel keine direkten Zugriff auf Active Directory-Dienst Benutzer mithilfe von LDAP-Tools wie LDP. Wenn Benutzer Zugriff auf Active Directory verfügen, können z. B. über eine Verbindung virtuelles privates Netzwerk (VPN) die Benutzer Active Directory um die Einträge für andere Benutzer gehosteten anzuzeigen zu durchsuchen. Dies teilt das isolierten Mieter Prinzip der HMC.

Ursache

Dieses Problem tritt auf, wenn folgenden Bedingungen erfüllt sind:
  • Eine Organisation Händler wird unter der hosting-Organisationseinheit erstellt.
  • Die Berechtigung Inhalt auflisten ist für alle gehosteten Benutzer erteilt.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Installieren Sie diesen Hotfix um dieses Problem zu beheben. Gehen Sie hierzu folgendermaßen vor:
  1. Beenden Sie die PRODUKTIONSPROGRAMMPLANUNG auf dem Server, auf dem Microsoft Provisioning Server (MPS) ausgeführt wird, um sicherzustellen, dass keine weiteren Anforderungen auf dem Server ausgeführt werden können. Gehen Sie hierzu folgendermaßen vor.
    1. Klicken Sie auf Start , zeigen Sie auf Programme , klicken Sie auf Verwaltung und klicken Sie dann auf Komponentendienste .
    2. Erweitern Sie Komponentendienste , erweitern Sie Computer , erweitern Sie Arbeitsplatz , erweitern Sie COM+-Anwendungen , klicken Sie mit der rechten Maustaste auf Bereitstellung Engine , klicken Sie auf deaktivieren , und klicken Sie dann auf Herunterfahren .
  2. Starten des MPS-Bereitstellungstools.
  3. Erweitern Sie Core-Plattform , und erweitern Sie dann MPF Core Namespaces und bewältigen MPF installiert .
  4. Klicken Sie mit der rechten Maustaste auf Active Directory verwaltet , und klicken Sie dann auf Deinstallieren .
  5. Klicken Sie auf Bereitstellung.
  6. Öffnen Sie den Ordner C:\MSIShare.
  7. Ändern des der Datei ManagedADNS.msi auf ManagedADNS_Orig.msi .
  8. Kopieren Sie die neue ManagedADNS.msi-Datei mit dem Hotfix in den Ordner MSIShare.
  9. MPS-Bereitstellungstools klicken Sie mit der rechten Maustaste auf Active Directory verwaltet , klicken Sie auf Installieren und klicken Sie dann auf Start Bereitstellung .
  10. Klicken Sie in den Komponentendiensten mit der rechten Maustaste auf Bereitstellung Engine , und klicken Sie Aktivieren und starten , die MPS-Engine neu zu starten.

Voraussetzungen

Microsoft Solution for Hosted Messaging und Zusammenarbeit Version 4.0 muss installiert sein, bevor Sie diesen Hotfix anwenden.

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Managedadns.msiNicht zutreffend283,13608-Oct-200713: 49Nicht zutreffend

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Sie können diesen Hotfix sicher, dass alle neuen Wiederverkäufern, die erstellt werden die richtige Zugriffsberechtigungen angewendet haben, anwenden.

Gehen Sie folgendermaßen vor zum Korrigieren von vorhandenen Berechtigungen, List Contents Zugriff auf alle Benutzer zu verhindern.

Für die hosting-Organisation

  1. Aktivieren Sie in den Active Directory-Benutzer und Computer-Snap-in Weitere Features im Menü Ansicht .
  2. Suchen Sie die hosting-Organisation, und klicken Sie mit der rechten Maustaste auf Eigenschaften .
  3. Klicken Sie auf Sicherheit , und klicken Sie dann auf Erweitert .
  4. Klicken Sie unter Berechtigungseinträge auf den Eintrag für AllUsersGroups (<domain> \AllUsersGroups) , und klicken Sie dann auf Bearbeiten .
  5. Klicken Sie unter Berechtigungen auf in der Spalte zulassen das Kontrollkästchen Inhalt auflisten .

Für jede Organisation Händler, die vor dem erstellt wurde dieser Hotfix installiert

  1. Aktivieren Sie in den Active Directory-Benutzer und Computer-Snap-in Weitere Features im Menü Ansicht .
  2. Suchen Sie die entsprechenden Händler Organisation, und klicken Sie mit der rechten Maustaste auf Eigenschaften .
  3. Klicken Sie auf Sicherheit , und klicken Sie dann auf Erweitert .
  4. Klicken Sie unter Berechtigungseinträge auf den Eintrag für AllCustomers@<Reseller>, und klicken Sie dann auf Bearbeiten .
  5. Klicken Sie unter Berechtigungen auf in der Spalte zulassen das Kontrollkästchen Inhalt auflisten .
  6. Klicken Sie im Feld Übernehmen auf Sie nur dieses Objekt .
Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Keywords: 
kbmt kbautohotfix kbexpertiseinter kbqfe kbhotfixserver KB943864 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 943864  (http://support.microsoft.com/kb/943864/en-us/ )
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