Artigo: 943864 - Última revisão: sexta-feira, 2 de Novembro de 2007 - Revisão: 1.1

Hosted utilizadores podem ver outros utilizadores hospedados se estes podem aceder ao HMC Active Directory utilizando ferramentas LDAP no Microsoft Solution para Hosted mensagens e colaboração versão 4.0

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Sintomas

No Microsoft Solution for Hosted mensagens e colaboração versão 4.0, os utilizadores de um sistema Hosted mensagens e colaboração (HMC) normalmente não tem acesso directo ao serviço de directório do Active Directory utilizando LDAP ferramentas como o LDP. Quando os utilizadores têm acesso ao Active Directory, por exemplo através de uma ligação de rede privada virtual (VPN), os utilizadores podem procurar Active Directory para ver os movimentos de outros utilizadores hospedados. Isto divide o princípio de arrendamento isolado do HMC.

Causa

Este problema ocorre caso se verifiquem as seguintes condições:
  • Uma organização revendedor é criada em unidade organizacional de anfitrião.
  • A permissão de listar o conteúdo é concedida a todos os utilizadores hospedados.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Para resolver este problema, aplique esta correcção. Para o fazer, siga estes passos:
  1. No servidor com o servidor de aprovisionamento Microsoft (MPS), pare os serviços MPS para se certificar de que não existem mais pedidos podem ser executados no servidor. Para o fazer, siga estes passos.
    1. Clique em Iniciar , aponte para Todos os programas , clique em Ferramentas administrativas e, em seguida, clique em Serviços de componentes .
    2. Expanda Serviços componentes , expanda computadores , expanda o Meu computador , expanda Aplicações do COM + , clique com o botão direito do rato em Aprovisionamento Engine , clique em Desactivar e, em seguida, clique em Encerrar .
  2. Inicie a ferramenta de implementação de MPS.
  3. Expanda Core Platform e expanda cobrança MPF instalar e espaços de nomes do MPF principal .
  4. Clique com o botão direito do rato Geridos do Active Directory e, em seguida, clique em desinstalar .
  5. Clique em Iniciar a implementação .
  6. Abra a pasta C:\MSIShare.
  7. Altere o nome do ficheiro ManagedADNS.msi para ManagedADNS_Orig.msi .
  8. Copie o novo ficheiro ManagedADNS.msi da correcção para a pasta MSIShare.
  9. Na ferramenta de implementação MPS, clique com o botão direito do rato Geridos do Active Directory , clique em instalar e, em seguida, clique em Iniciar a implementação .
  10. Em Component Services, clique com o botão direito do rato em Aprovisionamento Engine e, em seguida, clique em Activar e iniciar para reiniciar o motor MPS.

Pré-requisitos

Microsoft Solution for Hosted mensagens e colaboração versão 4.0 tem de estar instalado antes de aplicar esta correcção.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui uma correcção disponibilizada anteriormente.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Managedadns.msiNão aplicável283,13608-Outubro de 200713: 49Não aplicável

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Pode aplicar esta correcção para garantir que qualquer novos revendedores criados têm permissões de acesso correctas aplicadas.

Para corrigir as permissões existentes para impedir o conteúdo da lista de acesso a todos os utilizadores, siga estes passos.

Para a organização anfitrião

  1. No Active Directory e utilizadores do snap-in MMC de computadores, Active funcionalidades Avançadas no menu Ver .
  2. Localize a organização do anfitrião e, em seguida, clique com o botão direito do rato em Propriedades .
  3. Clique em segurança e, em seguida, clique em Avançadas .
  4. Em Entradas de permissões , clique na entrada para AllUsersGroups (<domain> \AllUsersGroups) e, em seguida, clique em Editar .
  5. Em permissões , clique para desmarcar a caixa de verificação Listar conteúdo na coluna Permitir .

Para cada organização de revendedor que foi criada antes de instalar esta correcção

  1. No Active Directory e utilizadores do snap-in MMC de computadores, Active funcionalidades Avançadas no menu Ver .
  2. Localize a organização do revendedor adequado e, em seguida, clique com o botão direito do rato em Propriedades .
  3. Clique em segurança e, em seguida, clique em Avançadas .
  4. Em Entradas de permissões , clique na entrada para AllCustomers@<Reseller> e, em seguida, clique em Editar .
  5. Em permissões , clique para desmarcar a caixa de verificação Listar conteúdo na coluna Permitir .
  6. No campo Aplicar em , clique apenas este objecto .
Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbqfe kbhotfixserver KB943864 KbMtpt
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