ID do artigo: 943864 - Última revisão: sexta-feira, 2 de novembro de 2007 - Revisão: 1.1

Os usuários Hosted podem ver outros usuários hospedados se eles podem acessar o Active Directory HMC usando ferramentas LDAP em solução Microsoft para Hosted Messaging and Collaboration versão 4.0

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Sintomas

No Microsoft Solution for Hosted Messaging and Collaboration versão 4.0, usuários de um sistema Hosted Messaging and Collaboration (HMC) geralmente não tem acesso direto ao serviço de diretório do Active Directory usando ferramentas LDAP como LDP. Quando os usuários tem acesso ao Active Directory, por exemplo através de uma conexão de rede virtual privada (VPN), os usuários podem procurar Active Directory para ver as entradas para outros usuários hospedados. Isso interrompe o princípio inquilino isolado de HMC.

Causa

Esse problema ocorre se as seguintes condições forem verdadeiras:
  • Uma organização revendedor é criada na unidade organizacional hospedagem.
  • A permissão Listar conteúdo é concedida a todos os usuários hospedados.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Para resolver esse problema, aplique esse hotfix. Para fazer isso, execute as seguintes etapas:
  1. No servidor que esteja executando o MPS (Microsoft configuração Server), interrompa os serviços do MPS para certificar-se que não mais solicitações podem ser executadas no servidor. Para fazer isso, siga estas etapas.
    1. Clique em Iniciar , aponte para Todos os programas , clique em Ferramentas administrativas e, em seguida, clique em Serviços de componentes .
    2. Expanda Serviços de componente , expanda computadores , expanda My Computer , expanda Aplicativos COM + , clique Mecanismo de configuração com o botão direito do mouse, clique em Desativar e, em seguida, clique em Desligar .
  2. Inicie a ferramenta de implantação MPS.
  3. Expanda Plataforma principal e expanda lidar MPF instalar e MPF Core Namespaces .
  4. Clique Gerenciado Active Directory com o botão direito do mouse e, em seguida, clique em desinstalar .
  5. Clique em Iniciar implantação .
  6. Abra a pasta C:\MSIShare.
  7. Altere o nome do arquivo ManagedADNS.msi para ManagedADNS_Orig.msi .
  8. Copie o novo arquivo ManagedADNS.msi a partir do hotfix para a pasta MSIShare.
  9. Na ferramenta de implantação MPS, clique Gerenciado Active Directory com o botão direito do mouse, clique em instalar e, em seguida, clique em Iniciar implantação .
  10. Em serviços de componentes, clique Mecanismo de configuração com o botão direito do mouse e clique em Habilitar e iniciar para reiniciar o mecanismo de MPS.

Pré-requisitos

Microsoft Solution for Hosted Messaging and Collaboration versão 4.0 deve ser instalado antes de aplicar esse hotfix.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Managedadns.msiNão aplicável283,13608-Outubro de 200713: 49Não aplicável

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Você pode aplicar esse hotfix para se certificar que qualquer novos revendedores que são criados tem as permissões de acesso correta aplicadas.

Para corrigir as permissões existentes para impedir o conteúdo de lista de acesso a todos os usuários, siga estas etapas.

Para a organização hospedagem

  1. No Active Directory Users e Computers snap-in, habilite recursos Avançado no menu Exibir .
  2. Localize a organização de hospedagem e, em seguida, clique com o botão direito do mouse Propriedades .
  3. Clique em segurança e, em seguida, clique em Avançado .
  4. Em Entradas de permissão , clique na entrada para AllUsersGroups (<domain> \AllUsersGroups) e em seguida, clique em Editar .
  5. Em permissões , clique para desmarcar a caixa de seleção Listar conteúdo na coluna Permitir .

Para cada organização revendedor que foi criada antes de você instalado esse hotfix

  1. No Active Directory Users e Computers snap-in, habilite recursos Avançado no menu Exibir .
  2. Localize a organização revendedor apropriado e, em seguida, clique com o botão direito do mouse Propriedades .
  3. Clique em segurança e, em seguida, clique em Avançado .
  4. Em Entradas de permissão , clique na entrada para AllCustomers@<Reseller> e em seguida, clique em Editar .
  5. Em permissões , clique para desmarcar a caixa de seleção Listar conteúdo na coluna Permitir .
  6. No campo Aplicar em , clique em somente este objeto .
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Solution for Hosted Messaging and Collaboration 4.0
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbqfe kbhotfixserver KB943864 KbMtpt
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