ID Artikel: 943996 - Melihat produk di mana artikel ini berlaku.
Perbesar semua | Perkecil semua
Sumber: Dukungan Microsoft

Hasil

Di komputer Windows Vista, Anda menemukan bahwa layanan Windows Firewall tidak dijalankan. Saat berusaha memulai layanan secara manual, Anda mendapatkan galat seperti berikut. Masalah ini juga dapat terjadi untuk layanan Klien DHCP, atau layanan ?Layanan Kebijakan Diagnostik?.

Berikut adalah galat untuk layanan "Windows Firewall":
Windows tidak dapat memulai Windows Firewall di Komputer Lokal. Untuk informasi selengkapnya, baca log Kejadian Sistem. Jika ini bukan layanan Microsoft, hubungi vendor layanan, dan rujuk ke galat khusus layanan kode 5.


Di log kejadian Sistem, Anda melihat kejadian berkut:
Sumber: Penyedia Log Kejadian manajer Kontrol Layanan.
ID Kejadian: 7024
Layanan Windows Firewall dihentikan dengan galat khusus layanan 5 (0x5)

Penyebab

Galat ini berarti "Akses ditolak". Ini dapat terjadi jika akun "MpsSvc" tidak memiliki izin yang diperlukan untuk kunci registri terkait.

Untuk akun NT Service\MpsSvc, memerlukan izin untuk kunci berikut ini:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch
    diperlukan izin: Nilai Permintaan;Nilai Ditetapkan
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy 
    diperlukan izin: Kontrol Penuh;Baca
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Defaults\FirewallPolicy
    diperlukan izin: Kontrol Penuh;Baca

Untuk layanan Klien DHCP, masalah dapat terjadi jika akun "NT Service\DHCP" tidak memiliki izin yang diperlukan untuk kunci berikut ini:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp
    diperlukan izin: Nilai permintaan, Buat nilai, Sebutkan Subkunci, Pemberitahuan, Kontrol Baca
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Configurations
    diperlukan izin: Kontrol Penuh, Baca

Untuk layanan "Layanan kebijakan Diagnostik", masalah ini dapat terjadi jika izin akun Trustedinstaller hilang untuk kunci berikut ini:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DPS\Parameters
diperlukan izin: Kontrol Penuh, Baca

Penyelesaian

Secara otomatis diagnosis dan perbaiki Windows Firewall umum, seperti berikut:
  • Windows Firewall bukan firewall asali
  • Windows Firewall tidak dimulai
  • Windows Vista tidak dapat memulai Windows Firewall
  • Galat khusus layanan 5 (0x5) Bantuan Jarak Jauh tidak berfungsi
  • Anda tidak dapat mengakses berkas dan pencetak bersama
Untuk mengunduh dan menjalankan pemecahan masalah secara otomatis, klik tautan Perbaiki masalah ini:
Perbaiki masalah ini
Layanan Pemecahan Masalah Otomatis Microsoft: Diagnosis dan perbaiki masalah layanan Windows Firewall secara otomatis


Jika ingin memperbaiki sendiri masalah ini daripada menggunakan pemecahan masalah otomatis di atas, tambahkan izin untuk akun atau kunci registri berikut. Misalnya, berikut adalah langkah-langkah untuk layanan Windows Firewall:
  1. Di Penyunting Registri, jelajah ke kunci yang ingin ditambahkan izin.
  2. Klik kanan kunci, kemudian klik Izin.
  3. Pastikan Lokasi sudah dipilih ke komputer lokal.
  4. Di kolom "Masukkan nama objek yang akan dipilih", ketik "NT SERVICE\mpssvc". Kemudian klik "Periksa nama."
  5. Klik OK.
  6. Kemudian pilih akun yang ditampilkan dalam daftar, dan tambahkan izin yang sesuai.
  7. Setelah selesai, klik OK.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properti

ID Artikel: 943996 - Kajian Terakhir: 25 Oktober 2010 - Revisi: 2.0
Berlaku bagi:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Kata kunci: 
kbnomt kbrapidpub kbfixme kbmatsfixme KB943996

Berikan Masukan

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com