Help and Support

The store event sink does not run as expected in an Exchange Server 2007 environment

Article ID:944333
Last Review:February 21, 2008
Revision:1.4

SYMPTOMS

In a Microsoft Exchange Server 2007 environment, the store event sink does not run as expected. The event is triggered, but the registered script is not executed.

For example, you follow the steps in Microsoft Knowledge Base (KB) article 895239 to register an OnSave store event sink for an administrator's Inbox folder on an Exchange 2007 mailbox server. Additionally, you use the sample script in the KB article 895239. Then, you send an e-mail message to the administrator's mailbox. However, the store event sink does not run as expected, and no file is created.

For more information how to register a store event sink by using Regevent.vbs on Exchange, click the following article number to view the article in the Microsoft Knowledge Base:
895239 (http://support.microsoft.com/kb/895239/) How to register a store event sink using Regevent.vbs on Exchange

Back to the top

CAUSE

This problem occurs because of some changes in Active Template Library (ATL) 8.0.

Back to the top

RESOLUTION

To resolve this problem in Exchange Server 2007 Service Pack 1, install Update Rollup 1 for Exchange Server 2007 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
945684 (http://support.microsoft.com/kb/945684/) Description of Update Rollup 1 for Exchange Server 2007 Service Pack 1
To resolve this problem in the release version of Exchange Server 2007, install Update Rollup 6 for Exchange Server 2007.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
942846 (http://support.microsoft.com/kb/942846/)Description of Update Rollup 6 for Exchange Server 2007

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 (http://support.microsoft.com/kb/817903/) New naming schema for Exchange Server software update packages

Back to the top


APPLIES TO
Microsoft Exchange Server 2007 Enterprise Edition
Microsoft Exchange Server 2007 Standard Edition

Back to the top

Keywords: 
kbbug kbfix kbqfe kbhotfixrollup kbhotfixserver KB944333

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.