The DVD playback volume in Windows Media Player or in a Windows Media Center application is not loud enough on a Windows Vista-based portable computer

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Article ID: 944436 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
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SYMPTOMS

You insert a DVD disk to watch a movie on a Windows Vista-based portable computer. You use Windows Media Player (Wmplayer.exe) or an application in Windows Media Center (Ehshell.exe) to watch the movie. However, the overall volume seems to be too low. For example, when you set maximum gain on all volume controls that are available in the audio mixer, system sounds and CD music playback are loud enough. However, DVD playback volume is still not loud enough.

CAUSE

This problem occurs because the default playback decoding mode of the AC-3 (Dolby Digital) streams is set to Normal mode. For DVD playback on portable computers, the default playback decoding mode should be set to Laptop Mode (RF decoding mode). The Laptop Mode (RF decoding mode) provides an additional increase in gain of 11 dB.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

For 32-bit versions of Windows Vista Home Premium and of Windows Vista Ultimate

To enable this hotfix, you must create the following registry entry on the portable computer:
dolby_rf_on
To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Scrunch\CodecPack\MSDVD
    Note If you cannot locate the registry subkey, go to step 3 to create the registry subkey. If you can locate the registry subkey, go to step 6.
  3. Right-click the Microsoft registry subkey, point to New, click Key, type Scrunch, and then press ENTER.
  4. Right-click the Scrunch registry subkey, point to New, click Key, type CodecPack, and then press ENTER.
  5. Right-click the CodecPack registry subkey, point to New, click Key, type MSDVD, and then press ENTER.
  6. On the Edit menu, point to New, and then click DWORD Value.
  7. In the details pane, type the following new value, dolby_rf_on, and then press ENTER.
  8. Right-click dolby_rf_on, and then click Modify.
  9. In the Edit DWORD Value dialog box, under Base, click Decimal.
  10. In the Value data box, type the value 1, and then click OK.

    Note Only "0" and "1" are supported values. If the dolby_rf_on registry entry contains any other value, the decoder ignores the value and uses the default value. If the registry entry is set to "1," the Laptop Mode is used as the default on the computer.
  11. Close Registry Editor.
  12. Restart the Windows Media Player or the Windows Media Center application.

For 64-bit versions of Windows Vista Home Premium and of Windows Vista Ultimate

To enable this hotfix, you must create the following registry entry on the portable computer:
dolby_rf_on
To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Scrunch\CodecPack\MSDVD
    Note If you cannot locate the registry subkey, go to step 3 to create the registry subkey. If you can locate the registry subkey, go to step 6.
  3. Right-click the Microsoft registry subkey, point to New, click Key, type Scrunch, and then press ENTER.
  4. Right-click the Scrunch registry subkey, point to New, click Key, type CodecPack, and then press ENTER.
  5. Right-click the CodecPack registry subkey, point to New, click Key, type MSDVD, and then press ENTER.
  6. On the Edit menu, point to New, and then click DWORD Value.
  7. In the details pane, type the following new value, dolby_rf_on, and then press ENTER.
  8. Right-click dolby_rf_on, and then click Modify.
  9. In the Edit DWORD Value dialog box, under Base, click Decimal.
  10. In the Value data box, type the value 1, and then click OK.

    Note Only "0" and "1" are supported values. If the dolby_rf_on registry entry contains any other value, the decoder ignores the value and uses the default value. If the registry entry is set to "1," the Laptop Mode is used as the default on the computer.
  11. Close Registry Editor.
  12. Restart the Windows Media Player or the Windows Media Center application.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable1,77428-Nov-200715:24Not Applicable
X86_19d6d660884a2510d13e42f959231f71_31bf3856ad364e35_6.0.6000.20728_none_1fd0161820b4be41.manifestNot Applicable69928-Nov-200715:24Not Applicable
X86_microsoft-windows-msmpeg2adec_31bf3856ad364e35_6.0.6000.20728_none_907013bed357ce73.manifestNot Applicable12,26528-Nov-200715:24Not Applicable
Msmpeg2adec-ppdlic.xrm-msNot Applicable3,05728-Nov-200706:49Not Applicable
Msmpeg2adec.dll11.0.6000.6346391,16828-Nov-200707:15x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_f0d33d916d7fee29a8b744b317b23943_31bf3856ad364e35_6.0.6000.20728_none_43b82bfe7b99c13a.manifestNot Applicable1,04628-Nov-200715:24Not Applicable
Amd64_microsoft-windows-msmpeg2adec_31bf3856ad364e35_6.0.6000.20728_none_ec8eaf428bb53fa9.manifestNot Applicable12,28128-Nov-200715:28Not Applicable
Update.mumNot Applicable2,00128-Nov-200715:24Not Applicable
Msmpeg2adec-ppdlic.xrm-msNot Applicable3,05728-Nov-200707:43Not Applicable
Msmpeg2adec.dll11.0.6000.6346519,16828-Nov-200708:10x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 944436 - Last Review: December 20, 2007 - Revision: 1.2
APPLIES TO
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbexpertiseinter kbhotfixserver kbqfe KB944436

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