Help and Support
 

powered byLive Search

SharePoint Portal Server 2003 cannot index a 2007 Office document or file

Article ID:944445
Last Review:November 6, 2007
Revision:1.1

SYMPTOMS

You upload a document or a file that was created by using the 2007 Microsoft Office system to a Microsoft Office SharePoint Portal Server 2003 Web site. When you do this, SharePoint Portal Server cannot index the 2007 Office document or file.

Back to the top

CAUSE

This issue occurs because the 2007 Office iFilters are not included in SharePoint Portal Server 2003. Therefore, the following 2007 Office file formats are not indexed by SharePoint Portal Server 2003:
.docx
.docm
.pptx
.pptm
.xlsx
.xlsm

Back to the top

RESOLUTION

To resolve this issue, install a 2007 Office program, such as Microsoft Office Word 2007, on the computer that is running SharePoint Portal Server. By default, this procedure also installs the 2007 Office iFilters. To do this, follow these steps:
1. Install Word 2007 on the computer that is running SharePoint Portal Server.
2.Click Start, point to Administrative Tools, and then click SharePoint Central Administration.
3. On the SharePoint Portal Server Site Settings page, click Configure search and indexing in the Search Settings and Indexed Content section.
4. On the Configure Search and Indexing page, click Include file types in the General Content Settings and Indexing Status section.
5.On the Specify File Types to Include page, click New File Type.
6. On the Add File Type page, type the file name extension for the file type that you want to add in the File extension box. The 2007 Office system uses the following file name extensions:
.docx
.docm
.pptx
.pptm
.xlsx
.xlsm
7. Click OK.

Back to the top


APPLIES TO
Microsoft Office SharePoint Portal Server 2003

Back to the top

Keywords: 
kbtshoot kbprb kbexpertiseinter KB944445

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.