Help and Support
 

powered byLive Search

After you install the 2007 Microsoft Office servers Service Pack 1 (SP1) or Windows SharePoint Services 3.0 SP1 on a server that has the Foxit PDF IFilter installed, .pdf document types are not indexed

Article ID:944447
Last Review:November 19, 2007
Revision:1.4
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows
On This Page

SYMPTOMS

Consider the following scenarios.

Back to the top

Scenario 1

You install the 2007 Microsoft Office servers Service Pack 1 (SP1) on a server that has the Foxit PDF IFilter installed. When a Microsoft Office SharePoint Server 2007 site collection on the server is searched by the SharePoint Server 2007 for Search service, .pdf document types are not indexed. When you try to search for .pdf documents in the SharePoint Server 2007 site collection, the .pdf documents are not found.

Back to the top

Scenario 2

You install Microsoft Windows SharePoint Services 3.0 SP1 on a server that has the Foxit PDF IFilter installed. When a Microsoft Windows SharePoint Services 3.0 site collection on the server is searched by the Windows SharePoint Services Search service, .pdf document types are not indexed. When you try to search for .pdf documents in the Windows SharePoint Services 3.0 site collection, the .pdf documents are not found.

Back to the top

CAUSE

This problem occurs because the Adobe PDF IFilter GUID is hard-coded in the 2007 Microsoft Office servers Service Pack 1 (SP1) and in Windows SharePoint Services 3.0 SP1. During the installation of the 2007 Microsoft Office servers Service Pack 1 (SP1) or Windows SharePoint Services 3.0 SP1, the Foxit PDF IFilter GUID is replaced by the Adobe PDF IFilter GUID in the registry.

Back to the top

WORKAROUND

To work around this problem, use one of the following methods.

Back to the top

Method 1: Reinstall the Foxit PDF IFilter

For more information about the Foxit PDF IFilter, visit the following Foxit Web site:
http://www.foxitsoftware.com/pdf/ifilter (http://www.foxitsoftware.com/pdf/ifilter)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Back to the top

Method 2: Add the Foxit PDF IFilter GUID back to the registry

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
1.Start Registry Editor. To do this, click Start, click Run, type regedit, and then click OK.
2.On the Edit menu, click Find.
3.In the Find what box, type {4C904448-74A9-11D0-AF6E-00C04FD8DC02}, and then click Next.
4.Replace each occurrence of the Adobe PDF IFilter GUID ({4C904448-74A9-11D0-AF6E-00C04FD8DC02}) by using the following Foxit PDF IFilter GUID:
{987f8d1a-26e6-4554-b007-6b20e2680632}
5.On the File menu, click Exit to exit Registry Editor.
6. Stop and then restart the Search services.
To stop and then restart the SharePoint Server 2007 for Search service, follow these steps:
a. Open the Command Prompt window. To do this, click Start, click Run, type cmd, and then click OK.
b. To stop the SharePoint Server 2007 for Search service, type the following command at the command prompt, and then press ENTER:
net stop osearch
c. To restart the SharePoint Server 2007 for Search service, type the following command at the command prompt, and then press ENTER:
net start osearch
d. At the command prompt, type exit to close the Command Prompt window.
To stop and then restart the Windows SharePoint Services Search service, follow these steps:
a. Open the Command Prompt window. To do this, click Start, click Run, type cmd, and then click OK.
b. To stop the Windows SharePoint Services Search service, type the following command at the command prompt, and then press ENTER:
net stop spsearch
c. To restart the Windows SharePoint Services Search service, type the following command at the command prompt, and then press ENTER:
net start spsearch
d. At the command prompt, type exit to close the Command Prompt window.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Back to the top


APPLIES TO
Microsoft Office SharePoint Server 2007
2007 Microsoft Office Servers Service Pack 1
Microsoft Windows SharePoint Services 3.0
Microsoft Windows SharePoint Services 3.0 Service Pack 1

Back to the top

Keywords: 
kbtshoot kbupdateissue kbpubtypekc kbexpertiseinter kbprb KB944447

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.