Article ID: 944938 - Last Review: April 5, 2012 - Revision: 11.1

You can’t install the Zune software because a required component is missing

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SYMPTOMS

When you try to install the Zune Music + Video software, you receive one of the following error messages:

The media for installation package couldn't be found. It might be incomplete or corrupt.

Setup must stop because the required package failed to install.

Can't contact Microsoft Update. Please try again later.

Can't download the required components from Microsoft Update. Please try again later.

Can't install the required components from Microsoft Update. Please try again later.

Path chosen is not valid

Installation failed, package Zune failed to install

No Installation Media

Can't find the media for installation package ".NET framework Runtime 2.0". It might be incomplete or corrupt.

Error Code 0x80070002


In all instances, the Zune software will not install.

CAUSE

These errors can happen when software components or updates are required by the Zune software for installation, but aren't available on your computer or included in the basic download.

THINGS TO TRY

1. Make sure that your computer meets the minimum system requirements.

  • Windows 7 (all editions)
  • Windows Vista (all editions)
  • Windows XP with Service Pack 3 (Home, Professional, Tablet PC, or Media Center Edition 2005 with Rollup Update 2)
    Note The Zune Music + Video software won't work on versions of Windows earlier than Windows XP SP3, any 64-bit version of Windows XP, or any version of Windows Server.
  • Mac OSX with Boot Camp running Windows 7 or Windows Vista
  • 256 MB of RAM
  • Video card with 64 MB RAM (video RAM or VRAM) and DirectX 9.0b
  • Microsoft Internet Explorer 6 or higher
For a more complete list of system requirements, see Computer requirements for Zune Music + Video (http://www.zune.net/en-US/support/zunesoftware/gettingstarted/pcreqs.htm) .

2. Check for updates.

You may need to update your computer:
  1. Visit the following Microsoft website:

    http://update.microsoft.com/microsoftupdate (http://update.microsoft.com/microsoftupdate)
  2. If you have not previously done this, click to "opt in" for Microsoft Updates.
  3. Click Check for updates.


3. Reinstall the Zune software using a Fix It.

Verify that you have administrative rights to install software and then run the Fix It below.

Fix it for me

You may be able to resolve this problem automatically. Click the Fix this problem link. Then, click Run in the File Download dialog box and follow the steps in this wizard.

Fix this problem
Microsoft Fix it 50577


Notes:
  • This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.

MORE INFORMATION

For more information about removing and reinstalling the Zune software, see the following Microsoft Knowledge Base article:

929358  (http://support.microsoft.com/kb/929358/ ) How to remove and then reinstall the Zune software


APPLIES TO
  • Zune software
  • Zune Digital Media Player
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