Article ID: 945068 - Last Review: December 12, 2007 - Revision: 1.2

Some visual elements in SQL Server Management Studio lose functionality when you register many instances of SQL Server

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

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SYMPTOMS

When you register many instances of Microsoft SQL Server in SQL Server Management Studio, some visual elements in SQL Server Management Studio lose functionality.

For example, you encounter the following issues in SQL Server Management Studio:
  • Some menus are unavailable.
  • Some menus do not display completely.
  • Some server activities cannot finish.
  • The copy operation and the paste operation cannot succeed.
This behavior is likely to occur when more than 200 instances of SQL Server are registered in SQL Server Management Studio.

Additionally, you are likely to experience issues that are related to the desktop heap when a process involves replication. For example, issues that are related to the desktop heap occur when a publisher and more than 200 distribution agents push data to 200 different subscribers.

CAUSE

When you register an instance of SQL Server in SQL Server Management Studio, SQL Server Management Studio consumes memory from the desktop heap. Depending on the visual element that the registration uses and on the size of desktop heap, the desktop heap may be used up. When this occurs, you encounter the issues that are described in the "Symptoms" section.

WORKAROUND

To work around this behavior, use one of the following methods.

Method 1

Reduce the number of instances of SQL Server that are registered in SQL Server Management Studio.

Method 2

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Increase the size of the desktop heap for the interactive window station at which SQL Server Management Studio is running. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\SubSystems
  3. Double-click the Windows registry entry.
  4. In Value data section of the Edit String dialog box, locate the SharedSection entry.
  5. Increase the second value of the SharedSection entry.
Notes
  • The second value of the SharedSection entry represents the size of the desktop heap for each desktop that is created in the WinSta0 interactive window station. The size is in kilobytes (KB).
  • By default, the second value of the SharedSection entry is 3072 in Windows Server 2003.

STATUS

This behavior is by design.

MORE INFORMATION

You can use the Desktop Heap Monitor tool to verify that the issues that you encounter are caused by the limited size of the desktop heap.

The following file is available for download from the Microsoft Download Center:

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Download
Download the DesktopHeapMonitor8_1_2925_0.exe package now. (http://www.microsoft.com/downloads/details.aspx?familyid=5cfc9b74-97aa-4510-b4b9-b2dc98c8ed8b)

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
126962  (http://support.microsoft.com/kb/126962/ ) "Out of Memory" error message appears when you have a large number of programs running
184802  (http://support.microsoft.com/kb/184802/ ) User32.dll or Kernel32.dll fails to initialize

APPLIES TO
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Workgroup Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition
Keywords: 
kbsql2005tool kbexpertiseadvanced kbtshoot kbprb KB945068
 

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