The Outlook Web Access search function does not work for some users in Exchange 2007

Article translations Article translations
Article ID: 945077 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

In Microsoft Exchange Server 2007, the Microsoft Office Outlook Web Access search function does not work for some of users. These users receive the following error message when they perform a search in Outlook Web Access:
Search results may take a long time to appear because Microsoft Exchange Search is unavailable. Results will not include matches in the e-mail body.
If you run the test-exchangesearch command, you receive the following output.
[PS] >test-exchangesearch username |fl
ResultFound : False
SearchTime : -1
Note This issue does not appear to affect newly created mailboxes.

CAUSE

This issue occurs because the full-text index catalog is corrupted.

RESOLUTION

To resolve this issue, rebuild the full-text index catalog. To do this, follow these steps:
  1. Open the Exchange Management Shell.
  2. Run the following script to remove the index directories that are associated with specified mailbox databases.
    ResetSearchIndex.ps1 [-force]
    				<dbname>
    				[<dbname>]
Note The ResetSearchIndex.ps1 script is located in the <drive>:\Program Files\Microsoft\Exchange Server\Scripts folder. The script deletes the CatalogData-<guid of database> folder and its contents. When you restart the MSExchangeSearch service, the CatalogData-<guid of database> is recreated. Also, a full database crawl is started.

Properties

Article ID: 945077 - Last Review: December 4, 2007 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbtshoot kbprb kbexpertiseinter KB945077

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com