ID do artigo: 945119 - Última revisão: sexta-feira, 30 de novembro de 2007 - Revisão: 1.2

Parar de erro está relacionado ao driver Storport.sys em um computador com Windows Server 2003: "(parâmetro1, Parâmetro2, Parâmetro3, parâmetro4) de 0x000000D1 DRIVER_IRQL_NOT_LESS_OR_EQUAL"

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Em um computador baseado no Windows Server 2003, é exibida a seguinte mensagem de erro Stop em uma tela azul:
0x000000D1 (parâmetro1, Parâmetro2, Parâmetro3, parâmetro4) DRIVER_IRQL_NOT_LESS_OR_EQUAL
anotações
  • Os parâmetros nessa mensagem de erro variam, dependendo da configuração do computador.
  • Nem todos os "0x000000D1" erros Stop são causados por esse problema.
Esse problema ocorre quando o driver Storport.sys é chamado para pausar ou continuar um adaptador em um computador com Windows Server 2003. Além disso, os desenvolvedores de driver de armazenamento podem encontrar sintomas desse problema quando seus drivers realizar operações semelhantes.

Causa

Esse problema ocorre porque o driver de sistema Storport.sys passa parâmetros incorretos para a função StorPortResume e para a função StorPortPause . Portanto, o sistema enfrenta o erro, e em seguida, o computador é reiniciado inesperadamente.

Resolução

Informações sobre o hotfix para Windows Server 2003

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows Server 2003 Service Pack 1 ou Windows Server 2003 2 instalado.
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 com Service Pack 1, x 86 versão
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.304418,94414 De novembro de 200711: 59x 86SP1
Storport.sys5.2.3790.3044108,03214 De novembro de 200711: 59x 86SP1
Windows Server 2003 com Service Pack 2, x 86 versão
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.418918,94414 De novembro de 200712: 20x 86SP2
Storport.sys5.2.3790.4189108,03214 De novembro de 200712: 20x 86SP2
Windows Server 2003, versão de 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.304424.06414 De novembro de 200715: 27x 64SP1
Storport.sys5.2.3790.3044188,41614 De novembro de 200715: 27x 64SP1
Windows Server 2003 com SP2, versão de 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.418924.06414 De novembro de 200715: 31x 64SP2
Storport.sys5.2.3790.4189188,92814 De novembro de 200715: 31x 64SP2
Windows Server 2003 com Service Pack 1, versão IA-64
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.304449,66414 De novembro de 200715: 27IA-64SP1
Storport.sys5.2.3790.3044347,13614 De novembro de 200715: 27IA-64SP1
Windows Server 2003 com Service Pack 2, versão IA-64
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.418949,66414 De novembro de 200715: 27IA-64SP2
Storport.sys5.2.3790.4189347,13614 De novembro de 200715: 27IA-64SP2

Informações sobre o hotfix para o Windows XP

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows XP Service Pack 1 ou Windows XP Service Pack 2 instalado.
322389   (http://support.microsoft.com/kb/322389/ ) Como obter o service pack mais recente do Windows XP

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP Professional, x 64 Edition
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.304424.06414 De novembro de 200715: 27x 64SP1
Storport.sys5.2.3790.3044188,41614 De novembro de 200715: 27x 64SP1
Windows XP Professional x 64 Edition com SP2, versão de 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Diskdump.sys5.2.3790.418924.06414 De novembro de 200715: 31x 64SP2
Storport.sys5.2.3790.4189188,92814 De novembro de 200715: 31x 64SP2

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a mensagem de erro "DRIVER_IRQL_NOT_LESS_OR_EQUAL", visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/ms795930.aspx (http://msdn2.microsoft.com/en-us/library/ms795930.aspx)
Para obter mais informações sobre a função StorPortResume , visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/ms807258.aspx (http://msdn2.microsoft.com/en-us/library/ms807258.aspx)
Para obter mais informações sobre a função StorPortPause , visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/ms807224.aspx (http://msdn2.microsoft.com/en-us/library/ms807224.aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbexpertisebeginner KB945119 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 945119  (http://support.microsoft.com/kb/945119/en-us/ )