Mensaje de error al enviar un mensaje de correo electrónico en Microsoft Dynamics CRM 3.0: "Permisos insuficientes"

Seleccione idioma Seleccione idioma
Id. de artículo: 945270 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Puede configurar Microsoft Dynamics CRM 3.0 para utilizar el servidor local de simple de transferencia de correo (SMTP) para el correo electrónico saliente. Al enviar un mensaje de correo electrónico, recibirá el siguiente mensaje de error:
Permisos insuficientes

El usuario ha iniciado la sesión no tiene los permisos de seguridad adecuada ver estos registros o realizar la acción específica. Para obtener más información, póngase en contacto con el administrador del sistema.
Si el valor DevErrors está establecido en activo en el archivo Web.config, recibirá el siguiente mensaje de error:
Microsoft CRM no controlados detalles del error:
Error de servidor en la aplicación '/'.

Servidor no pudo procesar la solicitud.
Descripción: Se produjo una excepción no controlada durante la ejecución de la solicitud web actual. Revise la traza de la pila para obtener más información acerca del error y dónde se originó en el código.

Detalles de excepciones: System.Web.Services.Protocols.SoapException: servidor no pudo procesar la solicitud.

Error de código fuente:

Se ha generado una excepción no controlada durante la ejecución de la solicitud Web actual. La información sobre el origen y la ubicación de la excepción pueden identificarse utilizando la excepción del seguimiento de la pila siguiente.

Pila:

[SoapException: servidor no pudo procesar la solicitud.] System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage Message, WebResponse Response, Stream responseStream, Boolean asyncCall) +1496
System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] Parameters) +218
Microsoft.Crm.Platform.Proxy.EmailWebService.Send(Guid emailId, Boolean issueSend, String trackingToken) +132
Microsoft.Crm.Application.SMWrappers.Email.Send(String ID, Boolean issueSend, String trackingToken) +93
Microsoft.Crm.Application.Platform.Email.Send() +83
Microsoft.Crm.Web.Activities.EmailDetailPage.Send(Object sender, DataEventArgs e) +83
Microsoft.Crm.Application.Forms.DataEventProcessor.Raise(FormEventId eventId, FormState State, User User, String objectId, Entity Entity) +176
Microsoft.Crm.Application.Forms.AppForm.RaiseDataEvent(FormEventId eventId) +89
Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity Entity) +57
Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity Entity, String formId, String formType) +83 Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity) + 13
Microsoft.Crm.Web.Activities.EmailDetailPage.ConfigureForm() +262
Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) + 30
System.Web.UI.Control.PreRenderRecursiveInternal() +62
System.Web.UI.Page.ProcessRequestMain() +1499

Descripción del error:
El usuario no tiene los privilegios necesarios.

Detalles del error:
No disponible

Número de error:
0x80040220

Archivo de origen:
No disponible

Número de línea:
No disponible
Solicitar dirección URL:
http://crmservername/Activities/Email/Edit.aspx

Causa

Este problema se produce porque la identidad de CRMAppPool no tiene acceso a la metabase de servicios de Internet Information Server (IIS).

Solución

Para resolver este problema, siga estos pasos:
  1. En el servidor de Microsoft Dynamics CRM 3.0, haga clic en Inicio , haga clic en Todos los programas , haga clic en Herramientas administrativas y, a continuación, haga clic en Administrador de Internet Information Services (IIS) .
  2. Expanda el nombre del servidor y, a continuación, expanda Grupos de aplicaciones .
  3. Haga clic con el botón secundario en CRMAppPool y, a continuación, haga clic en Propiedades .
  4. En la ficha identidad , determine qué cuenta se establece como la identidad de CRMAppPool .
  5. Ejecute la secuencia de comandos Adadd.vbs para conceder el acceso de lectura de cuenta a la metabase de IIS. Para obtener más información acerca de la secuencia de comandos Adadd.vbs, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    816789Acceso de lectura a todos con el grupo se quita después de instalar Exchange 2000 S816789
  6. Haga clic en Inicio , haga clic en Ejecutar , escriba iisreset y, a continuación, haga clic en Aceptar .
  7. Si esta cuenta también se utiliza para iniciar el servicio de flujo de trabajo de Microsoft Dynamics CRM, reinicie el servicio de flujo de trabajo de Microsoft CRM.

Más información

Cuando instala Microsoft Dynamics CRM 3.0, el programa de instalación concede a la seguridad especificada cuenta acceso a la metabase de IIS. Si cambia la identidad de CRMAppPool más adelante, debe conceder manualmente la cuenta de acceso a la metabase de IIS. De forma predeterminada, sólo el grupo BUILTIN\Administrators tiene acceso a la metabase de IIS.

Propiedades

Id. de artículo: 945270 - Última revisión: jueves, 3 de abril de 2008 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft CRM Customer Service sobre las siguientes plataformas
    • Microsoft CRM 3.0
Palabras clave: 
kbmt kberrmsg kbmbsadministration kbexpertisebeginner kbtshoot kbprb kbexpertiseinter kbmbsemail kbmbsmigrate KB945270 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 945270

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com