Article ID: 945312 - Last Review: April 2, 2008 - Revision: 1.1

The OpsMgr Health service may incorrectly display the health state of the cluster nodes in System Center Operations Manager 2007

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

When you use Microsoft System Center Operations Manager 2007 to perform cluster node health monitoring, the OpsMgr Health service may incorrectly display the health state of the cluster nodes.

CAUSE

This problem occurs if the Windows Management Instrumentation (WMI) data source generates multiple events in a short time and if the events contain the same time stamp.

The ordering of the events that contain the same time stamp may cause the OpsMgr Health service to display the health state incorrectly. This behavior may affect cluster monitoring in System Center Operations Manager 2007.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
System Center Operations Manager 2007, 32-bit editions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mommodulemsgs.dll6.0.5000.45241,20808-Jan-200809:14Not Applicable
Mommodules.dll6.0.5000.451,763,38408-Jan-200809:14Not Applicable
System Center Operations Manager 2007, 64-bit editions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.enterprisemanagement.operationsmanager.dll6.0.5000.312,166,78408-Jan-200809:13Not Applicable
Microsoft.enterprisemanagement.operationsmanager.sdkbin.dll6.0.5000.312,166,78408-Jan-200809:13Not Applicable
Mommodulemsgs.dll6.0.5000.45240,69608-Jan-200809:14Not Applicable
Mommodules.dll6.0.5000.453,282,48808-Jan-200809:14Not Applicable
Momperfsnapshothelper.exe6.0.5000.047,10408-Jan-200809:14Not Applicable
Momperfsnapshothelperproxy.dll6.0.5000.011,77608-Jan-200809:14Not Applicable

MORE INFORMATION

Hotfix installation instructions

This hotfix must be applied to each computer that meets the following criteria:
  • It hosts a Microsoft Operations Manager management server.
  • It hosts a Microsoft Operations Manager agent.
To apply this hotfix, follow these steps:
  1. Copy the SYSTEMCENTEROPERATIONSMANAGER2007-RTM-KB945312-X86-X64-ENU.MSI file to a local folder or to a network shared folder.
  2. Run the file on all the applicable computers by double-clicking the following file:
    SYSTEMCENTEROPERATIONSMANAGER2007-RTM-KB945312-X86-X64-ENU.MSI
    Note You can run this file in Windows Explorer or at a command prompt. The hotfix installation process restarts the OpsMgr Health service.
  3. Import the Microsoft.Windows.Cluster.Library.MP management pack.

    Note The management packs will be extracted to the following folder:
    %systemdrive%\ProgramFiles\ System Center 2007 Hotfix Utility\Q945312
Afer you apply the hotfix, you must approve the update in the "Pending Management" folder. To do this, follow these steps:
  1. Manually update each Operations Manager 2007 management server and gateway server in the management groups.
  2. On the computer that is running the management server role, click Start, point to All Programs, point to System Center Operations Manager 2007, and then click Operations Console.
  3. Select the Administration view, expand Administration, expand Device Management, and then click Pending Management.
  4. To apply this hotfix, review and then approve the agent computers in the "Pending Management" folder.
  5. For agents that are manually installed after the hotfix was applied to the server, you can manually update the agent. Or, follow these steps to have the Operations Manager 2007 management server perform the update:
    1. Make sure that the manual installation property is enabled for the "Operations Console Pending Management" folder.
    2. Click the Agent-managed Computers folder.
    3. Right-click the agent, and then click Update Agent Settings. The agent will be updated shortly.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft System Center Operations Manager 2007
Keywords: 
kbautohotfix kbfix kbexpertiseinter kbhotfixserver kbqfe KB945312
 

Article Translations