Artigo: 945380 - Última revisão: sexta-feira, 11 de Janeiro de 2008 - Revisão: 1.2

Mensagem de erro no Windows XP SP2: ? Windows não foi possível iniciar porque o ficheiro seguinte está em falta ou danificado. Windows\System32\Hal.dll ?

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante
Suporte para o Windows XP Service Pack 2 termina em 13 de Julho de 2010. O tópico de Client Migration (http://support.microsoft.com/ph/1131#tab4) no Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) é um ponto de partida para planear a estratégia de migração do Windows XP SP2. Para mais informações, consulte a Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle) .

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

No Windows XP Service Pack 2 (SP2), poderá receber a seguinte mensagem de erro:

Windows não pode iniciar porque o ficheiro seguinte está em falta ou danificado.
Windows root\system32\hal.dll.
Reinstale uma cópia do ficheiro acima.

Causa

Este problema poderá ocorrer se ocorre um dos seguintes problemas.

Problema 1

Tem uma partição incorrecta ou um registo de arranque incorrecto.

Problema 2

Danos de sistema ou disco de ficheiro faz com que o registo de arranque principal, o ficheiro HAL.dll ou o ficheiro Ntoskrnl.exe para ficar danificado.

Problema 3

Ficheiros Ntoskrnl.exe e HAL.dll a são incompatíveis.

Resolução

Resolução de problemas avançada

Se não estiver familiarizado com operações avançadas de resolução de problemas, poderá contactar alguém para o ajudar ou contactar o suporte. Para obter informações sobre como contactar o suporte da Microsoft, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Problema 1

Para resolver este problema, utilize um dos seguintes métodos.

Método 1

Repare o registo de arranque principal utilizando o comando fixmbr a partir da consola de recuperação do Windows XP.

Para obter mais informações sobre como utilizar a consola de recuperação no Windows XP, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
307654  (http://support.microsoft.com/kb/307654/ ) Como instalar e utilizar a consola de recuperação no Windows XP
Para obter mais informações sobre uma mensagem de erro que poderá receber quando utilizar o comando fixmbr, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
266745  (http://support.microsoft.com/kb/266745/ ) Mensagem de erro quando executa o comando fixmbr

Método 2

Se a partição de arranque primária for uma partição FAT, utilize o comando fixboot partir da consola de recuperação do Windows XP para escrever um novo sector de arranque na partição de sistema. Em seguida, utilize o comando fixmbr para reparar o registo de arranque principal.

Problema 2

Para resolver este problema, inicie o computador utilizando a consola de recuperação no Windows XP e, em seguida, execute o comando chkdsk /r.

Para obter mais informações sobre como instalar e utilizar a consola de recuperação no Windows XP, consulte a resolução na secção "Problema 1".

Nota Não tem de incluir o parâmetro /p no comando chkdsk porque o parâmetro /r faz com que o utilitário Chkdsk para localizar sectores danificados e recupere informações legíveis. O comando chkdsk implica o parâmetro /p.

Problema 3

Para resolver este problema, inicie o computador a partir do suporte de instalação do Windows XP, inicie a consola de recuperação e, em seguida, utilizar a ferramenta Bootcfg.exe para recriar o ficheiro Boot.ini. Para o fazer, siga estes passos:
  1. Configure o computador para iniciar a partir da unidade de CD ou unidade de DVD. Para obter informações sobre como efectuar este procedimento, consulte a documentação do computador ou contacte o fabricante do computador.
  2. Inserir o suporte de instalação do Windows na unidade de CD ou unidade de DVD e, em seguida, reinicie o computador.
  3. Quando receber a mensagem "Prima qualquer tecla para arrancar a partir do CD", prima uma tecla para iniciar o computador a partir do CD do Windows XP ou do DVD.
  4. Quando receber a mensagem "Bem-vindo ao programa de configuração", prima a tecla R para iniciar a consola de recuperação.
  5. Se tiver um arranque duplo ou um computador de arranque múltiplo, seleccione a instalação que tem de utilizar a partir da consola de recuperação.
  6. Quando lhe for pedido, escreva a palavra-passe de administrador e, em seguida, prima ENTER.
  7. Na linha de comandos, escreva bootcfg /list e, em seguida, prima ENTER.

    Nota As entradas no ficheiro Boot.ini actual serão apresentadas no ecrã.
  8. Na linha de comandos, escreva bootcfg /rebuild e, em seguida, prima ENTER.

    Nota Este comando verifica os discos rígidos do computador de instalações do Windows XP e, em seguida, apresenta os resultados.
  9. Siga as instruções que aparecem no ecrã para adicionar as instalações do Windows ao ficheiro Boot.ini.

    Por exemplo, siga estes passos para adicionar uma instalação do Windows XP ao ficheiro Boot.ini:
    1. Quando receber uma mensagem semelhante à seguinte, prima a tecla S:

      1 Total identificados instalações do Windows: [1] C:\Windows
      Adicionar instalação à lista de arranque? (Sim/não/todos)
    2. Receber uma mensagem semelhante à seguinte:
      Introduza o identificador de carregamento
      Quando receber esta mensagem, escreva o nome do sistema operativo e, em seguida, prima ENTER.

      Nota O nome é o Microsoft Windows XP Professional ou Microsoft Windows XP Home Edition.
    3. Receber uma mensagem semelhante à seguinte:
      Introduza opções de carregamento do SO
      Quando receber esta mensagem, escreva / fastdetect, e, em seguida, prima ENTER.
    Nota As instruções apresentadas no ecrã podem ser diferentes, dependendo da configuração do computador.
  10. Escreva exit e, em seguida, prima ENTER para sair da consola de recuperação.
  11. Escreva fixboot e, em seguida, prima ENTER.
  12. Escreva y e, em seguida, prima ENTER.
  13. O computador é reiniciado e o actualizados aparece a lista de arranque, quando for a mensagem "Seleccione o sistema operativo para iniciar".

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
314477  (http://support.microsoft.com/kb/314477/ ) Mensagem de erro: o Windows não conseguiu iniciar devido a um problema de configuração de hardware do computador disco
Para obter mais informações sobre como utilizar a funcionalidade Restauro do sistema, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
306084  (http://support.microsoft.com/kb/306084/ ) Como restaurar o sistema operativo para um estado anterior no Windows XP

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Service Pack 2
Palavras-chave: 
kbmt kbresolve kbhowto kberrmsg kbpubtypekc kbinfo KB945380 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 945380  (http://support.microsoft.com/kb/945380/en-us/ )