Pri spustení programu Internet Explorer 7 sa zobrazí prázdna webová stránka

Preklady článku Preklady článku
ID článku: 945385 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Pri spustení programu Windows Internet Explorer 7 sa nezobrazí domovská stránka. Namiesto nej sa zobrazí prázdna webová stránka.

Okrem toho sa môže zobraziť aj chybové hlásenie, ktoré sa podobá nasledujúcemu hláseniu:
Riadok:56
Znak:2
Chyba: Prvok sa nenašiel
Kód: 0
URL:http://runonce.msn.com/runonce2aspx
Tento problém sa zvyčajne vyskytuje po nainštalovaní programu Internet Explorer 7, po nainštalovaní systému Windows alebo po vynulovaní nastavenia programu Internet Explorer. Tento problém sa môže vyskytnúť iba u niektorých používateľov.

PRICINA

Tento problém sa vyskytuje, ak sa webová stránka prispôsobenia nastavenia v programe Internet Explorer 7 nenačíta správne, alebo ak sa webová stránka prispôsobenia nastavenia otvorí s nastavením obmedzenia zabezpečenia.

RIESENIE

Ak chcete odstrániť tento problém, vytvorte a spustite súbor Skiprunonce.reg pre každé používateľské konto, pri ktorom sa tento problém vyskytol. Použite tento postup:
  1. Spustite textový editor, napríklad program Poznámkový blok.
  2. Skopírujte nasledujúce informácie, prilepte ich do textového editora a potom súbor uložte pod názvom Skiprunonce.reg:
    Windows Registry Editor Version 5.00
    
     
    
    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    
    "RunOnceHasShown"=dword:00000001
    
    "RunOnceComplete"=dword:00000001
    
  3. Zavrite textový editor.
  4. Dvakrát kliknite na súbor Skiprunonce.reg, ktorý ste vytvorili v kroku 2.

    Keď používatelia spustia súbor .reg, zobrazí sa im nasledujúce hlásenie:
    Naozaj chcete pridať informácie z cesty k súboru .reg do databázy Registry?
    Ak používateľ klikne na tlačidlo Áno, používateľovi sa zobrazí nasledujúce hlásenie:
    Informácie v ceste k súboru .reg sa úspešne zadali do databázy Registry.

    Poznámky
    • Ak sa v systéme Windows Vista pokúsia súbor SkipRunOnce.reg spustiť používatelia, ktorí nie sú správcami, zobrazí sa im výzva na zadanie hesla správcu.
    • Ak chcete, aby sa súbor SkipRunOnce.reg spustil pre všetkých používateľov naraz, správca môže upraviť kľúč [HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main] namiesto kľúča [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main] v súbore SkipRunOnce.reg.

Sekcia pre pokročilých používateľov

Dôležité upozornenie. Táto sekcia, metóda alebo úloha obsahuje kroky, ktoré vás informujú o tom, ako upraviť databázu Registry. Ak však databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Preto dávajte pozor a postupujte presne podľa týchto krokov. Na dosiahnutie lepšej ochrany je pred úpravou databázu Registry vhodné zálohovať. To vám umožní obnoviť databázu Registry, ak sa vyskytnú problémy. Ďalšie informácie o zálohovaní a obnovení databázy Registry nájdete v nasledovnom článku databázy Microsoft Knowledge Base:
322756 Zálohovanie a obnovenie databázy Registry v systémoch Windows XP a Windows Vista (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine)
Táto sekcia je určená pre skúsených používateľov počítača. Ak sa nechcete púšťať do pokročilého riešenia problémov, môžete niekoho požiadať o pomoc alebo kontaktovať technickú podporu. Informácie o tom nájdete na nasledovnej webovej lokalite spoločnosti Microsoft:
http://support.microsoft.com/contactus
Skontrolujte, či existujú kľúče databázy Registry RunOnceHasShown a RunOnceComplete, a či sú nastavené na hodnotu 1. Použite na to tento postup:
  1. Kliknite na tlačidlo Štart, kliknite na príkaz Spustiť, zadajte príkaz regedit a potom kliknite na tlačidlo OK.
  2. Vyhľadajte nasledujúci podkľúč databázy Registry a kliknite naň:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
  3. Na table podrobností dvakrát kliknite na položku RunOnceHasShown databázy Registry.

    Poznámka. Ak sa položka RunOnceHasShown databázy Registry nenachádza na table podrobností, je nutné ju vytvoriť. Vykonáte to tak, že ukážete na položku Nový v ponuke Úpravy, kliknite na položku Hodnota DWORD a potom zadáte hodnotu RunOnceHasShown do poľa Nová hodnota.
  4. Do poľa Údaj hodnoty zadajte číslo 1 a potom kliknite na tlačidlo OK.
  5. Na table podrobností dvakrát kliknite na položku RunOnceComplete databázy Registry.

    Poznámka. Ak sa položka RunOnceComplete databázy Registry nenachádza na table podrobností, je nutné ju vytvoriť. Vykonáte to tak, že ukážete na položku Nový v ponuke Úpravy, kliknite na položku Hodnota DWORD a potom zadáte hodnotu RunOnceComplete do poľa Nová hodnota.
  6. Do poľa Údaj hodnoty zadajte číslo 1 a potom kliknite na tlačidlo OK.
  7. Zatvorte editor databázy Registry.

Podobné problémy a riešenia

Ak chcete riešiť podobné problémy, svojpomocné postupy pre začiatočníkov a stredne pokročilých používateľov počítača sú k dispozícii na nasledujúcej webovej lokalite spoločnosti Microsoft:
Zbaliť tento obrázokRozbaliť tento obrázok
Prepojenie
Riešenie problémov, pri ktorých program Windows Internet Explorer prestane reagovať alebo úplne zlyhá

Poznámka. Tento obsah sprievodcu nemusí byť k dispozícii vo všetkých jazykoch.

Vlastnosti

ID článku: 945385 - Posledná kontrola: 25. februára 2008 - Revízia: 1.1
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Windows Internet Explorer 7
Kľúčové slová: 
kbtshoot kbprb KB945385

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com