Help and Support

文書番号: 945385 - 最終更新日: 2008年2月20日 - リビジョン: 1.0

Internet Explorer 7 を起動すると空白の Web ページが表示される

元に戻す画像を拡大する
ガイド付きヘルプ
初級レベルから中級レベルのコンピュータ ユーザーを対象にした、より簡単な手順を利用できます。

この「サポート技術情報」 (Microsoft Knowledge Base) の資料には、上級レベルのコンピュータ ユーザーおよびサポート担当者を対象としたトラブルシューティング情報が記載されています。初級レベルから中級レベルのコンピュータ ユーザーを対象としたセルフ ヘルプの手順については、次のマイクロソフト Web サイトを参照してください。
元に戻す画像を拡大する
リンク
Troubleshoot problems in which Windows Internet Explorer stops responding or crashes (http://support.microsoft.com/gp/pc_ie_intro)

: このガイド付きヘルプの内容は、言語によっては利用できないことがあります。
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322756? (http://support.microsoft.com/kb/322756/ ) Windows XP および Windows Server 2003 でレジストリをバックアップ、編集および復元する方法

目次

すべて展開する | すべて折りたたむ

現象

Windows Internet Explorer 7 を起動したときに、設定したホーム ページが表示されません。代わりに、空白の Web ページが表示されます。

また、以下のようなエラー メッセージが表示されることがあります。
ライン: 56
文字: 2
エラー:要素が見つかりません。
コード: 0
URL: http://runonce.msn.com/runonce2aspx
この問題は通常、Internet Explorer 7 をインストールした後、Windows をインストールした後、または Internet Explorer の設定をリセットした後に発生します。この問題は、特定のユーザーでのみ発生することがあります。

原因

この問題は、Internet Explorer 7 で "設定の変更" Web ページが正しく読み込まれなかった場合、または制限されたセキュリティ設定で "設定の変更" Web ページが開かれた場合に発生します。

解決方法

この問題を解決するには、Skiprunonce.reg ファイルを作成し、問題が発生したユーザー アカウントごとに実行します。これを行うには、次の手順を実行します。
  1. メモ帳などのテキスト エディタを起動します。
  2. 以下の情報をコピーしてテキスト エディタに貼り付け、そのファイルを Skiprunonce.reg という名前で保存します。
    Windows Registry Editor Version 5.00
    
     
    
    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    
    "RunOnceHasShown"=dword:00000001
    
    "RunOnceComplete"=dword:00000001
    
  3. テキスト エディタを終了します。
  4. 手順 2. で作成した Skiprunonce.reg ファイルをダブルクリックします。

    ユーザーが .reg ファイルを実行すると、次のメッセージが表示されます。
    path of .reg file 内の情報をレジストリに追加しますか?
    [はい] をクリックすると、次のメッセージが表示されます。
    path of .reg file の情報が、レジストリに正しく入力されました。


    • Windows Vista では、管理者ではないユーザーが SkipRunOnce.reg を実行すると、管理者パスワードの入力を求めるメッセージが表示されます。
    • SkipRunOnce.reg をすべてのユーザーに対して一度に実行するには、SkipRunOnce.reg ファイルで [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main] ではなく [HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main] を変更します。

詳しい知識のあるユーザーの場合

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。 以下の説明は、上級レベルのコンピュータ ユーザーを対象としています。高度なトラブルシューティングに慣れていない場合には、問い合わせをしたり、サポートを受けたりすることができます。問い合わせおよびサポートについては、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)
レジストリ キー RunOnceHasShown および RunOnceComplete が存在しており、それらの値が 1 に設定されていることを確認します。これを行うには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に regedit と入力し、[OK] をクリックします。
  2. 次のレジストリ サブキーを見つけてクリックします。
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
  3. 詳細ウィンドウで、[RunOnceHasShown] レジストリ エントリをダブルクリックします。

    : RunOnceHasShown レジストリ エントリが詳細ウィンドウに表示されない場合は、作成する必要があります。これを行うには、[編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。次に [新しい値 #1] ボックスに RunOnceHasShown と入力します。
  4. [値のデータ] ボックスに 1 と入力し、[OK] をクリックします。
  5. 詳細ウィンドウで、[RunOnceComplete] レジストリ エントリをダブルクリックします。

    : RunOnceComplete レジストリ エントリが詳細ウィンドウに表示されない場合は、作成する必要があります。これを行うには、[編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。次に [新しい値 #1] ボックスに RunOnceComplete と入力します。
  6. [値のデータ] ボックスに 1 と入力し、[OK] をクリックします。
  7. レジストリ エディタを終了します。

この資料は以下の製品について記述したものです。
  • Windows Internet Explorer 7
キーワード:?
kbtshoot kbprb KB945385
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers