Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.
angličtina
Ľutujeme, tento článok nie je dostupný vo vašom jazyku.

Symptoms

Consider the following scenario:

  • A user has a mailbox that is hosted on Microsoft Exchange Server 2007.

  • The user has a long user principal name (UPN).

  • The user tries to connect to his or her Exchange Server 2007 mailbox by using the POP3 protocol.

In this scenario, the user may receive an error message that resembles the following:

There was a problem logging onto your mail server. Your User Name was rejected.
Account: "Account name",
Server: "Server name",
Protocol: POP3,
Server Response: "-ERR Protocol error. Connection is Closed."
Port: 110, Secure (SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC91

Cause

This issue occurs if Exchange Server 2007 is configured to use the default MaxCommandSize setting value of 40 bytes for the POP3 protocol.

Note If the MaxCommandSize setting for the POP3 protocol is 40 bytes, a user who has a long UPN may receive the error that is described in the "Symptoms" section.

Resolution

To resolve this issue, use one of the following methods, as appropriate for your situation.

Method 1: Increase the MaxCommandSize setting value by using the Exchange Management Shell

To resolve this issue, increase the MaxCommandSize setting value. To do this, follow these steps:

  1. Verify the current MaxCommandSize setting value. To do this, run the following cmdlet:

    Get-POPSettingsNote By default, the MaxCommandSize setting value is 40.

  2. Increase the MaxCommandSize setting value. To do this, run the following cmdlet.

    Set-POPSettings -MaxCommandSize 46Note In this cmdlet, the value of 46 is used as an example. Valid MaxCommandSize settings values are 40 through 1024.

  3. Restart the Microsoft Exchange POP3 service.

Method 2: Increase the MSExchPopImapCommandSize setting value by using Active Directory Service Interfaces (ADSI) Edit

To resolve this issue, increase the MSExchPopImapCommandSize setting value. To do this, follow these steps:

  1. Click Start, type Adsi Edit in the Search programs and files box, and then press Enter.

  2. On the Action menu, click Connect to.

  3. Click Select or type a domain or server, click the server that you want, and then click OK.

  4. Expand Default naming context, and then expand DC=domain,DC=com.

  5. Expand CN=Services, expand CN=Microsoft Exchange, expand CN=Administrative Groups, and then expand CN=Exchange Administrative Groups.

  6. Expand CN=server_name, expand Services Protocols, and then expand CN=POP3.

  7. Right-click CN=1, and then click Properties.

  8. Double-click MSExchPopImapCommandSize.

  9. Type the value that you want. For example, type 46.

    Note Valid values are 40 through 1024.

  10. Exit ADSI Edit.

  11. Restart the Microsoft Exchange POP3 service.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Boli tieto informácie užitočné?

Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×