Messaggio di errore riscontrato in un computer portatile basato su Windows Vista che dispone di una fotocamera USB integrata o esterna che riprende l'esecuzione dalla modalitÓ di sospensione a lungo termine: "0x000000E4" o "0x00000...

Traduzione articoli Traduzione articoli
Identificativo articolo: 945577 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si utilizza un computer portatile basato su Windows Vista, Ŕ possibile ricevere un errore irreversibile analogo al seguente:
STOP: 0x000000E4 (0x00000002, parameter2, parameter3, parameter4)
STOP: 0x0000000A (parameter1, parameter2, parameter3, parameter4)

Note
  • I parametri dell'errore irreversibile variano in base alla configurazione del computer e in base al tipo di problema.
  • Non tutti gli errori irreversibili "0x000000E4" o "0x0000000A" sono causati da questo problema.
Questo problema si verifica in presenza delle seguenti condizioni:
  • Una fotocamera USB Ŕ integrata nel computer o il dispositivo Ŕ collegato al computer mediante un cavo USB.
  • Il computer riprende l'esecuzione dalla modalitÓ di sospensione a lungo termine. Ad esempio, il computer Ŕ nello stato di sospensione per 30 minuti o pi¨.
  • Il valore della voce del Registro di sistema ForceHCResetOnResume del computer Ŕ uguale a 0.

Cause

Questo comportamento Ŕ causato da un problema di temporizzazione tra il modulo Usbvideo.sys e il modulo Ks.sys. Quando si verifica il problema, l'oggetto periferica viene eliminato prima che venga richiamato un elemento di lavoro correlato.

Workaround

Per aggirare il problema, modificare il valore della voce del Registro di sistema ForceHCResetOnResume in 1.

Per ulteriori informazioni su come aggiungere la voce ForceHCResetOnResume, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
928631 Un dispositivo USB potrebbe non funzionare correttamente dopo il ripristino di Windows Vista dallo stato di sospensione o ibernazione

Risoluzione

Informazioni sul pacchetto di servizi Windows Vista

Per risolvere questo problema, procurarsi il Service Pack pi¨ recente per Windows Vista. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
935791 Come ottenere il Service Pack pi¨ recente per Windows Vista

Hotfix e aggiornamenti della sicurezza inclusi nel SP2 di Windows Vista Service e Windows Server 2008

Per ulteriori informazioni sugli hotfix e aggiornamenti della sicurezza inclusi nel SP2 di Windows Vista Service e Windows Server 2008, visitare il seguente sito Web Microsoft TechNet: -
http://technet.microsoft.com/it-it/library/dd335033(WS.10).aspx
Nota: attualmente, l'elenco di hotfix e aggiornamenti della sicurezza Ŕ disponibile solo in inglese.

Informazioni sull'hotfix

Per applicare questo hotfix, Ŕ necessario creare la voce del Registro di sistema ForceHCResetOnResume.

Per consentire la modifica della voce del Registro di sistema, passare alla sezione "Correzione automatica". Per risolvere il problema autonomamente, accedere alla sezione "Correzione manuale".

Correzione automatica



Per risolvere il problema automaticamente, fare clic sul pulsante o sul collegamento Fix it. Quindi, fare clic su Esegui nella finestra di dialogo Download file e attenersi alla procedura guidata di Fix it.


Correggi problema
Microsoft Fix it 50706


Note
  • Questa procedura guidata Ŕ disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
  • Se non si sta utilizzando il computer che presenta il problema, Ŕ possibile salvare la soluzione Fix it su un'unitÓ di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.

Quindi consultare la sezione "Verifica della risoluzione del problema".



Correzione manuale

A tale scopo, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
  2. Individuare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}\<Four-digit_number>
    Notes
    • <Numero_a_quattro_cifre> Ŕ un segnaposto per dispositivi USB del sistema.
    • In questo passaggio Ŕ necessario individuare le sottochiavi del Registro di sistema che rappresentano i controller Universal Host USB del sistema. Tali controller sono in genere caratterizzati dai numeri a quattro cifre pi¨ bassi.
  3. Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
  4. Nel riquadro dei dettagli digitare ForceHCResetOnResume, quindi premere INVIO.
  5. Fare clic con il pulsante destro del mouse su ForceHCResetOnResume, quindi scegliere Modifica.
  6. Nella finestra di dialogo Modifica valore DWORD, in Base selezionare Decimale.
  7. Nella casella Dati valore digitare 1, quindi scegliere OK.
  8. Chiudere l'editor del Registro di sistema.
  9. Riavviare il computer.

Informazioni sull'hotfix

╚ disponibile un hotfix supportato da Microsoft che Ŕ, tuttavia, destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo pertanto solo nei sistemi in cui si verifica questo specifico problema. ╚ possibile che su questo hotfix vengano eseguite ulteriori verifiche. Tuttavia, se il problema in questione non costituisce una seria minaccia per il sistema, Ŕ consigliabile attendere la pubblicazione del prossimo aggiornamento software contenente tale hotfix.

Se l'aggiornamento Ŕ disponibile per il download, verrÓ indicato nell'apposita sezione all'inizio dell'articolo della Knowledge Base. Se la sezione non viene visualizzata, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix.

Nota Nel caso in cui si verifichino ulteriori problemi o siano necessarie attivitÓ di risoluzione, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft o per creare una richiesta di assistenza separata, visitare il sito Web Microsoft all'indirizzo:
http://support.microsoft.com/contactus/?ln=it&ws=support#tab0
Nota Nel modulo per il download dell'hotfix sono indicate le lingue in cui Ŕ disponibile l'aggiornamento. L'aggiornamento non Ŕ disponibile nelle lingue non incluse nell'elenco.

Prerequisiti

Non Ŕ richiesto alcun prerequisito.

Richiesta di riavvio

╚ necessario riavviare il computer una volta applicato l'hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali hotfix rilasciati in precedenza.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella seguente tabella (o attributi successivi). Date e ore elencate per questi file sono espresse in UTC (Universal Time Coordinated). Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario in Data e ora del Pannello di controllo.
Windows Vista, versioni basate su x86
Riduci questa tabellaEspandi questa tabella
File nameFile versionFile sizeDateTimePlatform
X86_usbvideo.inf_31bf3856ad364e35_6.0.6000.20730_none_2c7edee5d6a32cec.manifestNot Applicable1,48730-Nov-200713:38Not Applicable
Usbvideo.sys6.0.6000.20730133,88830-Nov-200702:28Not Applicable
Windows Vista, versioni a 64 bit
Riduci questa tabellaEspandi questa tabella
File nameFile versionFile sizeDateTimePlatform
Amd64_usbvideo.inf_31bf3856ad364e35_6.0.6000.20730_none_889d7a698f009e22.manifestNot Applicable1,48930-Nov-200713:43Not Applicable
Usbvideo.sys6.0.6000.20730168,44830-Nov-200702:50x64

Verifica della risoluzione del problema

  • Verificare se il problema Ŕ stato risolto. Se il problema Ŕ stato risolto, Ŕ possibile interrompere la lettura di questa sezione. Se il problema persiste, contattare il supporto tecnico.
  • Invio di commenti. Per fornire commenti o segnalare problemi relativi a questa soluzione, lasciare un commento nel blog "Correzione automatica" o inviare un messaggio di posta elettronica.

Status

Microsoft ha confermato che si tratta di un problema riscontrato nei prodotti Microsoft elencati nella sezione "Le informazioni in questo articolo si applicano a".

Informazioni

Per ulteriori informazioni sull'errore irreversibile "0x000000E4", visitare il seguente sito Web Microsoft:
http://msdn2.microsoft.com/en-us/library/ms797141.aspx
Per ulteriori informazioni sull'errore irreversibile "0x0000000A", visitare il seguente sito Web Microsoft:
http://msdn2.microsoft.com/en-us/library/ms793589.aspx
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilitÓ di tali prodotti.

ProprietÓ

Identificativo articolo: 945577 - Ultima modifica: venerdý 30 settembre 2011 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Vista Business N 64-bit Edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Basic N 64-bit Edition
Chiavi:á
kbautohotfix kbvistasp1fix kbexpertisebeginner kbhotfixserver kbqfe kbfixme kbmsifixme KB945577
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com