統合または外付け USB カメラを搭載している Windows Vista ベースのポータブル コンピューターが長時間のサスペンド モードから再開すると、エラーメッセージ "0x000000E4" または "0x0000000A" が表示される

文書翻訳 文書翻訳
文書番号: 945577
すべて展開する | すべて折りたたむ

目次

現象

Windows Vista ベースのポータブル コンピューターを使用している場合、次のような STOP エラー メッセージが表示されることがあります。
STOP: 0x000000E4 (0x00000002, parameter2, parameter3, parameter4)
STOP: 0x0000000A (parameter1, parameter2, parameter3, parameter4)

注意事項
  • STOP エラー メッセージのこれらのパラメーターは、コンピューターの構成および問題の種類によって異なります。
  • STOP エラー "0x000000E4" または "0x0000000A" の原因が、必ずしもこの問題であるとは限りません。
この問題は、次の条件に該当する場合に発生します。
  • USB カメラ デバイスがコンピューターに統合されている、またはデバイスが USB ケーブル経由でコンピューターに接続されている。
  • 長時間のサスペンド モードからコンピューターを再開する。たとえば、コンピューターが 30 分以上サスペンド状態であった。
  • コンピューターの ForceHCResetOnResume レジストリ エントリの値が 0 である。

原因

この現象は、Usbvideo.sys モジュールと Ks.sys モジュールの間のタイミングの問題が原因で発生します。この問題が発生すると、関連する処理項目が呼び出される前に、デバイス オブジェクトが削除されます。

回避策

この問題を回避するには、ForceHCResetOnResume レジストリ エントリの値を 1 に変更します。

ForceHCResetOnResume エントリを追加する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
928631 Windows Vista をスリープ状態または休止状態から再開すると、USB デバイスが正常に動作しないことがある

解決方法

Windows Vista Service Pack の情報

この問題を解決するには、Windows Vista の最新の Service Pack を入手します。詳細については、以下のサポート技術情報番号をクリックしてください。
935791 最新の Windows Vista Service Pack を入手する方法

Windows Vista SP2 および Windows Server 2008 SP2 に含まれる修正プログラムおよびセキュリティ更新プログラム

Windows Vista SP2 および Windows Server 2008 SP2 に含まれる修正プログラムおよびセキュリティ更新プログラムの詳細については、次のマイクロソフト TechNet Web サイトを参照してください。-
http://technet.microsoft.com/ja-jp/library/dd335033.aspx
注: 修正プログラムおよびセキュリティ更新プログラムの一覧の情報は、現在英語でのみ提供されています。

修正プログラムの情報

この修正プログラムを正常に適用するには、ForceHCResetOnResume レジストリ エントリを作成する必要があります。

ForceHCResetOnResume レジストリ エントリを作成するには、「Fix it で解決する」セクションに進んでください。自分でこの問題を解決するには、「自分で解決する」セクションに進んでください。

Fix it で解決する



この問題を自動的に解決するには、[この問題を解決する] ボタンまたはリンクをクリックします。次に、[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、Fix it ウィザードの手順に従います。


この問題を解決する
Microsoft Fix it 50706


注意事項
  • このウィザードは英語版のみである場合があります。しかし、自動的な解決は英語版以外の Windows でも機能します。
  • 問題のあるコンピューターとは別のコンピューターを操作している場合、Fix it ソリューションをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。

次に、「問題が解決されたかどうかの確認」セクションに進んでください。



自分で解決する

これを行うには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに「regedit」と入力し、[OK] をクリックします。
  2. 次のレジストリ サブキーを見つけます。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}\<Four-digit_number>
    注意事項
    • <Four-digit_number> は、システムの USB デバイスを表す 4 桁の番号です。
    • この手順では、システムの USB ユニバーサル ホスト コントローラーを表すレジストリ サブキーを見つける必要があります。通常、USB ユニバーサル ホスト コントローラーは 4 桁の最も小さい番号で表示されます。
  3. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。
  4. 詳細ウィンドウに、「ForceHCResetOnResume」と入力し、Enter キーを押します。
  5. [ForceHCResetOnResume] を右クリックし、[修正] をクリックします。
  6. [DWORD 値の編集] ダイアログ ボックスで、[表記] の下の [10 進] をクリックします。
  7. [値のデータ] ボックスに「1」と入力し、[OK] をクリックします。
  8. レジストリ エディターを終了します。
  9. コンピューターを再起動します。

修正プログラムの情報

マイクロソフトでは、この問題を修正する修正プログラムを提供しています。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、ここで説明する問題が発生しているコンピューターに対してのみ適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことを推奨します。

修正プログラムをダウンロードできる場合は、このサポート技術情報の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。

注: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要になる場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス サポートの電話番号一覧の参照、または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ln=ja&ws=support#tab0
注: 「修正プログラムのダウンロード」フォームには、修正プログラムを入手できる言語が表示されます。使用している言語が表示されない場合は、その言語の修正プログラムは提供されていません。

必要条件

必要条件はありません。

再起動の必要性

この修正プログラムの適用後は、コンピューターを再起動する必要があります。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、以前にリリースされた修正プログラムが置き換えられることはありません。

ファイル情報

修正プログラム (英語版) のファイル属性 (または後のファイル属性) は次の表のとおりです。これらのファイルの日付と時刻は世界協定時刻 (UTC) で記載されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
Windows Vista (x86 ベース)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatform
X86_usbvideo.inf_31bf3856ad364e35_6.0.6000.20730_none_2c7edee5d6a32cec.manifestNot Applicable1,48730-Nov-200713:38Not Applicable
Usbvideo.sys6.0.6000.20730133,88830-Nov-200702:28Not Applicable
Windows Vista (64 ビット版)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatform
Amd64_usbvideo.inf_31bf3856ad364e35_6.0.6000.20730_none_889d7a698f009e22.manifestNot Applicable1,48930-Nov-200713:43Not Applicable
Usbvideo.sys6.0.6000.20730168,44830-Nov-200702:50x64

問題が解決されたかどうかの確認

  • 問題が解決されたかどうかを確認します。問題が解決された場合、このセクションの作業は完了していることになります。問題が解決されていない場合は、サポートに問い合わせることができます。
  • マイクロソフトではフィードバックをお待ちしております。この解決方法に関するフィードバックを提供する、または問題を報告するには、"Fix it for me" ブログ (英語) にコメントを記入するか、電子メール メッセージ (日本語可) を送信してください。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

"0x000000E4" STOP エラーの詳細については、以下のマイクロソフト Web サイトを参照してください。
http://msdn.microsoft.com/ja-jp/library/ms797141.aspx
"0x0000000A" STOP エラーの詳細については、以下のマイクロソフト Web サイトを参照してください。
http://msdn.microsoft.com/ja-jp/library/ms793589.aspx
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

プロパティ

文書番号: 945577 - 最終更新日: 2011年9月30日 - リビジョン: 4.0
キーワード:?
kbqfe kbexpertisebeginner kbhotfixserver kbautohotfix kbvistasp1fix kbfixme kbmsifixme KB945577
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com